1. sagec's Avatar
    tl;dr version: Disable Wireless N on your router. Set to G only, or B/G only.

    After upgrading to OS 1.0.8, my wifi connection would die after a few minutes and I had to continuously reset the connection by disabling wifi on the playbook and re-enabling it. All v1.0.7 OS builds were rock solid.

    I tried all the suggestions published thus far, but none actually improved the situation.

    What finally did the trick was to change my router's basic wireless setting called "Wireless Mode" from "Mixed" to "Wireless-G only". I have 10 wireless devices connected to my Linksys E1000 router and not one of them has an issue, except the playbook.

    I've tested setting it back to mixed, and the same issue returns. This really sucks, since 9 of my devices are wireless N, including the playbook.

    I have the exact same symptoms with OS 1.0.8, and OS 2.0 Beta 1 and Beta 2.

    Posted from my Playbook at wapforums.crackberry.com
    Last edited by sagec; 11-26-11 at 09:03 AM.
    flash24, T.roy, drakewn and 5 others like this.
    11-25-11 04:18 PM
  2. js8229's Avatar
    Yep, changed my router from b/g/n to b/g and it cleared up. Browsing is much faster and no dropped connections. I don't think I'll miss much without 802.11n, but I'd rather not have to make that call for one device.
    11-25-11 04:33 PM
  3. fastartcee's Avatar
    Yesterday, after the update, my wireless connection seemed faster & more stable, but not today. Mostly, it's okay, but I'm back to 'network error' messages when I try to go to some sites; a second or third connection attempt works for those sites. Occasionally the browser just hangs when trying to access a site, with no error message. I sometimes have to restart the browser to make a connection.

    My signal strength shows 4 'bars', the max. If anything, the strength seems greater since the update.

    I just checked my wi-fi information: 11 Mbps ; wireless G. This is confusing, because my D-Link router is set to 'N only'! What could be the explanation?
    11-25-11 05:03 PM
  4. sagec's Avatar
    Yesterday, after the update, my wireless connection seemed faster & more stable, but not today. Mostly, it's okay, but I'm back to 'network error' messages when I try to go to some sites; a second or third connection attempt works for those sites. Occasionally the browser just hangs when trying to access a site, with no error message. I sometimes have to restart the browser to make a connection.

    My signal strength shows 4 'bars', the max. If anything, the strength seems greater since the update.

    I just checked my wi-fi information: 11 Mbps ; wireless G. This is confusing, because my D-Link router is set to 'N only'! What could be the explanation?
    Try switching your router to G or B/G only. I think the explanation is that the Playbook has serious issues with Wireless N.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-25-11 05:16 PM
  5. flash24's Avatar
    Thanks, haven't had any issues since changing it.
    11-25-11 07:02 PM
  6. sagec's Avatar
    Glad to help. :-)

    Posted from my CrackBerry at wapforums.crackberry.com
    11-26-11 08:50 AM
  7. anindoc's Avatar
    I had the same problem as the OP described at the outset. I finally did a restart of my PB (not soft or hard reset), and since then its been rock solid. I have a brand new Cisco router and with OS1.0.7 there was no problem. I am hopeful I wont have to mess with the router settings just yet, but thanks OP for the heads up...
    11-26-11 09:03 AM
  8. jvictor77's Avatar
    This change worked for me as well - no drops since last night!
    11-26-11 09:54 AM
  9. T.roy's Avatar
    So i decided to give the new beta a test drive last night. Almost immediately I started getting network errors even though I showed full signal strength; I had to cycle the wifi on/off on the playbook. I was playing around in the router(cisco valet m10) settings when I saw your tip. Switched from mixed mode to a wireless g only setting and the pb hasn't dropped the wifi since. Thanks for the tip.
    11-26-11 10:05 AM
  10. kbz1960's Avatar
    Yesterday, after the update, my wireless connection seemed faster & more stable, but not today. Mostly, it's okay, but I'm back to 'network error' messages when I try to go to some sites; a second or third connection attempt works for those sites. Occasionally the browser just hangs when trying to access a site, with no error message. I sometimes have to restart the browser to make a connection.

    My signal strength shows 4 'bars', the max. If anything, the strength seems greater since the update.

    I just checked my wi-fi information: 11 Mbps ; wireless G. This is confusing, because my D-Link router is set to 'N only'! What could be the explanation?
    The playbook reports it wrong.

    Unless people have internet that is faster then 24mbps n does nothing for internet. For a home network yes n is faster to transfer files etc. between home computers but it doesn't make the internet faster unless your internet supplies speeds above 24mbps.
    erhan8 likes this.
    11-26-11 10:44 AM
  11. kbz1960's Avatar
    So i decided to give the new beta a test drive last night. Almost immediately I started getting network errors even though I showed full signal strength; I had to cycle the wifi on/off on the playbook. I was playing around in the router(cisco valet m10) settings when I saw your tip. Switched from mixed mode to a wireless g only setting and the pb hasn't dropped the wifi since. Thanks for the tip.
    I went to the beta right before I saw the other update. No problem what so ever with wifi and it seems even better. Have the cheapest linksys router WRT120N.
    11-26-11 10:48 AM
  12. TgeekB's Avatar
    Worked so far. Thanks for the solution.
    11-26-11 11:36 AM
  13. Jake2826's Avatar
    Thanks for the post.
    11-26-11 12:08 PM
  14. drakewn's Avatar
    WOW!! Amazing! Sagec: You are SMART! My PB has never been faster!

    Then I tried browsing with my old Storm2, and as crazy as it seems, it is way faster now too. I didn't ever think it could be faster.

    Thank You.
    11-26-11 12:29 PM
  15. Spencerdl's Avatar
    Thanks, haven't had any issues since changing it.
    +1 NO issues here either, working as it should.
    angellsl likes this.
    11-26-11 12:44 PM
  16. anon(3896606)'s Avatar
    tl;dr version: Disable Wireless N on your router. Set to G only, or B/G only.

    After upgrading to OS 1.0.8, my wifi connection would die after a few minutes and I had to continuously reset the connection by disabling wifi on the playbook and re-enabling it. All v1.0.7 OS builds were rock solid.

    I tried all the suggestions published thus far, but none actually improved the situation.

    What finally did the trick was to change my router's basic wireless setting called "Wireless Mode" from "Mixed" to "Wireless-G only". I have 10 wireless devices connected to my Linksys E1000 router and not one of them has an issue, except the playbook.

    I've tested setting it back to mixed, and the same issue returns. This really sucks, since 9 of my devices are wireless N, including the playbook.

    I have the exact same symptoms with OS 1.0.8, and OS 2.0 Beta 1 and Beta 2.

    Posted from my Playbook at wapforums.crackberry.com
    First off, the beta's won't help at all.
    They have a really bad connection, however the latest update should have fixed the WI-FI drivers. Weird...
    11-26-11 01:12 PM
  17. st_ursus's Avatar
    Thanks for the solution.

    Switching to (g only) solved the problem.

    Wifi was so unreliable that purchases through App World was spotty, I could not rely on a purchase going through.
    11-26-11 01:13 PM
  18. FF22's Avatar
    I gather that this could be a problem at other wifi locations, like hotels, coffee shops, etc where the user cannot tweak the router. I've had a few problems at airports and at a hotel in Estes Park.
    11-26-11 01:29 PM
  19. king benny's Avatar
    I can confirm that changing the network mode to G only resolved my wifi dropouts for both my playbooks. An alternative solution (discovered in the other wifi thread in the PB OS section) is downgrading the security from WPA2 AES encryption to WPA TKIP.

    My test results on 2 tablets experiencing the same issues (one with OS2 beta and the other on 1.08):

    Network mode: G only
    Security: WPA2 with AES
    SUCCESS

    Network mode: Mixed (B/G/N)
    Security: WPA2 with AES
    FAIL (dropouts)

    Network mode: Mixed (B/G/N)
    Security WPA with AES
    FAIL (dropouts)

    Network mode: Mixed (B/G/N)
    Security WPA with TKIP
    SUCCESS

    So for me, N network mode and AES encryption are causing problems for the playbook but disabling one of them resolves the issue.
    11-26-11 02:14 PM
  20. erhan8's Avatar
    Setting my router to "g" only has given my browser new life. Speed is lightning fast and connection, rock solid. Again, as F2 mentioned this is a solution for home use. What will we encounter in the wild? Not all routers are built or setup the same.
    11-26-11 02:53 PM
  21. js8229's Avatar
    For the most part, I'm not seeing too many "hotspot" routers w/"n" available (places like starbucks, hotels, etc.) but in the future it most likely will be, and probably turned on by default like newer home routers.

    I can only hope this issue will be fixed by then, and it should be since it's very reproducible with this update on the PB.
    11-26-11 04:24 PM
  22. angellsl's Avatar
    g only solved my problem. thanks a lot
    11-26-11 08:32 PM
  23. smiley786's Avatar
    Can you tell me how to change my wireless settings?
    I have also recently updated and facing wifi issues, my playbook says that the network type is 802.11g so i don't understand what is going on, also my router isnt set up ln my computer it is just turned on as the computer it was set up on has been thrown away.
    11-27-11 07:51 PM
  24. PoohBear24's Avatar
    None of these responses has addressed my issue. I have 2 wireless routers, one for upstairs and one for downstairs. My problem is the BB Playbook keeps disabling the upstairs one and can't connect to the downstairs because of interference issues. That's why I have two. All other devices including an android tablet and laptop work fine on the upstairs.
    But on the playbook it will work when I get it reset for a while and then disable the upstairs one again. It literally shows the device has been disabled in the settings. Can someone tell me why?
    Last edited by PoohBear24; 06-08-12 at 04:58 PM.
    06-08-12 04:56 PM
  25. space_traveler's Avatar
    Nope, doesn't work for me. I tried this months ago and since then it still drops and sometimes won't even connect to begin with. Other times everything works great, stream video for hours and all that with no issues. But then I only have a Netgear wireless G router, can only select B & G or G alone, neither fixes the drops I get occasionally.
    06-08-12 05:06 PM
LINK TO POST COPIED TO CLIPBOARD