04-03-13 12:23 AM
32 12
tools
  1. OS2GUY's Avatar
    Hi everyone,

    I've been searching the PlayBook forum for about an hour. I remember seeing a thread (or threads) about this but cannot, for the life of me, find it (or them) now. I am obviously doing something wrong. If you can point me to the relevent thread, then by all means... If memory serves me well, there were recommendations regarding the router and modifications that could be made on it to alleviate the problem. Again, I just can't find the thread...

    I have had this problem from the start: My PlayBook will not stay connected to the house's Wi-Fi while in sleep mode. When I take it out of sleep mode, The Wi-Fi has disconnected and I must, every single time, go through the manual process of reconnecting manually. To be honnest, because of that, I find myself using it less and less. I have another tablet (Nexus 7) and it does not do that.

    I like my PlayBook a lot. In some aspect, it is way better than the Nexus 7, but that Wi-Fi thing is wearing my patience thinner and thinner. I'm almost at the point where I won't touch it because I know I'll have to reconnect to the network before doing any kind of work. Please Help!

    The PlayBook is the 16GB model and is running the latest OS (2.1.0.1526). The router I'm using is an older one. It is a Linksys WRT54GP2. If a change of router is the way to go (a PlayBook friendly one) I would gladly accept suggestions.

    Thanks for your time!
    03-03-13 02:47 PM
  2. FF22's Avatar
    I don't have any links. But what Security settings do you use on the router? I'm using wpa2 Personal. Some folks suggest changing the Channels the router uses. What model router do you have and how old is it? Does it have the latest router firmware?

    I also have set up a static address for the pb so that it does not change on computer or router reboot/resets.

    Let's see if others can help.
    03-03-13 03:10 PM
  3. kbz1960's Avatar
    I've never had that issue with mine. My router settings are

    Wi-fi is always off when coming out of sleep-wireless.png

    Wi-fi is always off when coming out of sleep-wireless1.png
    03-03-13 03:44 PM
  4. dangerousfen's Avatar
    I've never had the issue either. Unlike F2, I don't bother with a static IP address, I let the DHCP take care of the address and it always works flawlessly. Have you tried rebooting your router recently?
    03-03-13 04:51 PM
  5. OS2GUY's Avatar
    Hi F2,

    I'm using "WPA Pre-Shared key" which is the highest security option available on this router. Yes it is quite a few years old. Don't know exactly how many, but I'd say at the very least five... Model is Linksys WRT54GP2. As for the firmware update, there is one available but I was never able to install it. I believe there is a well known "bug" about that particular issue...

    Now you mention giving the PlayBook a static address. I believe that was what the thread I remember reading a long time ago suggested. I think I would like to try that. I not too sure how to go about it though. Networking isn't my forte...

    I'll see what other might suggest, but that is definately something I'd like to try.

    Thanks,
    03-03-13 06:13 PM
  6. OS2GUY's Avatar
    Hi KBZ1960,

    Your router configuration screens are quite different than mine. And much newer as it support the "N" protocol. As far as I can tell though, there doesn't seem to be that much difference in the configuration. You have WPA2 as I have only WPA. Channel is set to AUTO. On mine, there is no option for AUTO. Channel is set to 11.

    Do you think these differences might be the cause?

    Thanks,
    03-03-13 06:45 PM
  7. OS2GUY's Avatar
    Hi dangerousfen,

    I do have to reboot from time to time. I have an issue with my phone (LG Optimus L7). When I let the battery run off, the phone shuts down. When I recharge it, the phone, sometimes, will not connect to the Wi-Fi. I have to reboot the router for the phone to reconnect to the Wi-Fi. That is an issue with the phone only and only when it shuts down due to the battery running empty.

    To answer your question: Yes! I did reboot it 5 or 6 days ago (phone batteries running empty). Rebooting the router has never been any help. As I said, I've had this problem from the start. I bought the PlayBook in November of 2011.

    Come to think of it, for about a year, I used a different router (a modem/router) that was given to me by my ISP while I was using DSL (now I'm on cable). The same issue was present. The PlayBook just won't stay connected during sleep...

    Thanks,
    03-03-13 07:06 PM
  8. FF22's Avatar
    Here's what I've captured on creating a static address on the pb (apparently, there's a way to do it on routers but like you, I'm not an expert)

    Fixed or Static address

    If you go to 'Wi-Fi' on your PlayBook and select 'Saved Networks' under 'Select a network', edit your wireless network and uncheck 'Automatically obtain IP address'... there you can set a static address for your PlayBook to use.

    Your typical settings will be:

    IP Address: 192.168.X.X (this will be your local network... if your linksys sits on 192.168.1.X then your IP can be anything between 192.168.1.1 - 192.168.1.254... obviously it can't be the same IP as your linksys or any active device on the network)
    Subnet mask: 255.255.255.0
    Primary DNS: (I use OpenDNS) 208.67.222.222
    Secondary: 208.67.220.220
    Default gateway: 192.168.X.X (the IP you use to access the linksys page)
    03-03-13 07:10 PM
  9. kbz1960's Avatar
    Hi KBZ1960,

    Your router configuration screens are quite different than mine. And much newer as it support the "N" protocol. As far as I can tell though, there doesn't seem to be that much difference in the configuration. You have WPA2 as I have only WPA. Channel is set to AUTO. On mine, there is no option for AUTO. Channel is set to 11.

    Do you think these differences might be the cause?

    Thanks,
    You can download a program inSSIDer – Discover The Wi-Fi Around You | MetaGeek to see if there are a lot of other networks using the same channel and then change the channel in your router if there are.
    03-03-13 07:28 PM
  10. OS2GUY's Avatar
    Hi Eniygma,

    Yes! My home network is being saved. Less painful than what you had to go through, but still is a pain!

    I'm using the French version of the OS so I'm not too sure of the English wording. Taping the icon and then tapping the icon again in the small window. Then tapping the network's name. Then "save and connect". It then goes to another screen where it's trying to connect. sometimes, it will connect on the first try, sometimes not. Sometimes, It tries 3 times and stops trying. I have to go back and get it to try again. Simply a pain the ***.

    I should have pointed out that the PlayBook is less than 5 feet away from the router. They both "see" themselves...

    Thanks,
    03-03-13 09:08 PM
  11. OS2GUY's Avatar
    Hi again F2,

    I've tried what you suggest and it is working. On this router, IP addresses range from 192.168.15.100 to 192.168.15.149. So there is an available range of 50 addresses. As I understand it, it can be expanded. I don't think I should though as I have only 5 Wi-Fi devices in the house.

    One question: Should I be worried about another Wi-Fi device trying to obtain the address I gave the PlayBook (192.168.15.149) ? Should I give all Wi-Fi devices static IP addresses so they don't conflict with one another?

    Thanks,
    03-03-13 09:16 PM
  12. kbz1960's Avatar
    You can reserve in your routers page. Mine is in LAN setup.

    Wi-fi is always off when coming out of sleep-wireless.png
    03-03-13 09:29 PM
  13. FF22's Avatar
    I have a bunch of stuff connected to my router via wifi and the fact that the pb (and I used the same info other than the last digits for my bbphone's wifi) and my bb phone have a static address has not adversely affected any other wifi device.

    And, having a static address for your SAVED_HOME_ROUTER will NOT affect your pb if you go to a cafe or library with wifi. The static address only pertains to your home router.
    03-03-13 09:35 PM
  14. tmvqpbvu's Avatar
    it does not change on computer or router reboot
    03-03-13 09:49 PM
  15. OS2GUY's Avatar
    Hi kbz1960,

    That is a nice piece of software. I installed it on the Nexus 7 and it is telling me that most channels used around here are 1, 2, 3 and 11. My own router was on 11. I changed it to 5.

    We'll see if that helps.

    Thanks a lot,
    kbz1960 likes this.
    03-03-13 10:27 PM
  16. OS2GUY's Avatar
    Hi kbz1960, F2 and tmvqpbvu,

    Thanks for the advice. I'll run the setup like so (Static IP and on channel 5) and we'll see in a couple of days.

    Thanks to all who wrote in,
    kbz1960 likes this.
    03-03-13 10:34 PM
  17. kill_9's Avatar
    Delete the current WiFi profile and create the profile after performing a hard reboot.

    Posted via CB10 on the BlackBerry Z10
    03-04-13 12:00 PM
  18. OS2GUY's Avatar
    Hi folks,

    I've been using the PlayBook with a static IP and the router on channel 5 for the past four days. Although it is not perfect, it is much, much better. I'd say that the Wi-Fi is on, when coming out of sleep, about half the time. Basically, that is a 50% improvement. I am extremely happy. That is not to say that I wouldn't welcome a 100% improvement...

    I'll try what kill_9 suggest and report in a few days time.

    Thanks to all who wrote in.
    03-07-13 11:36 PM
  19. FF22's Avatar
    50% is better. (knock on wood) - I've never had an issue with the router at home.
    03-08-13 12:24 AM
  20. OS2GUY's Avatar
    Hi everyone,

    I've been running the PlayBook for about a week after doing what kill_9 suggested. A deletion and a creation of my profile after a hard reboot. Unfortunately, things did not improve. I'm still in a much better situation as Wi-Fi stays connected from time to time.

    I'm starting to wonder if Wi-Fi disconnects only after extended periods of non use. That is, if I pick it up after a couple of hours in sleep mode, chances are Wi-Fi will be on. If I pick it up, say the next day, Wi-Fi is most certainly off.

    If someone has an idea, I'm all ears...

    P.S.: Silly question: A hard reboot is the same as a hard reset, right?
    03-16-13 02:59 PM
  21. FF22's Avatar
    Might be the computer/router combination. I am not a wifi or network guru by any means. I do know that sometimes the ip address assignments can change. Might be a setting for the router to go to sleep or turn off stuff if it is not used for a while.

    Views vary on what's what with reset/reboot

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.
    03-16-13 03:58 PM
  22. OS2GUY's Avatar
    Hi F2,

    Thanks for a speedy response. I think you are suggesting 3 things. 3 types of "restarts"...

    Restart using the Battery Icon and press Restart
    This I've done many times and does not help

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.
    This I just tried and it simply shuts down. It does not restart by itself... Should it have restarted by itself?

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.
    This I tried last week as per kill_9 suggestion. It did not solve the issue.

    Am I understanding your comments correctly? I am French speaking and not perfectly bilingual... Sometimes, I do miss the finer points.

    Thanks again for your time!
    03-16-13 05:27 PM
  23. FF22's Avatar
    If you HOLD the Power Button in for 15 - 20 seconds, maybe a bit more, it will turn off and should eventually restart. At least, it the pb locks up (stalls or won't response but the screen is ON) the HOLD should cause it to actually restart.

    And you are doing quite well with the Mono-ligual American!!! (embarrassed but it's too late for me)
    03-16-13 06:48 PM
  24. OS2GUY's Avatar
    Hi again F2,

    I tried what you suggested. I deleted my profile and then rebooted (I did have to hold it for a few seconds more for it to reboot- I think it was more like 25 seconds). I then recreated the profile. Unfortunately, that did not fix the issue.

    To recap: I've deleted my profile and created it again after a regular shut down with no luck. Then again after a hard reset with still no luck. Finally after a hard reboot and still no luck...

    Could the Wi-Fi hardware of the PlayBook be defective?

    My brother has a PlayBook identical to mine. I wonder if he would lend it to me for a few days or a week. I could see if his tablet is behaving like mine on my network. Let's hope he doesn't have any incriminating stuff on his PlayBook...

    Thanks F2 and to all,
    03-23-13 01:10 PM
  25. OS2GUY's Avatar
    Hi,

    It's me again. I've been wondering about this for a while... Could there be some hidden setting that would shut down Wi-Fi after a period of non use? I'm thinking of something like a battery setting that might want to extend battery life by shutting down Bluetooth, Wi-Fi and the like...

    I've looked up and down the PlayBook for such a feature, but don't see one. What do you think?

    Thanks a bunch,
    03-23-13 03:22 PM
32 12

Similar Threads

  1. Wi-fi Radio always off
    By nbillo in forum BlackBerry Torch 9860/9850
    Replies: 3
    Last Post: 12-04-14, 02:36 PM
  2. My 8330 Lags when coming out of "sleep mode"
    By jsawyers in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 06-24-09, 03:15 PM
  3. My 8330 Lags when coming out of "sleep mode"
    By jsawyers in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 06-24-09, 03:15 PM
  4. Ringtone turning off when taken out of the holster
    By andyp in forum BlackBerry Bold 9000
    Replies: 4
    Last Post: 11-13-08, 08:11 PM
  5. can i stop msg from auto-opening when coming out of sleep?
    By stang8s in forum BlackBerry Curve 83xx
    Replies: 1
    Last Post: 09-10-08, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD