1. slparry's Avatar
    I have 2 playbooks, my first, bought last September is fine, charges quickly.

    How ever my recently purchased one has taken two days and it's still only reached 95%, this is on an OEM Playbook dock (which I understand contains the fast charger?)

    I've held off returning it to see if it's "ok" once fully charged, but what's the group opinion? Duff battery .... or will it "condition" itself?
    04-24-13 04:42 AM
  2. Wongsky's Avatar
    Maybe worth installing one of the battery utils / apps, and see what it says?

    Otherwise, maybe running it for a while and let the battery discharge a bit then putting it on charge again?

    I wouldn't labour with it too long, though, sounds like you've only just bought it - might be worth giving BlackBerry "tech" support a ring, then if it's not something they can easily solve, it'd probably be replaced?
    slparry likes this.
    04-24-13 05:04 AM
  3. slparry's Avatar
    Maybe worth installing one of the battery utils / apps, and see what it says?

    Otherwise, maybe running it for a while and let the battery discharge a bit then putting it on charge again?

    I wouldn't labour with it too long, though, sounds like you've only just bought it - might be worth giving BlackBerry "tech" support a ring, then if it's not something they can easily solve, it'd probably be replaced?
    Thanks, that was my feeling. I'll give it until after the weekend, then I can let it charge/discharge/charge ... if there's no improvement then I'll sort support or return it.
    04-24-13 05:41 AM
  4. taz323's Avatar
    I also have the base charger and it's very temperamental when charging, some days it charges great others very slow. And I know it has something to do with the pins. Best charger I've seen is the 3 pin travel charger, it's never let me down.
    04-24-13 08:33 AM
  5. Wongsky's Avatar
    I also have the base charger and it's very temperamental when charging, some days it charges great others very slow. And I know it has something to do with the pins. Best charger I've seen is the 3 pin travel charger, it's never let me down.
    The charging stand should be just as good as the "rapid" charger, really. I have read the pins can sometimes stick, too - just give them a wiggle with a toothpick to make sure they're still springing OK.

    Although I've got a charging stand, it's a once-in-a-blue-moon thing for me to use it, I use the "rapid" chargers with my PlayBooks normally, because they normally stay in their cases.
    04-24-13 09:08 AM
  6. Gooseberry Falls's Avatar
    I also have the base charger and it's very temperamental when charging, some days it charges great others very slow. And I know it has something to do with the pins. Best charger I've seen is the 3 pin travel charger, it's never let me down.
    I got the base charger just because it was cheap on clearance. I can only use it when my PB is naked, which isn't very often. I had to reposition it several times before I could get the charging to occur. With the travel rapid charger I can click it on in the dark.
    04-24-13 03:05 PM
  7. taz323's Avatar
    I got the base charger just because it was cheap on clearance. I can only use it when my PB is naked, which isn't very often. I had to reposition it several times before I could get the charging to occur. With the travel rapid charger I can click it on in the dark.
    Charge works the best, and you don't have to take it out of most case.
    04-24-13 03:24 PM

Similar Threads

  1. BB Link won't connect my phone and laptop
    By John Scholz1 in forum BlackBerry Link
    Replies: 5
    Last Post: 09-03-13, 01:01 AM
  2. Snapchat video working on z10 stl100-1 with 10.2.0.1047
    By mike260193 in forum BB10 Android App Sideloading
    Replies: 8
    Last Post: 09-02-13, 09:02 PM
  3. Fidme on Q10
    By chadt5382 in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 09-02-13, 09:59 AM
  4. Do I need 10.2 for a vine sideload to work? I'm on 10.1 with no luck.
    By maclaskey in forum BB10 Android App Sideloading
    Replies: 6
    Last Post: 08-29-13, 07:43 AM
  5. Unable to insert images into HTML app for PlayBook
    By steph_briere in forum Developers Lounge
    Replies: 3
    Last Post: 08-28-13, 04:18 PM
LINK TO POST COPIED TO CLIPBOARD