<a href="http://bbmobile.me/CBKEY2BLtopic?utm_source=cb&amp;utm_medium=topicblock&amp;utm_campaign=navigation" target="_blank">Shop BlackBerry KEY2</a>
  1. Jonathan-Archer's Avatar
    So I suppose many people had this problem before. There's a huge and frequent lag in typing an url in the browser adress bar. I'm baffled as to why this problem hasn't been solved with the coming of 2.1. I surely must not be the only one still having this isse.
    10-16-12 04:23 PM
  2. Bold_until_Hybrid_Comes's Avatar
    i dont like the lag when you click on a key it makes the keystroke noise then a duplicate of the key above that key stays there for a second then the key noise again really quick and repeating for a brief moment
    10-16-12 04:36 PM
  3. easydoesit99's Avatar
    +1 Very annoying.
    10-16-12 04:39 PM
  4. Dr.Deebs's Avatar
    Turning off the predictive keyboard solved this on my wife's PB, not that anyone should have to do that. Mine has never had the lag thankfully.
    10-16-12 04:55 PM
  5. ralfyguy's Avatar
    I see that as well at times. But what is more annoying to me is when you first start the browser and you go to type something in the address bar, it won't accept amy typing even though the keyboard is up and all. You have to cancel and then try again.
    10-16-12 05:29 PM
  6. tarektoverso's Avatar
    Have the same issue here. especially when I use the Search field. I have to click on the backwards button more than 15 seconds to delete one word. quite annoying.
    10-19-12 09:07 AM
  7. pinkert11's Avatar
    I had this in the beta and I was really hoping that it would be fixed when 2.1 was released in to the wild, however it is still there. I do notice that on a fresh start of the browser there seems little to no lag, but after a little browsing it gets very laggey to the point I close and re-open the browser.
    10-19-12 09:16 AM
  8. BerryClever's Avatar
    I get that problem with Google really really bad. Bing is a bit better with the lag, but there is still some there. Like Dr. Deebs suggested, turning off predictive text really helps with the search engines. As for the address bar, I haven't really noticed too much lag there... but maybe it is because I compared it with Google's search engine.
    Vanderchoac likes this.
    10-19-12 09:50 AM
  9. Tha.Housewife's Avatar
    all that browser madness went away now that I deleted alllll android apps. stuff running in the backgroud (much like a pc) was devouring memory and laggin up the pb browser.. now...no probs...werking beautifully
    10-19-12 10:37 AM
  10. Tha.Housewife's Avatar
    has anyone noticed that everyones having the same issues now two weeks after the 2.1 launch. 2 weeks of android players apps running silently in the backgroud is just now really starting to show....I think sometjing sililar happend in earlier pb versions with the old android player..
    10-19-12 10:57 AM
  11. daglesj's Avatar
    It's a bit of a shame that RIM doesn't react to updates like most other firms. Usually you get a big update and then a minor bug fix a few days/weeks after the event to tidy things up. Or at least you get sme feedback saying.."yes guys we know, we are investigating, watch this space!"

    But not RIM.

    I guess we'll have to wait for BB10 which will be a whole new ball game with a whole raft of new bugs to get fixed. To be honest I would prefer them to keep two separate streams going. The BB10 OS stream and keep refining the current OS as well. I think I know which I'd rather stick with for now.
    10-19-12 11:34 AM
  12. dave1701's Avatar
    yup, #1 annoyance with my playbook now.
    10-19-12 03:47 PM
  13. Tha.Housewife's Avatar
    lol watch,its probably gonna be sometbing like flashisnt up to date. I noticed flash 11.2 is out but we only have 11.1. wish we could update it ourselves..
    10-19-12 07:54 PM
  14. III 4U2NV III's Avatar
    +100, very annoying. Or how about when you type in the search box of Google and you try to click on the predictive selections but the selection text appears instead. Ugh
    Tha.Housewife likes this.
    10-19-12 08:04 PM
  15. Tha.Housewife's Avatar
    lol, I already know... even on a fresh os install..lol
    10-19-12 08:08 PM
  16. twstd.reality's Avatar
    mine used to be like that too, but not only in the browser - was very annoying. sometimes the keyboard would just freeze for a couple seconds after the pop up key. did a full wipe and re-installed the OS and everything's all good now. also changed the default keyboard to qwerty. I think if you force the OS to not have to decide (like preductions and what not) it's less laggy.
    10-19-12 08:22 PM
  17. Hyper-active's Avatar
    The type lag is driving me insane! Lol ^^ Just writing this message is agonising on my playbook. Need to wait years to see the text come up. I actually started writing this comment last year!
    FF22 likes this.
    10-20-12 08:45 AM
  18. kbz1960's Avatar
    Well you all could help by joining the beta zone and doing as they are asking.

    Hello,

    A new post has been added to the "BlackBerry PlayBook OS 2.1 Update Now Available" message thread.

    Hi folks!

    I have a team ready to investigate any problems we're seeing with a sluggish UI or with a slow or crashing Browser.

    If you're having problems with the device being slow to respond, or with the browser sometimes lagging or outright crashing, we can take a look. For now, we're going to stick to these types of issues, and we can go from there.

    Let's follow this process immediately after the issue occurs:

    1) Open the Help app
    2) Swipe down from the top bezel
    3) Tap Support
    4) Tap Log Submission
    5) Enter any email address (doesn't have to be real)
    6) Enter "12345678" at the end of INC0000 in the Incident # field
    7) Tap Create (if prompted, tap Send)
    8) Connect your device to the computer and find the *.pb log file stored on the PlayBook in the folder /documents/logs
    9) Send the .pb file to me directly, along with as many details as possible (you can never have too many details), at john@rim.com. Be sure to include what actions/steps you took to cause the problem, what website/app you were using, what PlayBook OS build you're running, etc.

    (If you used your own email address, you may receive a failure email - ignore this.)

    Note that the content of your log files and your submission email are protected by the Terms and Conditions of BlackBerry Beta Zone and will be kept private. I may not be able to respond with details of what we found, if anything, but do know that I'll send every log file to the development team for their review. We really want to make sure your experience with the UI and Browser is rock solid.

    Thanks!

    John
    Mr Donut and twstd.reality like this.
    10-20-12 09:46 AM
  19. bbqkid8's Avatar
    I noticed this lag before the 2.1 release and it went away every time I cleared the web cache and browsing history. So now I just surf in private mode, but only after keeping my login credentials for a few sites. Haven't had lag in the url bar since...
    playbookpa likes this.
    10-20-12 09:56 AM
  20. k__dam's Avatar
    Off topic but do you guys know how to open a new tab in the browser but don't have it switch to the new tab?

    If that's not possible which browser can do that?
    10-20-12 10:57 AM
  21. tarektoverso's Avatar
    I have found a way to fix this problem. You have to deactivate the Java script on your browser. Now the typing/editing is very smooth.

    Hope this will help.
    garlee likes this.
    10-22-12 12:17 PM
  22. zorecati's Avatar
    I get some lag when using search engines as it's trying to search as I type, but I have not noticed it typing in a URL.
    10-22-12 12:33 PM
  23. playbookpa's Avatar
    I noticed this lag before the 2.1 release and it went away every time I cleared the web cache and browsing history. So now I just surf in private mode, but only after keeping my login credentials for a few sites. Haven't had lag in the url bar since...
    THANKS!!! That's THE BEST tip I've found on this subject, tried and it really works very well here, with predictive text on by the way!

    No more lag, even CrackBerry is loading better now, can't say if related or in my head ;-)
    10-22-12 11:32 PM
  24. playbookpa's Avatar
    I noticed this lag before the 2.1 release and it went away every time I cleared the web cache and browsing history. So now I just surf in private mode, but only after keeping my login credentials for a few sites. Haven't had lag in the url bar since...
    THANKS!!! That's THE BEST tip I've found on this subject, tried and it really works very well here, with predictive text on by the way!

    No more lag, even CrackBerry is loading better now, can't say if related or in my head ;-)

    Seriously, for keyboard lag, it's really magical, try it just 5 min.!
    Last edited by playbookpa; 10-22-12 at 11:46 PM.
    10-22-12 11:33 PM
  25. symbotier's Avatar
    I noticed this lag before the 2.1 release and it went away every time I cleared the web cache and browsing history. So now I just surf in private mode, but only after keeping my login credentials for a few sites. Haven't had lag in the url bar since...
    This solution also seems to have worked for me too! Thanks. I have a 64GB Playbook that I bought soon after launch and I have had a lot of keyboard lag for several months (can't remember which update started it). My wife never had a problem with her newer 32 GB model. But with these settings typing is no longer quite so frustrating and I have the word prediction turned on again!
    01-28-13 06:59 PM

Similar Threads

  1. Why is there STILL typing lag in every OS?
    By jetman1287 in forum Storm OS Discussion
    Replies: 9
    Last Post: 06-15-10, 09:12 AM
  2. Which OS would you say has the least typing lag in the browser?
    By zazzified in forum Storm OS Discussion
    Replies: 5
    Last Post: 05-04-09, 10:58 PM
  3. Typing passwords in browser
    By dmarcus48 in forum BlackBerry Bold 9000
    Replies: 6
    Last Post: 01-19-09, 08:08 PM
  4. Keyboard Lag in Browser - .75
    By atylr92 in forum Storm OS Discussion
    Replies: 5
    Last Post: 12-25-08, 01:47 AM
  5. Typing lag in browser only?
    By Yesterdays Shoveler in forum BlackBerry Storm
    Replies: 7
    Last Post: 12-18-08, 02:03 PM
LINK TO POST COPIED TO CLIPBOARD