1. euphemy's Avatar
    Yesterday, it was at 7%. I tried charging it on the dock, would not recognize it. Today I tried a different outlet as it was off and for 6 hours, it acted like it was charging. (flashing green light) Tried turning it on, and it won't come on at all. I think it discharged instead of charging. I've tried numerous outlets. Nothing. It won't recognize any of the chargers.

    Posted via CB10
    10-27-13 04:50 PM
  2. qbnkelt's Avatar
    I'm sorry you're having this problem. I looked for this for you....I hope it helps.

    http://forums.crackberry.com/blackbe...charge-748416/
    10-27-13 07:47 PM
  3. euphemy's Avatar
    Thank you. I will see if that thread helps!

    Posted via CB10
    10-27-13 08:38 PM
  4. Carl Estes's Avatar
    Sometimes what can happen is if there is a build up of dust/debris on the Dock itself, and when you place the Playbook onto the dock, and yes, you see a lightning bolt, it CAN acually be in discharge state. It is just not making a good solid contact for the 3 charging pins.
    Every once in a while, I clean the Dock Cradle and the contacts on the PB with a CLEAN/NEW toothbrush (not used ewwww), this knocks the dust/debris out and helps ensure a good contact for charging.

    c
    10-29-13 10:10 AM
  5. euphemy's Avatar
    Thank you Carl, I will try this. It only charges with my old Bold plug. How odd is that?


    Posted via CB10
    01-30-14 04:28 PM

Similar Threads

  1. Replies: 45
    Last Post: 09-19-17, 01:57 PM
  2. To charge your device faster....
    By thidisbogus in forum BlackBerry Q10
    Replies: 13
    Last Post: 04-17-14, 12:06 AM
  3. Trouble with Downloading link 1.2
    By Draggy38 in forum BlackBerry Link
    Replies: 2
    Last Post: 10-27-13, 01:18 PM
  4. Usb Charging
    By Alfredofid in forum BlackBerry Z10
    Replies: 2
    Last Post: 10-26-13, 11:01 PM
  5. 10.2 leaks and charging
    By chudypee in forum BlackBerry Z10
    Replies: 3
    Last Post: 10-25-13, 10:37 PM
LINK TO POST COPIED TO CLIPBOARD