1. bishshoy's Avatar
    This procedure will enable faster transfer of files from your PC to your PlayBook. Speed will be 5 MBps, which is significantly faster than the drag-and-drop procedure or using Blackberry Desktop Software. This is same as the tutorial given in the post
    "copy-files-5x-faster-than-wi-fi-sharing"
    but the difference is that this achieves it by using an FTP IIS server instead of HTTP, which brings more security, a slightly more speed, no configuration for unknown file types are required via MIME rules as all files are recognized on the client as they are, and the biggest advantage is that you can use your favourite app "Ghost Commander" to transfer files to and from the PC as if you are browsing your SD Card.

    Instructions are kept "to the point" as much as possible. Arrows "->" denote the next step.

    Instructions for Windows 7 users :

    1. Go to Control Panel (Category View) -> Programs -> Turn Windows features On and Off.

    2. Select Internet Information Services (leave it partially checked). Expand to FTP Server and then (partially) check it too, and finally check "FTP Service". Hit OK. Restart PC.

    3. Start -> Run CMD -> "ipconfig" and note your IPv4 address.

    4. Start -> Run inetmgr (sometimes typing "iis" also works) -> Right Click your computer name in the left pane -> Add FTP site -> Fill in any name and select the path that you want to share with your PB -> Hit Next -> Fill in your IPv4 address -> Note down the Port Number -> "No SSL" will suffice most normal users -> Hit Next -> Tick "Basic Authentication" -> Allow access to "Specified Users" -> Type in the blank box, the name of you current Windows User Account. Set permissions as desired. Hit Finish.

    5. On your PB, turn on WiFi and download Ghost Commander from App World (I believe most users already have it). Hit FTP Site -> Fill in the server box as IPv4 address:Port Number (for example if my IPv4 address is 192.168.0.100 and Port Number is 21, I would fill in 192.168.0.100:21) -> Type in your Windows Account Username and Password and hit OK. Now you will be able to browse the PC folders, Copy to and from them, etc. Enjoy.
    Last edited by bishshoy; 07-27-12 at 05:31 AM.
    07-25-12 04:59 AM
  2. PatrickMJS's Avatar
    Thanks for posting this, bish shoy.

    Just to clarify: does this process allow us to use the PB browser to access files that are on my W7 computer over my home wifi network?
    07-25-12 11:21 AM
  3. bishshoy's Avatar
    Yes you can use the PB browser too. Use "ftp://ipaddress" in the address field, and you will be prompted for the username and password.
    07-25-12 01:52 PM
  4. zilla0617's Avatar
    Hello,
    When following your instructions, I get an error. In step #4 when I right-click I don't see "add FTP site" instead I see "add Website", is that the same thing? Thanks in advance

    Edit: I realized I did not tick the FTP server, however when I try to add specific users I input my windows username and it states that one already exists with that username. Is there a way to remove the previous one and add a new one? Thanks

    Arrows "->" denote the next step.

    Instructions for Windows 7 users :

    1. Go to Control Panel (Category View) -> Programs -> Turn Windows features On and Off.

    2. Select Internet Information Services (leave it partially checked). Expand to FTP Server and then (partially) check it too, and finally check "FTP Service". Hit OK. Restart PC.

    3. Start -> Run CMD -> "ipconfig" and note your IPv4 address.

    4. Start -> Run inetmgr (sometimes typing "iis" also works) -> Right Click your computer name in the left pane -> Add FTP site -> Fill in any name and select the path that you want to share with your PB -> Hit Next -> Fill in your IPv4 address -> Note down the Port Number -> "No SSL" will suffice most normal users -> Hit Next -> Tick "Basic Authentication" -> Allow access to "Specified Users" -> Type in the blank box, the name of you current Windows User Account. Set permissions as desired. Hit Finish.

    5. On your PB, turn on WiFi and download Ghost Commander from App World (I believe most users already have it). Hit FTP Site -> Fill in the server box as IPv4 address:Port Number (for example if my IPv4 address is 192.168.0.100 and Port Number is 21 the I would fill in 192.168.0.100:21) -> Type in your Windows Account Username and Password and hit OK. Now you will be able to browse the PC folders, Copy to and from them, etc. Enjoy.
    Last edited by zilla0617; 07-25-12 at 03:07 PM. Reason: User error
    07-25-12 02:53 PM
  5. bishshoy's Avatar
    You must input the Windows Account Username as it is. It is case-sensitive. Multiple user accounts can be added via "comma" separator just as you would do when you are sending mail to multiple recipients. If you want to edit the list after creating the site, do this :

    Start -> Run inetmgr -> Expand the computer name and click on the name of your already created ftp site -> A list of FTP configurations would appear in the middle pane -> "FTP Authorization Rules" is the one you are looking for, so double click it -> Then the user accounts, currently associated with your site will appear. On the left "Actions" pane has options to modify these.

    Let me know if its solved now.
    07-26-12 01:47 AM
  6. zilla0617's Avatar
    So I was able to delete the other files and create a new one. For whatever reason, I still can't get it to work. When viewing the rules I only see one file with permission to read and write. I made sure both the default and the new ftp I created are set to "start". When I test connection settings authorization cannot verify access to path C:/. Thanks for all your help.
    07-26-12 12:11 PM
  7. FreeJACLive's Avatar
    Too bad someone wouldn't come up with an IIS template instead so one could easily setup a webpage at home for this. I currently use Windows Home Server 2011 that has a very nice web interface to log in remotely to and grab and save files to. It works great with the PB. You can also stream video and audio content from the server after you long in. That part doesn't work on the Playbook unfortunately because the server is using Silverlight.
    07-26-12 12:53 PM
  8. PatrickMJS's Avatar
    I can't get inetmgr or iis to run. Is it a component that needs to downloaded first?
    07-26-12 12:58 PM
  9. FreeJACLive's Avatar
    Its a Windows feature that has to be enabled via Program and Features in the Control Panel.
    PatrickMJS likes this.
    07-26-12 01:11 PM
  10. PatrickMJS's Avatar
    Its a Windows feature that has to be enabled via Program and Features in the Control Panel.
    Thanks Free Jac Live,

    I found the iis section in the "add windows features" just below where the op mentioned for the ftp server.

    Got it working. Sweet little feature... should come in handy later.
    07-26-12 02:21 PM
  11. bishshoy's Avatar
    So I was able to delete the other files and create a new one. For whatever reason, I still can't get it to work. When viewing the rules I only see one file with permission to read and write. I made sure both the default and the new ftp I created are set to "start". When I test connection settings authorization cannot verify access to path C:/. Thanks for all your help.
    Right Click on the name of the site you just created and hit "Remove", and start afresh. Review if all steps have been done correctly or not. If you are on a Personal Network, i.e no other PC belonging to some other persons is on the same LAN, then you can avoid the having an Username and Password to access your site. To do this you have to do all the steps mentioned in my first post but this time, set "Allow access to" -> "Anonymous Users". Also in the same step, you need to enable "Anonymous Authentication". Then from Ghost Commander you wont be asked for a password.
    zilla0617 likes this.
    07-27-12 05:18 AM
  12. Anonymous9286410's Avatar
    you may also consider using Total Commander
    I prefer direct mapping, can do ftp though.

    same speed for me, no desktop needed.

    Damian
    07-27-12 06:01 AM
  13. zilla0617's Avatar
    Right Click on the name of the site you just created and hit "Remove", and start afresh. Review if all steps have been done correctly or not. If you are on a Personal Network, i.e no other PC belonging to some other persons is on the same LAN, then you can avoid the having an Username and Password to access your site. To do this you have to do all the steps mentioned in my first post but this time, set "Allow access to" -> "Anonymous Users". Also in the same step, you need to enable "Anonymous Authentication". Then from Ghost Commander you wont be asked for a password.
    I finally got it to work, now is there a way to access my playbook from my laptop? Thanks
    07-27-12 03:13 PM
  14. cletis's Avatar
    I am prepared for the backlash I may receive for the following comment, but I can't help it: I am still snickering over the use of the phrase "more security" to refer to IIS!
    07-27-12 04:19 PM
  15. Gatmyer's Avatar
    Cletis;

    I have no idea what you are talking about but........DAMN YOU
    07-27-12 06:29 PM
  16. bishshoy's Avatar
    I am prepared for the backlash I may receive for the following comment, but I can't help it: I am still snickering over the use of the phrase "more security" to refer to IIS!
    "Password Authorization"
    07-27-12 08:07 PM
  17. ChaSiuBao's Avatar
    what if i don't use a windows password??? and use the admin account?
    08-01-12 05:37 PM
  18. ralfyguy's Avatar
    To be honest, I followed the instructions as good as I can, but I never could get it to work. No matter what I type into the ftp part of Ghost Commander, it always says failed and it also says "unknown". I know I'm doing something wrong, but maybe it just doesn't work with XP.
    08-01-12 05:50 PM
  19. STRATEGIZER's Avatar
    For some reason I never thought of using FTP to transfer files to my Playbook (Mainly because I didnt think it was possible ).

    BTW, You can skip step 1,2,3,4 & just install FileZilla. Use the Host, User name, Password & port given/used in your Playbook FTP server client, Then hit connect. Eazy Peezy

    Thanks for the heads up !!!
    08-01-12 06:26 PM
  20. ralfyguy's Avatar
    OK this where I get utterly confused: Which is the host, user name and password on the windows machine and where does it go in the Ghost Commander info boxes? I tried any combination and it shows failed every time and says unknown host.
    I cannot figure this out for the life of me and I am not entirely computer illiterate.
    I don't even have a password on my windows user account, so i wouldn't even know what to enter there.
    08-01-12 10:41 PM
  21. bishshoy's Avatar
    what if i don't use a windows password??? and use the admin account?
    If you dont want to use password, then select in step 4, change "Allow access to" -> "Anonymous Users". Also in the same step, you need to enable "Anonymous Authentication". Then from Ghost Commander you wont be asked for a password.
    08-02-12 05:07 AM
  22. bishshoy's Avatar
    OK this where I get utterly confused: Which is the host, user name and password on the windows machine and where does it go in the Ghost Commander info boxes? I tried any combination and it shows failed every time and says unknown host.
    I cannot figure this out for the life of me and I am not entirely computer illiterate.
    I don't even have a password on my windows user account, so i wouldn't even know what to enter there.
    To be honest, I followed the instructions as good as I can, but I never could get it to work. No matter what I type into the ftp part of Ghost Commander, it always says failed and it also says "unknown". I know I'm doing something wrong, but maybe it just doesn't work with XP.
    I did not test out the instructions in Windows XP. For your problems, try out in step 4 "Allow access to" -> "Anonymous Users". Also in the same step, enable "Anonymous Authentication". Then from Ghost Commander you wont be asked for a password. If the problem still exists, then from IIS (on ur PC), click on "Sites", which you will find in the left pane. And a list of all the sites that your PC hosts will appear. Check whether the ftp site has "Status" as "Started" or not. There you will find a Binding IP address. Then run CMD -> ipconfig, and check whether the IPv4 Address matches with the Binding IP, if its not same then it wont work.
    08-02-12 05:18 AM
  23. ralfyguy's Avatar
    I cannot get this to work. I have no idea what to type into Ghost Commander. Nothing works.
    08-02-12 09:13 PM
LINK TO POST COPIED TO CLIPBOARD