1. dvinice's Avatar
    Hi,

    I recently got my playbook (been 2 weeks now) and I'm really enjoying it, i'm using twonky to view my local videos and it works perfect.

    Only issue is when I stream videos via the browser (any kind of video).. they work but always seem to buffer about 20-30 seconds in and continuously happens throughout the video.

    Youtube works fine though.

    So far i've tried :

    Changing WiFi settings from b/g/n and also using Auto
    Changing channel (wifi settings)
    Clearing cache
    Disabling javascript and Flash (and enabling them again)
    Reboot
    Hard reboot (Holding Volume and power together)

    I can only assume that the playbook has a small buffer size which is making this buffer? I see alot of people have this problem too on here.

    I also have an iPad and can say the videos work fine on that so i'm convinced it's something to do with the playbook - suggestions welcome.
    02-14-13 07:13 AM
  2. slparry's Avatar
    Have you tried lowering the quality of the videos? If it's Flash style ones like youtube uses you can reduce the quality to suit the bandwidth
    02-14-13 08:02 AM
  3. dvinice's Avatar
    Yeah i've tried that, I still have the same problem.

    It works for a few seconds then buffers again.. quite frustrating.
    02-14-13 08:51 AM
  4. tfp's Avatar
    I can only speak from my own personal experience but mine does not have this issue. I use my PlayBook to stream entire hockey games (2+ hours) soccer games (2+ hours) and even online tv shows (30-60 mins) and have never had this buffering issue even when using the Bridge connection for internet.

    I can see from my circle of friends, 8 PlayBooks in total, that it is not a PlayBook issue as none of them experience this.

    You know what they say about people who make assumptions lol j/k
    02-14-13 10:31 AM
  5. Bbnivende's Avatar
    I can only speak from my own personal experience but mine does not have this issue. I use my PlayBook to stream entire hockey games (2+ hours) soccer games (2+ hours) and even online tv shows (30-60 mins) and have never had this buffering issue even when using the Bridge connection for internet.

    I can see from my circle of friends, 8 PlayBooks in total, that it is not a PlayBook issue as none of them experience this.

    You know what they say about people who make assumptions lol j/k
    I wish I was one of your 8 friends ( I only know of one friend that owns a PB) since I have the same issue as OP using WIFI. I do not watch TV using the cell phone service .. yikes that must be a data hog ?
    02-14-13 10:41 AM
  6. Bbnivende's Avatar
    Definitely could be a WIFI issue that is related to the antenna on the PB. ( flames begin) I have been in hotel rooms where my BB9900 works on WIFI but my PB can't pick up the signal. Could be a combo of a crappy antenna and software (flames begin) . When I get some time I will test out the antenna theory with the PB beside the router and down in the basement where the signal is not so strong.
    02-14-13 11:11 AM
  7. ChrisMay's Avatar
    This seems to be an odd one!
    For some (lucky) people, streaming seems to work fine, and for others (like me) it doesn't work well at all.
    YouTube generally seems to work ok for me. ITVPlayer and 4od (probably only knw these if you are from the UK) don't work at all 30 or so seconds, then buffering/fails.
    BBC iPlayer seems better, though not perfect. All work without any issues on my laptop, which uses the same WiFi/broadband connection.

    Like you suggest, I think it has to do with the buffering on the Playbook, but also something in conjunction with the website that serves the video stream, so certain sites work ok, and others don't. It is very frustrating. I raised a support issue with Blackberry, but all they could really say was what I just said, and that it could get fixed in some future (unspecified) update to the browser, maybe...
    02-14-13 11:18 AM
  8. djpailo's Avatar
    Definitely could be a WIFI issue that is related to the antenna on the PB. ( flames begin) I have been in hotel rooms where my BB9900 works on WIFI but my PB can't pick up the signal. Could be a combo of a crappy antenna and software (flames begin) . When I get some time I will test out the antenna theory with the PB beside the router and down in the basement where the signal is not so strong.
    The signals mean absolutely nothing. There is no common standard as to what the signal bars on a device mean for 3G signals (and I'm guessing for Wi-fi too), so comparing them is meaningless, since one bar on a playbook may be just as good as all the bars highlighted on a phone.
    rimshot 1 likes this.
    02-14-13 11:37 AM
  9. dvinice's Avatar
    This seems to be an odd one!
    For some (lucky) people, streaming seems to work fine, and for others (like me) it doesn't work well at all.
    YouTube generally seems to work ok for me. ITVPlayer and 4od (probably only knw these if you are from the UK) don't work at all 30 or so seconds, then buffering/fails.
    BBC iPlayer seems better, though not perfect. All work without any issues on my laptop, which uses the same WiFi/broadband connection.

    Like you suggest, I think it has to do with the buffering on the Playbook, but also something in conjunction with the website that serves the video stream, so certain sites work ok, and others don't. It is very frustrating. I raised a support issue with Blackberry, but all they could really say was what I just said, and that it could get fixed in some future (unspecified) update to the browser, maybe...
    Agree it is very frustrating, a bit surprised that the support has said it'll get fixed.. are they admitting that maybe there is an issue with this?

    ITVPlayer and 4OD don't work here either.
    02-14-13 11:55 AM
  10. Bbnivende's Avatar
    The signals mean absolutely nothing. There is no common standard as to what the signal bars on a device mean for 3G signals (and I'm guessing for Wi-fi too), so comparing them is meaningless, since one bar on a playbook may be just as good as all the bars highlighted on a phone.
    Well if my PB plays video well next to the router and buffers badly where the signal is not so strong is that not indicative of an antenna issue ? From experience I do know that the antenna on the PB is not as good as all my other devices (4).
    02-14-13 12:12 PM
  11. ChrisMay's Avatar
    Agree it is very frustrating, a bit surprised that the support has said it'll get fixed.. are they admitting that maybe there is an issue with this?

    ITVPlayer and 4OD don't work here either.
    An important correction here, Support said 'it may get resolved by a 'future release'. They didn't really acknowledge that there was an issue, other then some sort of incompatability between the playbook browser and some websites. The tone of their message was putting the blame on the websites though, even though I said that these websites worked fine on other devices.

    EDIT: I just went back and re-read my emails from support. Actually, they were even less encouraging than I remembered.
    The difference of performance between both devices [my laptop and my playbook] is due to factors such as hardware specifications and the device's software build.
    The stream sites's performance disparity is felt because each stream site will require different amounts of memory to process. Like mentioned the way it will play will depend on the site's requisites and the device's way to process them.

    Obviously our development team is always researching ways to improve the performance of the BlackBerry PlayBook. And certainly BB10 will bring a new and streamlined user experience. There is no release date for BB10 for the BlackBerry PlayBook as of now.
    and
    At this time moment aren't any settings to change or anything you could do to improve the streams's performance on the BlackBerry PlayBook.

    The performance may change although with changes from said stream's websites.
    So nothing helpful, really...
    Last edited by ChrisMay; 02-14-13 at 01:12 PM.
    02-14-13 01:01 PM
  12. ChrisMay's Avatar
    I can only speak from my own personal experience but mine does not have this issue. I use my PlayBook to stream entire hockey games (2+ hours) soccer games (2+ hours) and even online tv shows (30-60 mins) and have never had this buffering issue even when using the Bridge connection for internet.
    I'm not doubting you, but could you let me know the websites that you successfully stream these from? Blackberry support told me (in so many words) that some sites would work better than others, so if you are successfully streaming, I'd like to try a website that works (at least for someone else).
    02-14-13 01:15 PM
  13. Bbnivende's Avatar
    Well if my PB plays video well next to the router and buffers badly where the signal is not so strong is that not indicative of an antenna issue ? From experience I do know that the antenna on the PB is not as good as all my other devices (4).
    I ran my test. The PB was not able to run Youtube and sound was garbled. I restarted (warm boot) the PB and the youtube worked fine upstairs and downstairs. Good old PB !! I gave it a pat.
    02-14-13 04:30 PM
  14. GeneralHerzog's Avatar
    The best way to confirm if it is your home router/PB antenna, is to go out and find a free wifi access point at say Starbucks, McDonalds, or if a Timmies if you have the chance.
    Try the exact same videos at the public venue, if it plays fine then you have your answer.

    If you get the same issue, then there's something wrong with the PB. If the PB has an issue, before anything else, wipe the device, reinstall the OS and patch all at once (don't reinstall then patch later). If it still continues ......then I'd say you have a lemon. (but since I don't believe in BlackBerry Lemons.........)
    02-14-13 04:41 PM
  15. jethrodood's Avatar
    Ive been having issues with streaming stutters as well and have come to find out that if the server sets up the stream to run at 60fps instead of the more typical 30fps, then I get stutter.. Playbook doesn't appear to like it @60. Such is the case with my favorite hockey Site anyway. Many others work perfect.
    02-14-13 11:23 PM

Similar Threads

  1. Shhhhhhh! Amazon streaming video works GREAT!
    By rbenjamin in forum BlackBerry PlayBook
    Replies: 0
    Last Post: 04-22-11, 06:51 PM
  2. m.nbc.com Streaming Video works!
    By NBAJWill55 in forum Android
    Replies: 10
    Last Post: 11-09-09, 10:28 AM
  3. streaming video never works
    By joebold in forum BlackBerry Bold 9000
    Replies: 18
    Last Post: 01-17-09, 07:09 PM
  4. I can watch youtube but can't watch streaming video from scifi.com
    By reaperg21 in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 08-09-08, 03:09 AM
  5. Same video works on 8310 and pearl but not 8330
    By jdoc77 in forum BlackBerry Curve 83xx
    Replies: 8
    Last Post: 07-09-08, 02:18 PM
LINK TO POST COPIED TO CLIPBOARD