1. Sadiqi's Avatar
    I updated OS of my PB but not finished the registration after, because battery shows 5%. I plug in the charger via USB and doesnt' work.
    I tried other chargers and same - nothing happens.
    Now I can turn on my PB, but just after loading the system (at the registration step) it shows battery 0% and going to shut down.
    But reaction to a charger is strange now.
    When I plug the charger (no matter oryginal or not) the red LED lights up for 15-20 seconds, then off for about 10 seconds and for 20 seconds the screen shows up the icon:
    Strange reaction to the charger-playbookplugicon.jpg
    then everything off and PB is not going to charge.
    I tried to put charger even for night and nothing happen
    Any tips how to fix it? I have only USB chargers (2,1 A max).
    03-30-13 10:10 AM
  2. BB_Bmore's Avatar
    Wow its sad nobody helps PlayBook users here anymore. I guess people are too busy with instagram lol figuring out how to sign in OP search "stack charge" here on CrackBerry. There are many threads and you should be okay. Many a dead PlayBook has come back to life.
    03-31-13 01:41 AM
  3. jpash549's Avatar
    I updated OS of my PB but not finished the registration after, because battery shows 5%. I plug in the charger via USB and doesnt' work.
    I tried other chargers and same - nothing happens.
    Now I can turn on my PB, but just after loading the system (at the registration step) it shows battery 0% and going to shut down.
    But reaction to a charger is strange now.
    When I plug the charger (no matter oryginal or not) the red LED lights up for 15-20 seconds, then off for about 10 seconds and for 20 seconds the screen shows up the icon:
    Click image for larger version. 

Name:	PlayBookPlugIcon.jpg 
Views:	85 
Size:	2.9 KB 
ID:	145369
    then everything off and PB is not going to charge.
    I tried to put charger even for night and nothing happen
    Any tips how to fix it? I have only USB chargers (2,1 A max).
    The Blackberry Knowledge base article on charging is KB 27705.

    http://btsc.webapps.blackberry.com/b...ListHelperImpl

    Do not try to charge with screen on. If the charge level is really low the charger current flow is restricted and it may take some time to reach higher rate charging . Use the original charger and be sure to insert the plug in correctly. If you have used other chargers it is possible that the port has been damaged. Suggest inspecting it carefully
    03-31-13 02:48 AM

Similar Threads

  1. Out and about: Reactions to the Z10
    By diegonei in forum BlackBerry Z10
    Replies: 0
    Last Post: 03-26-13, 12:22 PM
  2. Strange reaction to the sim card.
    By Darynachka in forum BlackBerry Bold 9000
    Replies: 2
    Last Post: 05-05-11, 03:01 PM
  3. Replies: 2
    Last Post: 10-31-09, 03:23 PM
  4. Replies: 1
    Last Post: 08-17-09, 05:00 PM
  5. Is there anything particular to the wall charger on the 8300?
    By Brons2 in forum BlackBerry Curve 83xx
    Replies: 4
    Last Post: 12-30-07, 07:55 PM
LINK TO POST COPIED TO CLIPBOARD