1. jf1444's Avatar
    Took the plunge and picked up PB this week as a xmas gift to myself! For $200 this tablet can't be beat!! i am very impressed with the hardware and the OS. I also have an iphone and wife has ipad2 and android smartphones and the PB holds its own quite well!!
    Sure...there is not 140k apps available for it but I don't care for much apps. This is really a sweet tablet

    One 'issue' that I have and may actually be deal-breaker is the web-browser's speed. Well not the actual speed but the time it takes to load a page. it is difficult to explain...

    When i go to any page (simple as google or busy as yahoo, flash or no flash etc) a small blue bar is visible across the top of the browser as the page loads. I find that the browser 'pauses' for a few seconds and then continues to load the page. I've done side-by-side tests against my iphone, ipad,Nexus S, and a couple of laptops all connected to the same wireless network and the pb is considerably slower compared to those. I also repeated these tests using my phone as hotspot with the same results. The PB takes it sweet time to 'think' and load. Once that pause is gone,the pages load lightening fast. I don't have an issue with my network. I've already tested that.

    Is this 'normal' for this browser? i hate having to wait 5-10secs when wanting to load a page..
    btw: ipad2 on same wifi loads easily 3x faster...
    btw2: yes, i've turned off flash when comparing against ipad... and cleared cache etc

    It is very annoying and am seriously considering bringing it back...
    Last edited by jf1444; 12-30-11 at 06:06 PM. Reason: spelling
    12-30-11 05:55 PM
  2. Unsure2's Avatar
    While I have gripes about RIM's support of the Playbook or lack thereof--to the point that one or two overly zealous fans have called me a "hater"-- I generally consider the Playbook browser, at least, to be quite good--snappy and fast. Have you tried the SimpleBrowser (AppWorld) to see if it loads faster?

    It can be difficult to do honest tests of loading speed between different browsers, because of different buffering, some browsers displaying a page before everything is loaded while another browser waits for everything, etc. I'll see if I can do some tests.
    12-30-11 06:20 PM
  3. FF22's Avatar
    You can also try to turn off javascript - it makes a big difference on Crackberry pages.

    I am not sure how the "N" standard for Routers affects actual loading (versus losing wifi periodically) but there have been some issues with it. So going into router settings and disabling "n" and engaging "b/g" has helped some folks.
    12-30-11 06:48 PM
  4. Chrysalis1156's Avatar
    +1 on the turning off javascript unless you need it. Took my browsing in here from pokey to snappy.
    12-30-11 08:04 PM
  5. jf1444's Avatar
    +1 on turning off javascript! That really seemed to speed things up quite a bit!!
    Guess I'll hold on to my pb for at least a while longer....

    Correction: This thing now FLIES ! Wow !! Thanks for the tip!
    Last edited by jf1444; 12-30-11 at 10:17 PM.
    peter9477 likes this.
    12-30-11 10:11 PM
  6. kbz1960's Avatar
    Yep RIM have work to do on java script.
    12-30-11 10:23 PM
  7. jafobabe's Avatar
    It even gunks up my PC when I have CB site up!
    12-30-11 10:28 PM
  8. narci's Avatar
    I find the PB browser slow and I should not have to turn off javascript.

    My HP Touchpad's browser loads pages faster then the PB.

    From what I have been hearing, the browser on OS2.0 is much faster.

    Counting the days till Feb.
    12-30-11 11:00 PM
  9. The_Kills's Avatar
    meh this is my biggest gripe at the moment with the PB. i dont mind the slow loading, i hate when flash is enabled, the scolling is slow or choppy.
    12-30-11 11:16 PM
LINK TO POST COPIED TO CLIPBOARD