1. lynxs_claw's Avatar
    Having a bit of an issue here and wondering if any other CB members are experiencing the same issue.

    After the OS2.1 upgrade, I tried using my video camera at 1080p (then eventually 720p and 480p - same issue) to record my daughters skating lesson. I noticed at around the 10 second, 30 second, and 50 second mark the video would freeze for a few (2 to 6 seconds) seconds. This problem is intermittent but generally tends to go away after about a minute.

    At first I thought maybe it was due to upgrading the latest OS and betas over time and maybe something got corrupted. So for the first time I re-installed my playbook OS from scratch. I have grabbed a lot of games and apps through app world and after a lengthy re-install.. tried the video camera. There was no lag or issues!

    So next I installed my side-loaded apps (all from goodereader.com) and the lag came back. So the next immediate step I tried was was uninstalling all the sideloaded apps and then the camera was good again.

    So I'm not sure what's happening here and if anyone who has sideloaded any apps is having this same sort of problem. What's funny is that I've installed the same side-loaded apps on other PB's in the house (one 64gb/one 16gb) and on my brother-in-law's (64 gb) and they all don't exhibit the issue.. just my 64 gb

    Never had this problem before.

    I have 6.75 gb left on the PB and originally before the OS re-install there was 3.25 gb left so I don't think it's a free memory issue. And the issue happens on the front AND the rear camera. Before recording I don't see the freeze .. only after I start recording.

    I'll have to post a list of my sideloaded Android apps when I get home cause I don't have the list with me right now.

    It almost seems like there is a/some program(s) running in the background that is taking the CPU away from the video recording...

    Any thoughts?
    10-09-12 08:45 AM
  2. pacoman03's Avatar
    It seems possible. When I first installed the original 2.1 beta OS, I was having a problem with my android player, where if I had an app running in it and then minimized the app, when I'd bring it back up the player would be black and I had to close and reopen the app to use it. I did what you did, a wipe and reinstall of the beta OS. After reinstall, I loaded an android app or two from app world, and the problem was gone. So I then started sideloading my apps, 10 at a time. First 10 installed- everything still fine. Second ten, the problem was back. I then started uninstalling the apps one at a time until the problem went away, then I reinstalled what seemed to be the offending app and the problem was back. So I uninstalled that app and got rid of the bar file. Anyhow, even though it was an android app affecting the android player, now that the android player has access to the PB camera, maybe one of your sideloaded apps is trying to access the camera and is causing you problems.
    lynxs_claw likes this.
    10-09-12 09:01 AM
  3. Carl Estes's Avatar
    I've only one sideloaded app, The Eye-Fi card app from goodereader. I just tried shooting vids ( pointed at the tv for movement) from one of my PB's (64Gb), and did not see anything that jumped out at me.

    I ran @ 1080 for about 3 min, no issue, then I went down to 720 and 480. All "about" 3/4 mins each and saw no issues.

    BUT this is with only 1 Sideloaded app. Might try to sideload one at a time and see if there is one specific
    app that sends you PB into fits and starts.

    C
    10-09-12 09:03 AM
  4. lynxs_claw's Avatar
    Thanks for the responses so far. Note that when I'm recording with the video camera, I have no other apps running - sideloaded or otherwise. I will definitely post all the sideloaded apps I've installed.

    I may have to do what you did pacoman3, install a group of apps at a time to narrow down the offender. The only issue is I've uninstalled all the apps again and I'm not too sure if the camera is functioning properly again. I hope it's not something that has now been installed on my system and I can't get rid of it without another wipe (re-installing is a pain!).

    Does anyone know of any apps that show you what's running in the background on your playbook?
    10-09-12 10:46 AM
  5. lynxs_claw's Avatar
    It seems possible. When I first installed the original 2.1 beta OS, I was having a problem with my android player, where if I had an app running in it and then minimized the app, when I'd bring it back up the player would be black and I had to close and reopen the app to use it. I did what you did, a wipe and reinstall of the beta OS. After reinstall, I loaded an android app or two from app world, and the problem was gone. So I then started sideloading my apps, 10 at a time. First 10 installed- everything still fine. Second ten, the problem was back. I then started uninstalling the apps one at a time until the problem went away, then I reinstalled what seemed to be the offending app and the problem was back. So I uninstalled that app and got rid of the bar file. Anyhow, even though it was an android app affecting the android player, now that the android player has access to the PB camera, maybe one of your sideloaded apps is trying to access the camera and is causing you problems.
    Do you remember what app it was?
    10-09-12 10:49 AM
  6. FF22's Avatar
    While I have not been reading about the FREEZE glitch for a while, it has been an issue/bug/whatever for a while for some pb's. I am not sure that it is related to sideloading as folks reported it as a problem a long time ago. If it goes away if the sideloaded apps are removed, good going.
    10-09-12 10:53 AM
  7. pacoman03's Avatar
    Do you remember what app it was?
    I do, but I won't mention it because if I did it might take this thread off in a completely different direction. And, FWIW, it didn't need to be running to cause the problems that it did. Just having it installed on my PB caused the problems that I had.
    10-09-12 11:08 AM
  8. robsteve's Avatar
    While I have not been reading about the FREEZE glitch for a while, it has been an issue/bug/whatever for a while for some pb's. I am not sure that it is related to sideloading as folks reported it as a problem a long time ago. If it goes away if the sideloaded apps are removed, good going.
    I have seen it off and on since April of 2010. It is not related to sideloading. I don't think anybody has ever posted a cause or cure.
    10-09-12 11:24 AM
  9. lynxs_claw's Avatar
    Ok, I think I have this solved. I should have talk to my design engineer (who I convinced to get a playbook) before blowing away my OS. When I explained to him the problem, he wanted to look at my "app permissions" in my PB settings. I told him I already looked there and there are no permissions set for my sideloaded apps.

    I only had 3 apps that had permissions associated. When he saw that Facebook app was set "Allow" for the camera.. he told me to try changing the permission to "Denied". When I did that .. I got NO freezing whatsoever.

    @robsteve,

    I do believe it does have to do with sideloading, but not directly. My thoughts are somehow one of the sideloaded apps were conflicting with Facebook having access to my camera. I can't explain it otherwise. Before sideloading with the full permission to Facebook.. no issues with freezing when recording.. after installing my sideloaded apps .. major freezing .. turning off Facebook permission only for camera .. issue GONE..
    10-09-12 02:09 PM
  10. myllym's Avatar
    Hi there, I had this exact problem, before the upgrade. But I don't think you will like my solution. I worked out, by process of elimination, that I had too many files in the 'camera' directory. I didn't want to believe this, so I put the files back again, and hey presto the freezing started again.

    Not sure that helps, but as the PB stores the recorded video and still pictures in one directory, there was something it didn't like. Whether quantity or size, I couldn't tell.
    FF22 and lynxs_claw like this.
    10-09-12 04:02 PM
  11. lynxs_claw's Avatar
    Ok, I think I have this solved. I should have talk to my design engineer (who I convinced to get a playbook) before blowing away my OS. When I explained to him the problem, he wanted to look at my "app permissions" in my PB settings. I told him I already looked there and there are no permissions set for my sideloaded apps.

    I only had 3 apps that had permissions associated. When he saw that Facebook app was set "Allow" for the camera.. he told me to try changing the permission to "Denied". When I did that .. I got NO freezing whatsoever.


    Nope, spoke to soon.. still got the freezing ... un-installed all the side-loaded apps (except the air browser - can't uninstall it) and it's still there! This is so frustrating!!!
    10-12-12 01:35 AM
  12. aaron8733194's Avatar
    It must be your device because I've tried to recreate your issue on my playbook. The majority of my apps are sideloaded from goodereader.com and they don't affect my native apps at all. I suggest you do a reset and regrant all the app permissions. A freezing camera is not affected by the Android runtime as the runtime is processed by the QNX platform and NOT the PlayBook OS. If you need more help, see my profile for ways to contact me.
    Having a bit of an issue here and wondering if any other CB members are experiencing the same issue.

    After the OS2.1 upgrade, I tried using my video camera at 1080p (then eventually 720p and 480p - same issue) to record my daughters skating lesson. I noticed at around the 10 second, 30 second, and 50 second mark the video would freeze for a few (2 to 6 seconds) seconds. This problem is intermittent but generally tends to go away after about a minute.

    At first I thought maybe it was due to upgrading the latest OS and betas over time and maybe something got corrupted. So for the first time I re-installed my playbook OS from scratch. I have grabbed a lot of games and apps through app world and after a lengthy re-install.. tried the video camera. There was no lag or issues!

    So next I installed my side-loaded apps (all from goodereader.com) and the lag came back. So the next immediate step I tried was was uninstalling all the sideloaded apps and then the camera was good again.

    So I'm not sure what's happening here and if anyone who has sideloaded any apps is having this same sort of problem. What's funny is that I've installed the same side-loaded apps on other PB's in the house (one 64gb/one 16gb) and on my brother-in-law's (64 gb) and they all don't exhibit the issue.. just my 64 gb

    Never had this problem before.

    I have 6.75 gb left on the PB and originally before the OS re-install there was 3.25 gb left so I don't think it's a free memory issue. And the issue happens on the front AND the rear camera. Before recording I don't see the freeze .. only after I start recording.

    I'll have to post a list of my sideloaded Android apps when I get home cause I don't have the list with me right now.

    It almost seems like there is a/some program(s) running in the background that is taking the CPU away from the video recording...

    Any thoughts?
    10-12-12 02:12 AM
  13. DoctorNeutron's Avatar
    Don't know if this helps: after 2.1, Compass Pro killed my sound system, even after
    Several reboots. Removal cured the sound sub-system problem. Doc Neutron
    10-12-12 10:55 AM
  14. glamrlama's Avatar
    Having a bit of an issue here and wondering if any other CB members are experiencing the same issue.

    After the OS2.1 upgrade, I tried using my video camera at 1080p (then eventually 720p and 480p - same issue) to record my daughters skating lesson. I noticed at around the 10 second, 30 second, and 50 second mark the video would freeze for a few (2 to 6 seconds) seconds. This problem is intermittent but generally tends to go away after about a minute.
    I have been having the same issue. It was happening in 2.0 but the 2.1 beta cleared this up for me. The 2.1 official seems to have brought the problem back. Frustrating. I'm not a heavy video user which is good. Please fix this one RIM. Any solutions out there?
    10-12-12 06:11 PM

Similar Threads

  1. Best android apps in OS2.0
    By xtrasher_kingx in forum PlayBook Apps & Games
    Replies: 12
    Last Post: 02-22-12, 12:49 AM
  2. Kindle app in Os2.0 ????
    By stevenbones in forum BlackBerry PlayBook
    Replies: 10
    Last Post: 10-11-11, 09:38 AM
  3. Kindle app in Os2.0 ????
    By stevenbones in forum PlayBook Apps & Games
    Replies: 10
    Last Post: 10-11-11, 09:38 AM
  4. link to video chat app?
    By d3adcrab in forum PlayBook Apps & Games
    Replies: 3
    Last Post: 08-29-11, 09:26 PM
  5. Youtube... Linking to videos from comment emails.
    By SAFE_NAFE in forum Storm 3rd Party Apps
    Replies: 0
    Last Post: 04-15-09, 11:59 PM
LINK TO POST COPIED TO CLIPBOARD