1. EFats's Avatar
    Not exactly sure when this started happening, it might have been after the 2.0 update. Early on I never had problems with my PB.

    What is happening is that when I resume after suspend (e.g. swipe up), the screen is often corrupted. In the simplest case, the screen is visible, but the colours are "inverted" or the "negative" of what it should be. In the worse case, I get what looks like an almost blank gray screen (although very reminiscent of a metallic wallpaper type of thing). Usually there are some occasional pixels that flicker when I swipe around, so it seems to be alive.

    Luckily, I can still re-suspend with the hard-button (yes, that one that is impossible to press) and after a few wake-up/suspend attempts, it returns to normal. There has been no monkeying around with my PB, no beta OS, no side loading, rooting, nothing. Just bone standard stuff plus the updates. Battery level doesn't matter. Nor does having anything running during suspend. Typically I have video player up or messages, but I've experienced this with nothing running as well.

    Anyone else experienced this recently?
    06-24-12 11:57 PM
  2. jafobabe's Avatar
    Not me. Have you tried a HARD Three Finger Re-Boot?
    06-25-12 12:53 AM
  3. Snuupy's Avatar
    Reload the OS. xsacha might be able to shed some light on this.
    06-25-12 12:57 AM
  4. FF22's Avatar
    If the various following procedures do not fix it then contact rim

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)

    ...............

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.

    ....................

    Try Security wipe - Options/Gear, Security, Wipe

    OR..........

    Try the Debrick method....

    Perform a backup of your pb if you can using Desktop Manager or, at least, manually coping any unique data, photos, voice recordings, documents, etc.

    1) Turn your playbook OFF by holding down the power button
    2) Let your playbook sit for about 10 minutes as earlier suggested.
    3) After letting the PB sit (and still powered off) open up the Blackberry Desktop Software (the latest version)
    4) Once the Blackberry Desktop Software is opened, use the USB Cable and hook the PB to the PC.. THEN power on the Playbook
    5) A screen will show on your computer showing that the device cannot be found
    6) Click on Update. It will take awhile
    06-25-12 08:05 AM
  5. Chaddface's Avatar
    I would call RIM and tell them about the power button as well. I sent one in just for the button.

    I haven't had that issue but have seen it mentioned a few times on these forums.

    Please report the advice RIM offers you.
    06-25-12 09:10 AM
  6. gtiffany's Avatar
    I had the same thing happen with my Playbook shortly after installing the latest official update. Sometimes it was the gray screen, sometimes it was the negative screen. I did call customer service and they were very helpful, talking me through three different re-installs of the operating system. They were very good about calling me back to check on my progress. They did eventually give me an RMA. Sent the device in, they kept it for tso weeks before saying they could find nothing wrong. I re-explained the problem and gave them links to two different threads here on CB (search for screen problems). Got the Playbook back three days later with a note saying it was fixed.

    I still get the occasional gray screen or reverse screen, but can correct it by putting the device back on standby or touching the power button (mine was recessed, but they fixed that too). I'm now of the opinion that it is a random bug introduced in the last update. I'm hoping it sill be corrected in the next update. Right now, it's a minor annoyance I can live with.
    06-25-12 09:11 PM
  7. h20work's Avatar
    Not exactly sure when this started happening, it might have been after the 2.0 update. Early on I never had problems with my PB.

    What is happening is that when I resume after suspend (e.g. swipe up), the screen is often corrupted. In the simplest case, the screen is visible, but the colours are "inverted" or the "negative" of what it should be. In the worse case, I get what looks like an almost blank gray screen (although very reminiscent of a metallic wallpaper type of thing). Usually there are some occasional pixels that flicker when I swipe around, so it seems to be alive.

    Luckily, I can still re-suspend with the hard-button (yes, that one that is impossible to press) and after a few wake-up/suspend attempts, it returns to normal. There has been no monkeying around with my PB, no beta OS, no side loading, rooting, nothing. Just bone standard stuff plus the updates. Battery level doesn't matter. Nor does having anything running during suspend. Typically I have video player up or messages, but I've experienced this with nothing running as well.

    Anyone else experienced this recently?
    Temporary solution, press the power button quickly and then a swipe up from the bottom to wake it back up. Much faster than the 3 finger salute and seems to work most of the time.
    06-25-12 10:52 PM
  8. EFats's Avatar
    Yes, maybe I wasn't clear. My solution is to hit that horrible recessed hard power button to re-suspend it then swipe again to wake up. Sometimes it works, sometimes it takes a few more tries. Cold boot or shut down doesn't seem to prevent this.

    I am not keen on re-installing the OS. Sounds like I'm not the only one and it's an intermittent bug that's been introduced in the latest version. I can wait for an update ...
    06-26-12 12:01 AM
  9. h20work's Avatar
    Yes, maybe I wasn't clear. My solution is to hit that horrible recessed hard power button to re-suspend it then swipe again to wake up. Sometimes it works, sometimes it takes a few more tries. Cold boot or shut down doesn't seem to prevent this.

    I am not keen on re-installing the OS. Sounds like I'm not the only one and it's an intermittent bug that's been introduced in the latest version. I can wait for an update ...
    Figures that this happens on my 64gb that has the recessed power button, yet my 16gb with the normal button works just fine. I remember all the posts "you don't need to use the power button ever" dismissing the problem.
    06-26-12 07:06 AM
  10. EFats's Avatar
    Status update:
    I didn't bother trying to send it in, I think it was just past 1 year when I first started getting problems and I couldn't really live without it anyways.

    It seemed to get progressively worse as time went on. To the point where I actually stopped using the swipe to wake up. I'm not sure why, but the power button wake-up seems significantly more reliable.
    I did a full OS re-install, but that didn't solve the problem.

    Quite maddening problem. It obviously doesn't seem to have much problem waking up. Power button wake seems good, even the swipe seems good despite causing display corruption. Is the frame buffer goofed or something? Why only on swipe? It's not like swipe is broken, it always works perfectly once it's "alive"....
    It's not like the swipe-to-wake is always broken either. Sitting next to my desktop at night, it generally seems much better behaved than on the bus during the day.

    I suppose I shall put up with it until Playbook v2 comes out, whenever that happens.
    09-10-12 11:49 PM
  11. Hawnz's Avatar
    Status update:
    I didn't bother trying to send it in, I think it was just past 1 year when I first started getting problems and I couldn't really live without it anyways.

    It seemed to get progressively worse as time went on. To the point where I actually stopped using the swipe to wake up. I'm not sure why, but the power button wake-up seems significantly more reliable.
    I did a full OS re-install, but that didn't solve the problem.

    Quite maddening problem. It obviously doesn't seem to have much problem waking up. Power button wake seems good, even the swipe seems good despite causing display corruption. Is the frame buffer goofed or something? Why only on swipe? It's not like swipe is broken, it always works perfectly once it's "alive"....
    It's not like the swipe-to-wake is always broken either. Sitting next to my desktop at night, it generally seems much better behaved than on the bus during the day.

    I suppose I shall put up with it until Playbook v2 comes out, whenever that happens.
    Maybe you should install the beta
    09-11-12 12:07 AM
  12. inzpirez's Avatar
    Happened to me too.as far as I remember it didn't occur on os1.0. My solution is similar to what posted above. Shutdown the screen using the button and wake it up by swiping across the screen. I've wiped the os,reinstall it, install a beta 2.1 and the problem is still there. I'm thinking it is more a hardware prob rather than software. Also, what I realized is that it happens more frequently when I use silicone case compared to the 'book style' case. My guess, the latter case has put too much stress on the screen thus causing the prob to occur.
    09-11-12 12:35 AM
  13. swbeveridge's Avatar
    I am having the same issue with a brand new 32 gb. Hard reboot, wipe and reinstall do not fix the problem. I have logged a ticket with RIM, and I think it may end up I will have to return it. In fairness, this our fourth playbook, and the only one with issues.
    09-11-12 11:51 PM
LINK TO POST COPIED TO CLIPBOARD