1. kevdasev's Avatar
    love my playbook, couldnt live with out it. use it every day. its awesome... what im about to tell you has happened once before, but i was able to solve the problem. this time however its a different case. out of the year and few months of having it, this has happened twice. first time it happened it was like 2-3 months ago. and i was just using it, normally, web browsing whatever... and i'm not too sure how it happened. but it wouldnt turn on, at all. i would press the power button, and the screen stayed the pitch black like it was off. but when i pressed it again, or tried to wake it up with the swipe gesture, the screen staying black, would light up a little. a lighter pitch of black.. so i guess it like turned on? or something.. so i was like ok, im just gonna let the battery die and charge it back up so i can use it again. i waited for a few days, it worked. my playbook was fixed...

    THIS time is a little different.. same thing happened, it seemed to like power off. but after a couple times of toggling with the power button, the screen wouldnt go to the lighter black as it did before.. so i connected it to the computer, charged it a little to see what'll happen. nothing. my playbook has been lying on my desk, just dead in need of help for a few days... every few hours when i get home and get the chance (about 2 times a day approximately) i would try to turn it on but nothing. its dead. just there. no response at all. PLEASE HELP, i miss my pb
    12-20-12 10:02 PM
  2. rotorwrench's Avatar
    Are you continuing to try and charge it via computer? Is that your predominant method of charging? Just curious as most any computer USB current output in insufficient to fully charged the PB and I'm wondering if you've just been doing partial charges. Have you tried charging with the PB charger?
    12-20-12 10:44 PM
  3. CairnsRock's Avatar
    If you are using the usb port to charge, it could be a faulty connection. The usb ports are a known weak point. You might want to try a charging dock or rapid charger, which use the charge port.
    12-20-12 10:53 PM
  4. kevdasev's Avatar
    no i usually charge it through the regular power cord
    12-20-12 10:55 PM
  5. FF22's Avatar
    Do you generally run the power down low?

    In any event, PRESS and HOLD the power button for 15-20 seconds and then leave it alone for about that long again and see if it comes back to life.

    Here's some more on restart

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.

    Stack charge may be necessary


    The PlayBook OS currently shuts down at 3.5 volts. When the battery gets below 2.67V it won't show power lights or even try to start because there isn't enough juice to even power the processor to run the code on the BIOS. The BIOS is software hard coded on a chip within the PlayBook that tells it how to load the PlayBook OS and is coded such that it only recognizes signed PlayBook boot images (which is why it is so hard to root and that nobody has been able to get one to boot Android or WebOS. The BIOS software also contains some charging algorithms for when the OS is not running - ie device is powered off but plugged into a charging source. This code ONLY runs when the battery is above 2.67 volts because the processor can't run below that.

    The root of the problem is that this design issue prevents the device from accepting any charge longer than 60 seconds when the battery is too low to run the charging algorithms on the BIOS or on the OS (one runs before the device is powered on and one runs afterwards). RIM did this because Lithium Ion batteries have a nasty habit of catching fire if not charged properly so they wanted to ensure that the processor could be in control of the charging. Makes perfect sense and they probably thought they were avoiding situations like where early Li Ion batteries on laptops were catching on fire. The problem is they were a bit too aggressive in dealing with the problem at design stage. If the battery is below 2.67Volts their protective algorithms can't run but you also can't put enough charge into the battery to charge it! Hence all the reports of people having success with stack charging.

    Unfortunately there are a lot of wrong ways to do this floating around out there and getting repeated everyone someone posts a new thread on the issue. It really should be made a sticky. What is the right way?

    1) ONLY use a source that provides 1.7Amps or more of charge. The original charger provides this. The rapid chargers provide a lot more. Your phone charger only provides a fraction of this. Anything less is going to take forever to charge the battery above 2.67 volts and may not have enough juice to charge the battery AT ALL once the processor starts to run above 2.67Volts or even worse once the OS starts to run above 3.5Volts. Forget about using your computer to charge it when the OS isn't running as the computer looks for the hardware to identify itself and won't put out a full charge current unless the device indicates it can accept. Once the OS is running, you'd often CAN get enough power from the USB on the computer but that is because the OS has signaled it is OK for the computer to send it. When the OS/BIOS isn't running, the PlayBook won't take much/any charge from a computer. The rapid chargers are best as they quickly charge but more importantly do not use the (too) flimsy USB port. A lot of problems are caused by this port getting wobbly over time and the device not getting a charge at all. Everyone should have a rapid charger.

    2) Until you get your device WELL above the 3.5Volts that let's the PlayBook boot, do NOT try to start it. Every attempt drags the battery down some more and that attempt sucks much more charge from the battery than you can put in in those 60 seconds before the hardware shuts down the charging. How can you tell where your battery is? Well if you are getting no lights on the playbook on your first charging attempt you are below 2.67volts. If lights go on and then it doesn't start the OS it is below 3.5Volts. If it loads the OS and then dies it is just above 3.5Volts. If the device loads the OS it is somewhere below 5.0Volts. Depending upon where you start (how low the battery is) various techniques work best. They are: REAL stack charging (plug in for 60 seconds, unplug, plug in for 60 seconds, repeat until the processor starts accepting charging (the big battery symbol on the screen). Again, DO NOT try to turn the device on until then. You are just working against yourself and it will take much longer. You should get the charging symbol within 20-45 minutes of repeated REAL stack charging. Forget you ever heard of plugging in for 2 mins and then off for 2 mins and similar as those 2 mins of off time are COMPLETELY worthless. I have put a multimeter on the PlayBook in this state and it NEVER takes more than a minute of charge when under 2.67volts but will accept another minute of charge after a short (1-2 second) disconnection. Just do it right.

    3) Once you see that charging screen leave it plugged in to the charger (stop stack charging) for at least an hour before you try to start the PlayBook. If you don't you may end up in a situation where the attempt to start drags that battery back down below 2.67V and you have start stack charging again. Be patient, you are almost there!

    4) Fully charge your Playbook after this to ensure your PlayBook gets back to 100%.

    Unfortunately, there isn't a lot RIM can do about this now. It's a hardware design issue. I'd be interested in knowing if the fixed it with the 4G versions. I don't think I've ever seen that complaint with one of those but I've "fixed" both of mine a few times (the kids keep trying to power them on after letting them shut down on low battery despite me saying time RUN not walk and put it on a rapid charger when ever it hits the flashing red battery signal (9%). I've also helped many friends and people on the web and NOBODY who has followed the instructions has failed to get their PlayBook to charge.

    I'm convinced this fault is the reason so many PlayBooks are returned to the stores and through RMA. RIM has been very good about this but it should never have happened. Happy Charging!

    Report back and a Debrick may be necessary to try

    Try the Debrick method....

    Perform a backup of your pb if you can using Desktop Manager or, at least, manually coping any unique data, photos, voice recordings, documents, etc.

    1) Turn your playbook OFF by holding down the power button
    2) Let your playbook sit for about 10 minutes as earlier suggested.
    3) After letting the PB sit (and still powered off) open up the Blackberry Desktop Software (the latest version)
    4) Once the Blackberry Desktop Software is opened, use the USB Cable and hook the PB to the PC.. THEN power on the Playbook
    5) A screen will show on your computer showing that the device cannot be found
    6) Click on Update. It will take awhile
    David in Durham likes this.
    12-20-12 11:15 PM
  6. SK122387's Avatar
    If all this doesn't work, call RIM. They're so good about troubleshooting, just make sure you have like an hour or so to work with them. They usually will replace your PlayBook with a brand new one, after the troubleshooting efforts fail.
    12-20-12 11:18 PM
  7. kill_9's Avatar
    OP, you have to use the wall adapter to recharge the battery of the BlackBerry PlayBook and allow a good 24 hours even though it does not require 24 hours. Then with the tablet connected to the wall adapter power-up the tablet. Check the battery charge level. NOTE: Be absolutely certain the microUSB connector is seated correctly in the USB port and not loose or slightly off to one side. There is a 0.00001% probability you have a faulty battery although it happens from time-to-time. Good luck!
    12-20-12 11:37 PM
  8. 991514982a's Avatar
    Typically the stack charging method helps playbooks with dead batteries come back to life. However the OPs situation is different. He was using the playbook and it just turned off and now is stuck in off. Therefore you can not apply the solutions that you'd typically use on playbooks with dead batteries or blinking yellow or red lights.

    Try this... get a set of prying tools (a thin guitar pick works well as well) to take the back cover off the playbook (start at the gap where the buttons are and work your way across). Unscrew the two screws that holds the battery connector with the motherboard, disconnect the connector from the motherboard (wait for a minute or two), then reconnect either USB cable or Rapid Charger to the playbook and attempt to turn on. Sometimes you'll need to hold the power button while disconnecting and then reconnecting your power supply to trigger reboot/restart

    scared for my playbook-batteryproblem.jpg
    Last edited by 991514982a; 12-21-12 at 01:03 AM.
    12-21-12 12:52 AM

Similar Threads

  1. Do I need a screen protector for my playbook?
    By tdan198 in forum BlackBerry PlayBook
    Replies: 8
    Last Post: 06-22-11, 01:32 PM
  2. I want a CB icon/app for my PlayBook
    By frfghtr in forum PlayBook Apps & Games
    Replies: 1
    Last Post: 05-09-11, 10:35 AM
  3. Found a nice case for my Playbook
    By Blkacesvf41 in forum BlackBerry PlayBook
    Replies: 0
    Last Post: 05-02-11, 06:42 AM
  4. Promo video for my PlayBook app
    By TheMarco in forum PlayBook Apps & Games
    Replies: 23
    Last Post: 04-18-11, 11:40 PM
  5. I'm Scared For My BB :(
    By 364ll in forum Rehab & Off-Topic Lounge
    Replies: 7
    Last Post: 02-09-10, 07:08 PM