1. anon3396357's Avatar
    My Playbook of 2 years had just bit the dust, or at least so I think. I've scoured the web for information on reviving a dead PB and stuff, but what happens is my PB is currently exhibiting some weird behaviour:

    1. Plug in charger (came with the PB, yellow tip Micro USB charger)
    2. Solid Red LED for 10s, then off
    3. Red battery icon with a lightning bolt through it in the middle of the screen, then off
    4. Solid Yellow LED for a few seconds, then off
    5. Glowing Yellow LED for a minute or two
    6. PB boots up, gets through setup
    7. Ends up at "Battery Critically Low" screen, battery at 0%

    I've left the charger plugged in for the past 3 days but it has never gone up. Pulling out the charger shuts the PB off immediately, plugging it in repeats 1-7 all over again. I'm compelled to believe that my battery has died (like seriously dead, rather than having a low voltage), but I'm not 100% sure. I'm considering to buy a magnetic rapid charger off Amazon, but at the same time have no qualms dumping the PB into the thrash. Already using an iPad so the PB is not mission critical.

    It has come to a point where I'm not too willing to buy and ship a magnetic rapid charger even if it's $15, but I'd like to know what you guys think.
    04-29-13 09:57 AM
  2. joshua_sx1's Avatar
    I'd like to know what you guys think.
    Hmm... if you are going to stock or put your tablet (like the PlayBook) in hibernation for two years, better to cover it with plastic or put it inside a box so it will not collect dust...

    Let's hear from others...


    Posted via Z10
    04-29-13 10:11 AM
  3. Rickster1's Avatar
    Sounds like you need to stack charge it. basically charge it for a minute, unplug charger, charge it for a minute, unplug charger. Repeat as necessary or vary the time that you charge it. i.e. quicker charges versus lonver. If you are still getting the warning battery low before you try this, you should be able to revive it. Worth a try!
    04-29-13 10:18 AM
  4. anon3396357's Avatar
    Hi guys thanks for the replies so far. My PB has actually been in active use so far, but it just died one day. I've tried reloading the OS, but could never complete the setup because once it reboots there isn't enough juice in the battery to boot up. I've tried the stack charge method a number of times as well, except without the magnetic charger.
    04-29-13 10:54 AM
  5. FF22's Avatar
    Could it be the charging adapter that is the problem? They can go bad. Know anyone with a pb where you could borrow their charger?

    Give the following a read and see if any of it might help:

    More Mapsonburt:

    Don't keep trying if you get the Red light/5 Yellows... you'll soon drag the battery down past where you can start it again. Leave it off, plug it in and let it charge (with at least a 1.8A charger). Once you get the flashing (once every few seconds) green light, you can power it up - on the charger. If you do drag it down below the red flash/5 yellows, plug it in for 1 minute, unplug (at the wall) for a second or so, plug it back in and repeat for 20-30 minutes. You'll eventually get the red/yellows and then leave it plugged in (and off) until you get the flashing green. It's a PITA but the PlayBook has a very conservative charging algorithm when the battery is below 2.67 Volts to prevent explosions (I'm guessing). I've never been unable to start one with that method.

    Mapsonburt:


    The PlayBook OS currently shuts down at 3.5 volts. When the battery gets below 2.67V it won't show power lights or even try to start because there isn't enough juice to even power the processor to run the code on the BIOS. The BIOS is software hard coded on a chip within the PlayBook that tells it how to load the PlayBook OS and is coded such that it only recognizes signed PlayBook boot images (which is why it is so hard to root and that nobody has been able to get one to boot Android or WebOS. The BIOS software also contains some charging algorithms for when the OS is not running - ie device is powered off but plugged into a charging source. This code ONLY runs when the battery is above 2.67 volts because the processor can't run below that.

    The root of the problem is that this design issue prevents the device from accepting any charge longer than 60 seconds when the battery is too low to run the charging algorithms on the BIOS or on the OS (one runs before the device is powered on and one runs afterwards). RIM did this because Lithium Ion batteries have a nasty habit of catching fire if not charged properly so they wanted to ensure that the processor could be in control of the charging. Makes perfect sense and they probably thought they were avoiding situations like where early Li Ion batteries on laptops were catching on fire. The problem is they were a bit too aggressive in dealing with the problem at design stage. If the battery is below 2.67Volts their protective algorithms can't run but you also can't put enough charge into the battery to charge it! Hence all the reports of people having success with stack charging.

    Unfortunately there are a lot of wrong ways to do this floating around out there and getting repeated everyone someone posts a new thread on the issue. It really should be made a sticky. What is the right way?

    1) ONLY use a source that provides 1.7Amps or more of charge. The original charger provides this. The rapid chargers provide a lot more. Your phone charger only provides a fraction of this. Anything less is going to take forever to charge the battery above 2.67 volts and may not have enough juice to charge the battery AT ALL once the processor starts to run above 2.67Volts or even worse once the OS starts to run above 3.5Volts. Forget about using your computer to charge it when the OS isn't running as the computer looks for the hardware to identify itself and won't put out a full charge current unless the device indicates it can accept. Once the OS is running, you'd often CAN get enough power from the USB on the computer but that is because the OS has signaled it is OK for the computer to send it. When the OS/BIOS isn't running, the PlayBook won't take much/any charge from a computer. The rapid chargers are best as they quickly charge but more importantly do not use the (too) flimsy USB port. A lot of problems are caused by this port getting wobbly over time and the device not getting a charge at all. Everyone should have a rapid charger.

    2) Until you get your device WELL above the 3.5Volts that let's the PlayBook boot, do NOT try to start it. Every attempt drags the battery down some more and that attempt sucks much more charge from the battery than you can put in in those 60 seconds before the hardware shuts down the charging. How can you tell where your battery is? Well if you are getting no lights on the playbook on your first charging attempt you are below 2.67volts. If lights go on and then it doesn't start the OS it is below 3.5Volts. If it loads the OS and then dies it is just above 3.5Volts. If the device loads the OS it is somewhere below 5.0Volts. Depending upon where you start (how low the battery is) various techniques work best. They are: REAL stack charging (plug in for 60 seconds, unplug, plug in for 60 seconds, repeat until the processor starts accepting charging (the big battery symbol on the screen). Again, DO NOT try to turn the device on until then. You are just working against yourself and it will take much longer. You should get the charging symbol within 20-45 minutes of repeated REAL stack charging. Forget you ever heard of plugging in for 2 mins and then off for 2 mins and similar as those 2 mins of off time are COMPLETELY worthless. I have put a multimeter on the PlayBook in this state and it NEVER takes more than a minute of charge when under 2.67volts but will accept another minute of charge after a short (1-2 second) disconnection. Just do it right.

    3) Once you see that charging screen leave it plugged in to the charger (stop stack charging) for at least an hour before you try to start the PlayBook. If you don't you may end up in a situation where the attempt to start drags that battery back down below 2.67V and you have start stack charging again. Be patient, you are almost there!

    4) Fully charge your Playbook after this to ensure your PlayBook gets back to 100%.

    Unfortunately, there isn't a lot RIM can do about this now. It's a hardware design issue. I'd be interested in knowing if the fixed it with the 4G versions. I don't think I've ever seen that complaint with one of those but I've "fixed" both of mine a few times (the kids keep trying to power them on after letting them shut down on low battery despite me saying time RUN not walk and put it on a rapid charger when ever it hits the flashing red battery signal (9%). I've also helped many friends and people on the web and NOBODY who has followed the instructions has failed to get their PlayBook to charge.

    I'm convinced this fault is the reason so many PlayBooks are returned to the stores and through RMA. RIM has been very good about this but it should never have happened. Happy Charging!


    ........................
    The battery is likely below 2.65 volts. That happens if the PlayBook has sat for a while. Plug your charger into the playbook (make sure it's the stock charger and not a computer or other charger as you need to pump in lots of amps - more than 1.7amps - the more the better). The rapid charger is even better as it can go to 5 amps.

    LEAVE the charger plugged into your PlayBook. Unplug it from the wall (to save the fragile micro-USB port) every minute for a few seconds and plug back in. You'll see lots of references on the web to plug in for 2 minutes and unplug for 2 minutes. Ignore those. I took the PlayBook apart and put a multimeter on mine when it was doing this. If the battery is below 2.65 volts, the PlayBook charging circuit charges for about 1 minute and then shuts down. NO AMOUNT of continued charging makes any difference. As soon as you unplug it (at the wall) and power it back up, it will take charge again for another 45-60 seconds. Repeat.

    Keep doing that for as long as it takes to get the screen to show the charging display. If it is just below 2.65volts, it will take somewhere between 20-45 minutes as the battery only takes a little bit of charge each cycle and you need to get that voltage up over 2.65 volts (at which point it will show the charging display and take a full charge). It may take more... but keep at it. Every time you plug it in for 60 seconds, you are adding a bit more power to the battery.

    DO NOT try to power the device on until the device has a full charge. You will just risk getting it into a situation where it can't fully boot before it drags the charge down below 2.65 volts again and you'll have to start all over.

    This works... and saves you from having to jump start it like I did the first time I got mine into this situation.

    ----------------------

    KB27705-BlackBerry PlayBook battery power charge, discharge characteristics, and guidance on extending battery life
    04-29-13 10:55 AM
  6. anon3396357's Avatar
    Hey F2, I've seen your posts a lot and thanks for the information I've tried all those as well to no avail. The PB charger works fine on my Samsung Galaxy Note 2 so that rules out a faulty charger. That's the reason why I believe that my PB is really dead, maybe the bootloader is FUBAR or something. What really bewilders me is that my PB responds to the PB charger as mentioned in my original post in the manner how the usual dead PB would get revived - but stops short at the final step where you're just supposed to leave it plugged in for 24 hours or something. It's been 72 hours and it's still 0% for me.
    04-29-13 11:07 AM
  7. FF22's Avatar
    It could be really dead - that is some aspect of the charging circuit could be bad. I've never been inside one. I guess since you are probably beyond warranty you could open it up and see if something obvious has come loose. Now that I think (rare), I thought someone mentioned that in the UK the warranty might be two years???? If you are close, maybe you could still get help from rim.

    Good luck
    04-29-13 11:33 AM
  8. bsiegle's Avatar
    I had the same problem, but it was under warranty. BlackBerry replaced my unit.
    04-29-13 03:49 PM
  9. johnierw's Avatar
    DG I just had a similar thing happen to me, but I had traveled out of state and mine stopped charging almost immediately?? When I gothome the PB started up normally, but the battery read 0 volts although it had been plugged in for over a week!! I got home plugged it in and 5 minutes later it was charging. F2 said don't ask to many questions and thank the PB God for the assist! I would check your outlets or try a different power source or someone else's house? I think that was my issue was bad power in the hotel I was staying, but don't quite know for sure. Best of luck!
    Hey F2, I've seen your posts a lot and thanks for the information I've tried all those as well to no avail. The PB charger works fine on my Samsung Galaxy Note 2 so that rules out a faulty charger. That's the reason why I believe that my PB is really dead, maybe the bootloader is FUBAR or something. What really bewilders me is that my PB responds to the PB charger as mentioned in my original post in the manner how the usual dead PB would get revived - but stops short at the final step where you're just supposed to leave it plugged in for 24 hours or something. It's been 72 hours and it's still 0% for me.
    04-29-13 07:28 PM
  10. Angus_CB's Avatar
    I have one that acted that way.
    I pulled the back off, disconnected the battery for a minute, reconnected the battery and stack charged it.
    There are YouTube videos and posts on this forum that show how to do this.
    It's working fine now.
    Be patient when stack charging. Once it starts to charge leave it for at least 24 hours.
    04-30-13 05:39 AM

Similar Threads

  1. Dead Playbook in Best Buy
    By ultra07 in forum BlackBerry PlayBook
    Replies: 42
    Last Post: 10-04-11, 09:15 PM
  2. Dead PlayBook - Flashing Red Light
    By Connor_BB in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 09-04-11, 12:16 PM
  3. Dead Playbook
    By kmcaustin in forum BlackBerry PlayBook
    Replies: 2
    Last Post: 05-20-11, 02:45 PM
  4. how do you revive a dead blackberry?
    By sito in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 11-15-09, 04:02 PM
  5. How do i revive a dead blackberry with connectivity issues?
    By dre_rob85 in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 07-26-08, 06:18 PM
LINK TO POST COPIED TO CLIPBOARD