01-20-13 11:32 PM
41 12
tools
  1. Eli Bret's Avatar
    Wi-Fi connectivity - How about to make this thread a place to post our fixes and solutions to this particular problem?
    I know how frustrating it can be when you browse thru the forums and internet and cannot find anything constructive to have something fixed. It drives you nuts. Most people around there do not care about technical aspect of things, they just want their pieces of hardware to work and do what the device was designed to do. It may help people out there to restore their faith into their Playbooks in this case.
    In my incident right after the update to 2.0.1 Playbook Wi-Fi connection became unstable. Playbook would be dropping connection only to restore it within a minute or so and it was a vicious, never ending cycle. My whole house network would work with no issues, including Wi-Fi connected laptops. What did it do for me?
    This solution works for D-Link router DIR-825 (Hardware Version: B1, Firmware Version: 2.06NA). It might work for the other brands but you need to find location of the settings on the router setting pages.
    Log in to your router, locate Advanced tab on the top of page, go to Advanced Wireless in the right and make sure WMM box is unchecked for both, 2.4 and 5MGz. Restart your router. (WMM stands for Wi-Fi Multimedia, This technology maintains the priority of audio, video and voice applications in a Wi-Fi network so that other applications and traffic are less likely to slow them.)
    This single settings change fixed my Wi-Fi connection problem and the result was instant - without PB reboots, resets and restarts.
    I must say before I got to this solution I followed also the advice I found on D-Link forums related to Playbook issues in general and tweaked some other router settings as follow:
    1. In Network Settings turn on DNS Relay
    2. In Advanced Wireless uncheck box Short GI
    3. In Firewall Settings mark Endpoint Independent for both UDP and TPC
    4. In Wireless Settings for both bands Security Mode: WPA-Personal, WPA Mode: Auto (WPA or WPA2), Cipher Type: TKIP and AES
    I hope this help and we can save some Playbooks our there from being exposed to flying lessons.
    04-22-12 09:17 AM
  2. ct19's Avatar
    For me the solution is to switch back to b+g mode an not b+g+n ist may be slower but it was the only thing that really works.
    Last edited by ct19; 04-22-12 at 04:14 PM.
    04-22-12 09:26 AM
  3. Scotter75's Avatar
    KB 26522 states not to allow 802.11n to use TKIP or WEP data encryption.
    PatrickMJS likes this.
    04-22-12 10:11 AM
  4. Eli Bret's Avatar
    KB 26522 states not to allow 802.11n to use TKIP or WEP data encryption.
    You can omit my advice in 1 thru 4, it's optional. Disabling WMM restored functionality of Wi-Fi for me. You can set cipher type to AES, it works faultlessly.
    04-22-12 10:35 AM
  5. PatrickMJS's Avatar
    Wi-Fi connectivity... right after the update to 2.0.1 Playbook Wi-Fi connection became unstable. Playbook would be dropping connection only to restore it within a minute or so and it was a vicious, never ending cycle. My whole house network would work with no issues, including Wi-Fi connected laptops. What did it do for me?
    This solution works for D-Link router DIR-825 (Hardware Version: B1, Firmware Version: 2.06NA). It might work for the other brands but you need to find location of the settings on the router setting pages.
    Log in to your router, locate Advanced tab on the top of page, go to Advanced Wireless in the right and make sure WMM box is unchecked for both, 2.4 and 5MGz. Restart your router. (WMM stands for Wi-Fi Multimedia, This technology maintains the priority of audio, video and voice applications in a Wi-Fi network so that other applications and traffic are less likely to slow them.)
    This single settings change fixed my Wi-Fi connection problem and the result was instant - without PB reboots, resets and restarts.
    I must say before I got to this solution I followed also the advice I found on D-Link forums related to Playbook issues in general and tweaked some other router settings as follow:
    1. In Network Settings turn on DNS Relay
    2. In Advanced Wireless uncheck box Short GI
    3. In Firewall Settings mark Endpoint Independent for both UDP and TPC
    4. In Wireless Settings for both bands Security Mode: WPA-Personal, WPA Mode: Auto (WPA or WPA2), Cipher Type: TKIP and AES
    Hey Eli,

    I have the D-Link DIR-825 and it has been working fine since I got it last summer. I never needed to go in and tweak any settings at all. The PB, phones, laptops, ipads, wdtv, all these devices work fine with it. I checked my settings and they are different from what you have advised. These are the settings my 825 had out of the box.

    WMM - you said to uncheck these but I have them both checked and the router works fine with all my devices.

    Short GI: you said to uncheck this, but I have it checked and all is working fine.

    My firewall settings are not what you recommended... for TDP: "port & address restricted"; for UDP: "address restricted". Again, all working fine.

    Cipher type: you mentioned using "AES & TKIP". As far as I know, TKIP only works for WPA, not WPA2, and only when the router is not using the "N" band. My router's cipher type is set to AES for both WPA & WPA2, and it is working fine, no problems with any of my devices, including my PB.

    Bottom line: for people reading threads like this, these wifi solutions sound terribly complex but are often unnecessary. In my case, all the default settings worked fine as they were right out of the box. All I had to do was specify the password.

    I'm glad to hear Eli got his issues dealt with, but using the very same router, I had none of these wifi issues using the router's default settings.
    04-22-12 12:23 PM
  6. tinker2000's Avatar
    I had mine recently change to N only, 2.01 messed it up with AES/TKIP... Set back to BGN mix and works again. Bit pissed off because I dont need B or G. Cisco ADSL router
    04-22-12 02:00 PM
  7. Eli Bret's Avatar
    Patrick, I do understand my case is not universal, nor the solutions I used.
    I should add in my post: "If it's not broken don't touch or fix - just use it" but wrongly I assumed it would be clear. Maybe it has something to do with firmware or hardware versions or maybe not. It worked for me. Steps 1-4 are optional and no, you do not have to try it or change your settings if they work.
    The purpose for the thread was to help not to provide yet another field for criticizing or challenging each other.
    BigAl_BB9900 likes this.
    04-22-12 02:01 PM
  8. aminrajabi's Avatar
    I have a CISCO router and disabling WMM fixed my Wifi issue as well.

    Thanks OP!
    04-22-12 02:15 PM
  9. samab's Avatar
    (1) Your DIR-825 rev B has a newer firmware --- should have updated your router's firmware first.
    (2) WMM means TWO things --- (1) letting media traffic goes first and (2) power saving technology.

    Wireless Multimedia Extensions - Wikipedia, the free encyclopedia

    How does WMM Power Save work? | Wi-Fi Alliance

    If you have wifi connection problems and turning off WMM fixed your wifi connection problems --- it means that your router sends a signal to the Playbook to tell the Playbook's wifi radio to fall asleep. Somehow, either the router or the Playbook fail to wake up the wifi radio.

    Some routers have separate WMM controls for media traffic QoS and power saving --- you only have to turn off the power saving part.
    Last edited by samab; 04-22-12 at 03:53 PM.
    Eli Bret likes this.
    04-22-12 03:08 PM
  10. BB_Bmore's Avatar
    Just got a patch update anyone else?
    04-22-12 04:04 PM
  11. Eli Bret's Avatar
    Here where I am now. I did modify only WMM (unchecked) and all works well. But after reading the suggestions posted here I switched WMM back (check the box on) to test it again. As soon as I did it the wifi went wild again and the connection kept looping on and off never staying on for long. As I said on the begining I'm back with WMM switched off for now enjoying my Playbook (and my wife enjoys hers). I will try to check on D-Link site if there are any seperate settings for power saving (thanks SAMAB).
    On the side note, the Wi-Fi connection seems to be "smoother" after router fix than it was before update to 2.0.1, but it's just a feel not a proven test.
    04-22-12 07:01 PM
  12. chiniki's Avatar
    Thanks to the OP my PB and my wife's can finally stay connected to the Wifi!
    04-22-12 09:23 PM
  13. samab's Avatar
    First thing you should do is to update your router's firmware.

    Then you work with the most simple wifi configuration --- 802.11g only, WPA2 with AES and WMM off.

    Then you work with 802.11n only, narrow channel only, WPA2 with AES, and WMM off.

    Then you work with WMM on to see if there is a problem. WMM Power Save is a known problem for EVERYBODY --- android phones have problems with it, iphones have problems with it... --- and the problem is mostly outdated router firmware.
    Last edited by samab; 04-22-12 at 09:51 PM.
    04-22-12 09:42 PM
  14. kbz1960's Avatar
    Just for comparison my netgear wndr3700 settings. No problem with wifi.
    Last edited by kbz1960; 04-26-12 at 05:07 PM.
    04-26-12 05:02 PM
  15. mpcook's Avatar
    Just for comparison my netgear wndr3700 settings. No problem with wifi.
    Same router, same settings, pb wireless works great on on either band.
    04-26-12 08:53 PM
  16. conix67's Avatar
    My router is different but also from D-link (655) and it works fine with default settings.

    PB still loses Wifi connection (not signal drop) at work even with 2.0.1 update and it's driving me nuts.
    04-26-12 11:52 PM
  17. chaosdivine's Avatar
    Patrick, I agree with your post here - you can leave 99% of the settings at default and you only need to change FROM wireless N TO wireless G for it to work reliably.

    Anyhow, I too have a DIR-825 and JUST (as in today) got my new Playbook and had a LOT of problems getting it to work reliably on my network. There is definitely a bug with the Playbooks and wireless N network connectivity. I am starting to wonder if this bug is the reason I got such a deal on the Playbook at firesale prices (32 GB for $149 with free BB Branded leather case). The update patch to 2.0.1.358 actually made things worse for me than out of the box.

    The only thing that worked for me was to set my wireless settings to G and not N and otherwise my settings are identical to yours. I found that my wireless settings completely failed for all my houses's laptops and computers (several) if I unchecked WMM. I mean I couldn't even connect to the router via wireless after that to change settings back (from any computer). I had to tether it via Ethernet cable to get access to the router again. I was so frustrated to say the least...

    Anyhow, in my trials I messed with so many settings that I decided to do a factory reset of the router and ended up going with the defaults. After running around the house redoing wireless connections with new pass phrases, low and behold all my computers worked again but not the Playbook - until I read that others were saying, ditch N and use G. Once I did this change, I have no problems - except for the reduced broadcast distance in my house that I enjoyed with N connectivity.

    So, does anyone actually have some updated news from tech support on this? Is there a beta fix or patch to be able to use N connectivity again? So far, I like the playbook and would gladly keep it but this network bug is a HUGE problem. No wonder people are returning these things left right and centre, I mean there is a serious flaw when a wifi tablet CAN'T connect to the damn network reliably...

    I don't mind waiting for a real fix but I would like to know if indeed this is actually going to happen in my lifetime.

    Any updated feedback on the permanent fix for this from forum members would be great to hear...please and thank you!


    Hey Eli,

    I have the D-Link DIR-825 and it has been working fine since I got it last summer. I never needed to go in and tweak any settings at all. The PB, phones, laptops, ipads, wdtv, all these devices work fine with it. I checked my settings and they are different from what you have advised. These are the settings my 825 had out of the box.

    WMM - you said to uncheck these but I have them both checked and the router works fine with all my devices.

    Short GI: you said to uncheck this, but I have it checked and all is working fine.

    My firewall settings are not what you recommended... for TDP: "port & address restricted"; for UDP: "address restricted". Again, all working fine.

    Cipher type: you mentioned using "AES & TKIP". As far as I know, TKIP only works for WPA, not WPA2, and only when the router is not using the "N" band. My router's cipher type is set to AES for both WPA & WPA2, and it is working fine, no problems with any of my devices, including my PB.

    Bottom line: for people reading threads like this, these wifi solutions sound terribly complex but are often unnecessary. In my case, all the default settings worked fine as they were right out of the box. All I had to do was specify the password.

    I'm glad to hear Eli got his issues dealt with, but using the very same router, I had none of these wifi issues using the router's default settings.
    09-15-12 09:40 PM
  18. kbz1960's Avatar
    Have you looked to see if there is a new firmware for your router?
    09-15-12 10:03 PM
  19. chaosdivine's Avatar
    Have you looked to see if there is a new firmware for your router?
    Hey there kbz1960...I think you were replying to me - no? Forgive me for barging in if not and thank you for doing so if indeed you were talking to me.

    In answer to your question, I am running the latest firmware available for the DIR-825 (updated from 2.06NA to 2.07NA). Not sure if it's the router or the Playbook itself. See, in my household, I have three laptops, two desktops, one iPad, one Touchpad and a Torch all work without issues at N connectivity. The only one that fails is the Playbook (2.0.1.358). It will work with G settings though. Strange eh?

    Thing is only 4.5 hours out of the box too from the store...makes me nervous.
    Last edited by chaosdivine; 09-16-12 at 04:58 PM. Reason: Found out my Firmware wasn't the latest after all. Still didn't fix probs though.
    09-15-12 10:47 PM
  20. kbz1960's Avatar
    Humm, in that case can you take it back for another? It may have a bad wifi chip.
    09-16-12 08:01 AM
  21. chaosdivine's Avatar
    Humm, in that case can you take it back for another? It may have a bad wifi chip.
    I bought it through an online sale with thesource.ca so I know I could take it back to the store if necessary. Just trying to figure out for sure if it's the router or the Playbook itself. I wish I had another N router to try so I could eliminate one or the other.

    There is definitely a problem with the DIR-825 and the BB Playbook for after I search the web on it further, there are lots of people with the same setup complaining about having the same problems. Using G mode instead of N mode seems to fix it as a work around. I stumbled upon another workaround that I have yet to implement myself yet, but I plan on doing it. Though the person I got this from is running a DIR655, I know I have the ability to create a similar network setup. I just have to figure out how to do it first...

    He talks about creating a Guest Zone and assigning that to the Playbook itself: "But thanks to D-Link's Guest Zone function, now I have a workaround, I created a guest zone (a separate network) with its own SSID, set guest zone's security to TKIP to force to G, now Laptop/iPhone connect to main network in N, PB connects to sub-network in G, works like a charm".


    So that's something I am going try first before making a further decision. Thanks for your reply by the way.

    (If there is anyone that is wondering, here is the thread that I was reading where this guy talks about his troubleshooting and test results. It is helpful. http://forums.hardwarezone.com.sg/bl...k-3255181.html)

    Update: So I got Guest Mode setup and have it configured to work with G settings and the Playbook works. My other computers use the separate network and all run in N mode fine as usual. So for now I will live with the PB living on G settings. I still don't know where the problem lies but I am leaning towards the router now. Disabling WMM mode will let the Playbook work but kills three computers running N. Not the fourth for some reason. I don't know where the problem actually lies. Spent a lot of time researching this so far still don't have a real answer. Will have to take the Playbook out of the house and see if I can connect to some wireless networks around the city and see what happens.
    Last edited by chaosdivine; 09-16-12 at 05:05 PM. Reason: Updated post with result of setting up guest mode - it works but in G mode.
    09-16-12 01:24 PM
  22. Eli Bret's Avatar
    Hello 'chaosdivine'...
    I realy feel your frustration over Wi-Fi connectivity issue. When I started this thread I went thru similar experience.
    Unfortunatelly I still do not know the nature of the problem. I do not know why and what is the real cause... I left it there not looking back since all is working fine on my end after disabling WMM in router settings.
    Just to clarify my Dir-825 hardware version is B1 and firmware 2.06na. I have DHCP server option enabled with 11 devices on the network incl. 2 PlayBooks. Both PBs run OS 2.0.1.668. WMM option is still unchecked. Smooth run since the original post.
    I can not give the right solution that would clear your problem, just words of wisdom: do not give up. I hope you'll find the right hardware/software setup solution.
    chaosdivine likes this.
    09-16-12 06:26 PM
  23. chaosdivine's Avatar
    Hello 'chaosdivine'...
    I realy feel your frustration over Wi-Fi connectivity issue. When I started this thread I went thru similar experience.
    Unfortunatelly I still do not know the nature of the problem. I do not know why and what is the real cause... I left it there not looking back since all is working fine on my end after disabling WMM in router settings.
    Just to clarify my Dir-825 hardware version is B1 and firmware 2.06na. I have DHCP server option enabled with 11 devices on the network incl. 2 PlayBooks. Both PBs run OS 2.0.1.668. WMM option is still unchecked. Smooth run since the original post.
    I can not give the right solution that would clear your problem, just words of wisdom: do not give up. I hope you'll find the right hardware/software setup solution.
    Thanks for your reply Eli.Bret - sincerely. I haven't given up yet and will eventually hunt this gremlin down (and if I figure it out, I will post detailed information here). But for now I have just let things work at G speeds. It works well but transferring files to and from the device over wi-fi is slow but otherwise it works fine. The device itself is a joy to use otherwise. I never use my Touchpad now.

    If you don't mind and have the time, I am curious to ask you to check something on the Playbook. Under the gear icon (Playbook settings - top right corner of interface) please go to Wi-Fi and under Diagnostic Information choose Wi-Fi Information from the dropdown menu and scroll down to Network Type. Does it indeed show 802.11 n? What is the connection rate? Just curious. I know mine says 802.11g and the connection rate says 54 Mbps right above it. I am using a security type of WPA2 Personal.

    Anyhow, I hear that the 2.1 OS release may help me in this situation. So I am hoping it drops soon so I can try it out. By the way I am running 2.0.1.358 and not OS 2.0.1.668 so maybe .668 does the trick too? Anyhow, I'll hold out a few days here for the 2.1 release and report back.
    Last edited by chaosdivine; 09-20-12 at 04:01 PM. Reason: Cleaned things up a bit.
    09-20-12 03:27 PM
  24. PatrickMJS's Avatar
    Here is my PB's wifi info.

    My DIR-825 is hardware version B1, firmware version 2.07NA.

    I'm on .358, not .668 like you. Doubt if that makes a difference.

    Good luck.
    chaosdivine likes this.
    09-20-12 03:36 PM
  25. chaosdivine's Avatar
    Thanks Patrick, I appreciate you taking the time to do that! If you say you're on .358 too (I am on .358) then I am lost...LOL! I hope you meant to say .668 and not .358...could you please clarify that? Thank you.

    Otherwise our router hardware is identical (DIR-825 version B1, firmware version 2.07NA).
    Last edited by chaosdivine; 09-20-12 at 04:07 PM.
    09-20-12 04:04 PM
41 12
LINK TO POST COPIED TO CLIPBOARD