1. SifJar's Avatar
    Over the last few days, I seem unable to download stuff from App World on either of my regular WiFi connections. Whenever I try, I either get Error [0003-0005] if it's a free app, or my PB will fail to login at the prompt if it's a paid app. I have tried (successfully) downloading via my phone configured as a WiFi hotspot and also via a "Guest WiFi" connection I have setup on one rooter (the normal connection on this same router being one of the troublesome connections). The Guest WiFi connection has WEP security, whereas the regular one has WPA2, but there has been no issue with the regular connection before and I've been using it for over a month. Everything else works fine on the regular connection too (browsing internet, browsing App World etc.)

    Anyone have any ideas of the problem, or even better, a solution? I'm considering making a backup and then security wipe and restoring the backup (which I think should restore all my apps and their data along with my BB ID etc., and basically return the PB to it's current state, hopefully without the problem, is that correct?), but I'll wait a few days and see if anyone has any better suggestions.

    EDIT: Well a little bit more googling led me to find a solution: deleting the WiFi profile and setting it up again. Seems to be working for at least one of the connections, can't test the other till the weekend but I have confidence now.
    Last edited by SifJar; 10-28-12 at 03:10 PM.
    10-28-12 02:58 PM
  2. FF22's Avatar
    Thanks for posting back. And, yes, that seems to be the oddball fix when wifi/appworld have problems - delete it and recreated it.

    Off-topic - is uber currency working again?
    10-28-12 04:42 PM
  3. SifJar's Avatar
    Thanks for posting back. And, yes, that seems to be the oddball fix when wifi/appworld have problems - delete it and recreated it.

    Off-topic - is uber currency working again?
    Actually, I had completely forgotten about UberCurrency again, sorry about that. Honestly, I do intend to look into it

    EDIT: Well, it seems the "Open Exchange Rates API" has become a paid for service. I guess I'll have to look elsewhere to get my exchange rates. It may take a while to find an alternative source and update the app accordingly. I apologise for this, I was under the impression the API would always be free to access. Without charging for the app (and getting a lot more downloads than it has currently), there is no way I could feasibly pay for the API access.

    EDIT: There is actually a free plan, which allows 1000 API requests per month. I will sign up for that and get it implemented. Will hopefully get an update pushed out in the next few days.

    EDIT: Fixed version has been submitted to App World. Now should also be available for Dev Alphas (I don't have one to test how it looks on those devices though, so it may be terrible).

    The plus side of all this is I can see how many people are using the app.
    Last edited by SifJar; 10-28-12 at 05:25 PM.
    FF22 likes this.
    10-28-12 04:53 PM

Similar Threads

  1. problem with my WIFI
    By yungstar in forum General BlackBerry Discussion
    Replies: 7
    Last Post: 11-03-11, 06:40 AM
  2. Strange Problem with my wifi and the router
    By systech in forum BlackBerry Bold 9000
    Replies: 2
    Last Post: 03-10-09, 06:23 PM
  3. WiFi Problems with my AT&T BOLD
    By caesarsj in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 11-11-08, 04:23 PM
  4. Little problems with my curve
    By 1FstYota in forum BlackBerry Curve 83xx
    Replies: 13
    Last Post: 07-29-07, 10:48 PM
  5. Strange problem with my Pearl...
    By JoeSacto in forum BlackBerry Pearl 8100
    Replies: 5
    Last Post: 04-27-07, 08:15 PM
LINK TO POST COPIED TO CLIPBOARD