1. tyshone1's Avatar
    Ok. Let me start out by saying, I am at the breaking point. Here's why.
    A couple of weeks ago my Playbook battery drained down to the point where it was unable to charge. I contacted tech support and we made several attempts to bring it back from the dead but all attempts failed. I sent it in under an RMA and eventually received a replacement unit. There was no indication that I was getting a replacement device and if I had not recorded the S/N I would have never known. However, it was like receiving a new device so I wasn't complaining. That is, not until I tried to complete the setup. The setup appeared to go according to plan until I reached the Software Update screen. A update was detected but when I tried to download, I received a (132353) could not activate this tablet error. I contacted tech support and according to the first engineer I spoke to, the tablet was in a "shelved" status and should have been activated before the device was shipped. I was then told that I would have to wait 48 hours for activation to complete. That conversation took place on Monday of this week and it is now Wednesday and I am no further along. I placed a call today and was told I would receive a status call back at the end of the day. Because the setup will not complete, the tablet is not usable. I am in the technical support business and this type of support would not fly. I am at the point of demanding a replacement or a refund.

    Do you think I am being a difficult customer?
    08-22-12 01:15 PM
  2. FF22's Avatar
    You are being a customer. Give another day.
    Kandoo-BB and DC506 like this.
    08-22-12 01:35 PM
  3. tyshone1's Avatar
    You are being a customer. Give another day.
    I am now at the 5th day with no resolution. I'm starting to have withdrawals.
    08-24-12 02:10 PM
  4. FF22's Avatar
    Have you contacted them again? It probably is time. Good luck
    08-24-12 04:22 PM
LINK TO POST COPIED TO CLIPBOARD