1. lp16's Avatar
    Hi, I'm a new PB user from Malaysia. I have this problem logging in to my wifi at home. It always shows me error about getting IP address, but my pc and Bold has no such issue.

    Anything wrong. I'm getting frustrated.....
    12-28-11 04:53 AM
  2. Crakzag's Avatar
    I had a problem with connecting earlier but resolved by pressing button on wifi box and allowing pb to connect without any further issues other than having to do once again after playing with wifi settings on device.
    12-28-11 08:48 AM
  3. lp16's Avatar
    I did that as well, even switching off the power source. I've tried many times, switching off whatever button I could think off......

    However, once in a while, I do get connected but then it'll just disconnect for no reason. My Bold and pc remains connected and the connection is very good. My router is only a few feet away from my PB.

    Is there any setting to be done. As far as I know, it is pretty straight forward. My PB searched for my network and it should connect automatically, right?
    12-28-11 11:02 AM
  4. anindoc's Avatar
    What kind of router are you using, if it b/g/n then you should try switching off the n- mode. Also try switching your router security from WAP2, into a different one, if thats what you are using.
    I would also suggest that you try rebooting your PB, if that dosent help do a hard reset and try connecting again.
    Hard reset= hold down the power, volume +/- buttons together until the PB shuts off, restart after a minute.
    12-28-11 11:08 AM
  5. lp16's Avatar
    Ok, I will try hard resetting my PB and see what happens. Hope it'll solve my connectivity mystery. Thanks.
    12-28-11 11:14 AM
  6. northern_skypilot's Avatar
    I think we've been experiencing the same problem? My wifi would time out/disconnect after 15 minutes or so. After being on the phone with RIM, the solution (fingers crossed!) was to simply reboot the router and do a hard reset on the PB. So far, 17 hrs. later, the connection is solid. Good luck.
    12-28-11 11:47 AM
  7. FF22's Avatar
    You might also consider going into the Router and disabling the N mode and limit your router to b/g.
    12-28-11 11:56 AM
LINK TO POST COPIED TO CLIPBOARD