1. jagrlover's Avatar
    Battery indicator reads 0. Unplug it and it will die after some time. Plug it back in and it charges for a bit and eventually turns itself back on. I can leave it charging for days and it stays at 0. Tried both the USB charger and the magnetic rapid charger. I can use it all I want while plugged in. All styles of reboots have been attempted. What now? Factory reset? I've got a friend a BlackBerry who tells me that the PB has 2 batteries and that the first one might be dead or something like that. Any ideas?

    Posted via CB10
    03-01-14 05:28 PM
  2. Gooseberry Falls's Avatar
    There are other accounts of this but I didn't see any answers on how to fix it. I dunno about the 2-battery thing from your BBRY contact. From the teardown info only seems to be one:
    BlackBerry PlayBook Teardown - iFixit

    It sure sounds like a dead battery. There is an app in BBRY World called Battery Guru. I think its a couple of dollars. It may tell you the state of the battery. Most people with the charging issue can't even get the PB to turn on with the charger connected. So, I don't know if yours is a software problem and reloading would help. Maybe someone else will chime in...
    03-01-14 06:29 PM
  3. jpash549's Avatar
    There are other accounts of this but I didn't see any answers on how to fix it. I dunno about the 2-battery thing from your BBRY contact. From the teardown info only seems to be one:
    BlackBerry PlayBook Teardown - iFixit

    It sure sounds like a dead battery. There is an app in BBRY World called Battery Guru. I think its a couple of dollars. It may tell you the state of the battery. Most people with the charging issue can't even get the PB to turn on with the charger connected. So, I don't know if yours is a software problem and reloading would help. Maybe someone else will chime in...
    The PB has two batteries which operate in parallel. They are mounted in a holder which also contains a charging controller which operates in conjunction with the main PB system. If one battery has failed, is very weak or some failure has occurred in the circuitry the other battery may not take its full charge.
    03-01-14 10:52 PM
  4. jagrlover's Avatar
    The PB has two batteries which operate in parallel. They are mounted in a holder which also contains a charging controller which operates in conjunction with the main PB system. If one battery has failed, is very weak or some failure has occurred in the circuitry the other battery may not take its full charge.
    When plugged in, there is never the lighting bolt over the battery symbol.

    Posted via CB10
    03-01-14 11:09 PM
  5. Gooseberry Falls's Avatar
    Ahh, sorry closer reading of the teardown says the two black things on the left and right are batteries.
    Cynycl likes this.
    03-02-14 08:38 AM
  6. Cynycl's Avatar
    Ahh, sorry closer reading of the teardown says the two black things on the left and right are batteries.
    You mean you haven't ripped yours apart yet trying to make it work properly?

    I keep forgetting some of us are virgins
    03-02-14 03:54 PM
  7. jagrlover's Avatar
    So I thought that I might as well wipe it and reload. Everything seemed to be going well as I had to set it up again, I entered my BBid, went through the tutorial and........


    PlayBook works but won't charge-img_20140308_195656.jpg

    It's toast isn't it?

    Posted via CB10
    03-08-14 08:06 PM
  8. jpash549's Avatar
    So I thought that I might as well wipe it and reload. Everything seemed to be going well as I had to set it up again, I entered my BBid, went through the tutorial and........


    Click image for larger version. 

Name:	IMG_20140308_195656.jpg 
Views:	98 
Size:	22.4 KB 
ID:	253726

    It's toast isn't it?

    Posted via CB10
    Do you also have the magnetiic charger attached at this point?
    03-08-14 09:07 PM
  9. jagrlover's Avatar
    Do you also have the magnetiic charger attached at this point?
    Yes

    Posted via CB10
    03-08-14 11:59 PM

Similar Threads

  1. anyone got skygo working?
    By marcelcarpz1 in forum Android Apps (Amazon Store & APK Files)
    Replies: 4
    Last Post: 07-04-14, 01:47 PM
  2. Will Audio Technica ATH-M50's work with Z10?
    By samisosa420 in forum BlackBerry Z10
    Replies: 20
    Last Post: 03-27-14, 12:35 AM
  3. PlayBook LTE compatible with UK?
    By geekl33tgamer in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 03-04-14, 09:58 PM
  4. Android App won't download 4.2.1.537
    By OldNewStartup in forum Android Apps (Amazon Store & APK Files)
    Replies: 7
    Last Post: 03-03-14, 01:02 AM
  5. Hub on Playbook Tutorial... Os 10 part of the Playbook
    By royalbucks in forum BB10 Leaked/Beta OS
    Replies: 2
    Last Post: 03-01-14, 04:21 PM
LINK TO POST COPIED TO CLIPBOARD