01-11-14 08:55 AM
55 123
  1. Bold_until_Hybrid_Comes's Avatar
    Ok I'm trying to help someone else with a playbook that has some type of dead battery.

    No lights at all. I have heard about the stack charging but doesn't that usually happen when the red light at least comes on for a few seconds? Tried power and both volumes, etc. No red light atall, no green light atall.
    10-22-12 11:42 PM
  2. dugggggg's Avatar
    With a truly dead-as-a-doornail battery, the initial stack charges will give no visible indication, as the battery voltage is simply too low. Keep plugging in and unplugging the charger---from the wall, so as to reduce wear on the usb port---and eventually the voltage should rise to the point where you should start to see signs of life.
    10-23-12 12:30 AM
  3. FF22's Avatar
    Go into a dark closet and check if the screen is really off - black, not backlit gray.

    Press and hold the power button for 15-20 seconds release and let it sit for another 20-30 seconds.

    Try the Stack charging anyway. A slew of methods.

    Okay, try any and all of the various methods, including just holding the power button in for 30-40 seconds. Also go into a dark closet and make sure the screen is really black/off and not a lit up gray.

    I was told about "stack" charging, 6 cycles of charge no charge, for 2 minutes each, charging for never more than 2 minutes.

    Plug the PB in with the factory charging cable (red light comes on for a several seconds, then goes off). Wait about 10 more seconds. Unplug PB for about 30 seconds.

    Repeat n times.

    n == 6 for me. Finally my PB light switched to green, then began to oscillate, signalling charging. After a few more minutes my PB came back to life.

    You might want to UNplug/Replug at the wall/socket end to avoid using or damaging the weaker usb port on the pb itself.

    Just talked to tech support, because i'm impatient sometimes. Here is the initial process they gave me to try.

    Plug in the charger for 2 mins, unplug for 10 sec -> Repeat 6 to 8 times

    Then while unplugged perform the Hard reset (POWER, VOL + and - at the same time) . **When the red light comes on PLUG IN THE CHARGER**

    The playbook is supposed to then start charging/boot.
    Along the same lines as just above, someone posted:


    WOW, i tried EVERY SINGLE Step out there and the one step that worked ... was HOLDING down the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear.. the it will charge with just a flashing green..... lol wasted 4 hrs for nothing hope this works for everyone else

    Some have now found a shorter sequence works:

    Oh man I fixed it. I stack charged it! But not for 2 minutes.

    Every time my PB red signal goes off I removed the connection from the wall charger and placed it back within a second. I repeated it for almost 25-30 times and all in the sudden a big charger button showed up on the screen and a green light on the charging LED. I left th e power connection for 2 more hrs and started using it.
    And another posting that might help....

    There are a few solutions and some are mentioned above. SO try the things I am mentioning below.... Let me know if it works .

    Problem Scenario:

    1. Blackberry wont boot or turn on, on pressing the power button, the red light stays for a few seconds and does not turn on 2. Sometimes you will see the red light followed by a green/ yellow light that blinks 5 times and does not turn on.

    Reason: The main reason why both of the above things happen is because the battery is completely drained out, you could call it " Flat out". The problem with playbook is that the playbook wont charge if the playbook is Flat out drained. whereas other tablets or cellphones does....Playbook has to fix that issue. Meanwhile we do have a solution to go around that problem and that requires some patience. Some of the solutions mentioned in the previous comments indicate to charge it via computer.... "It doesn`t work" not if the battery is drained out flat.... so dont even bother trying it if u see the above mentioned problem.

    Solution: try this step by step and this are 3 different solutions so one of this would definitely work. 1. Press the Power button and you will see the Playbook Logo ( chances for this are low ) 2. Press the power button and the volume together, if there is 1 % charge left there is a chance that it would boot on, when you see the logo, immediately charge the playbook ( chances are medium ) 3. this solution requires patience. plug the charger into the socket and plug the USB into the playbook, the red light stays for 8-10 secs. Remove the USb from the playbook wait for 2 to 5 sec and replug the usb back to the charger and wait till that red light comes and goes again. repeat this step atleast 20-30 times. you might be asking why? the only power that the playbook gets is when that red light is on when plugging the usb into the playbook, once that light goes the playbook is not charging.. so what you are doing here is forcing the playbook to get charged for 8 sec every time u plug it to the playbook....this way the playbook gets that power needed to boot. Once the Playbook has that power to boot. The red light stays and changes to green but this time it blinks slowly and keeps blinking. you would also see the playbook logo return.... this green light keeps blinking until there is enough charge for the playbook to stand on its own and then changes to a solid red until it gets fully charged.

    Knowledge Base Article

    KB27705-BlackBerry PlayBook Power - Battery charge and discharge characteristics



    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    Phone : 0800 914 533 (within 90 days from activation)
    10-23-12 12:31 AM
  4. Chaddface's Avatar
    What happened leading up to this state?
    10-23-12 12:38 AM
  5. Bold_until_Hybrid_Comes's Avatar
    What happened leading up to this state?
    She hasn't had it on in months. I have never had this problem with mine because it use it every day. I am trying some more stacks right now even though no lights are coming on
    10-23-12 12:43 AM
  6. Chaddface's Avatar
    Maybe try leaving it plugged in for a few hours?
    10-23-12 01:01 AM
  7. Bold_until_Hybrid_Comes's Avatar
    Maybe try leaving it plugged in for a few hours?
    Yeah I think I might try that until the morning. These 2 minute stacks don't seem to be doing anything and I've tried all of the holiding down button things.

    Im starting to get pissed as it is like my playbook, having the old school first gen power button which is basically flush. A royal pain to hold down for 40 seconds!
    10-23-12 01:06 AM
  8. FF22's Avatar
    I, too, would leave it plugged in over night. I know my bbphone will show absolutely NO signs of life if I completely deplete its battery and sometimes it can take half an hour before I finally get a "pulse."
    10-23-12 01:18 AM
  9. Bold_until_Hybrid_Comes's Avatar
    In the name of the father, and of the son, and of the holy spirit. May this playbook please show some form of life when I get up at 7 tomorrow. Amen
    10-23-12 01:36 AM
  10. Bold_until_Hybrid_Comes's Avatar
    Still nothing. I dont know what to do.
    10-23-12 07:38 AM
  11. Chaddface's Avatar
    RIM offered to fix my power button a few months out of warranty. It may be worth a call.
    10-23-12 08:46 AM
  12. jagrlover's Avatar
    For me it was no lights at all. Just dead. Nothing worked, no button combinations, stack charging, I even have the rapid charger. Then I read somewhere here to hold the power button down for 15 seconds, let go for 5, then just press the power button again and magic! It turned on. Hope this helps. It saved me
    10-23-12 09:18 AM
  13. Scotter75's Avatar
    Check this out. Take a magnifying glass and look at the contacts at the bottom of the PlayBook. It is possible it may be bent and not making contact with the charger plug. This has happened to more than one person.
    RubberChicken76 likes this.
    10-23-12 10:30 AM
  14. Bold_until_Hybrid_Comes's Avatar
    I'm going to try the 15 second then let go then press again thing. I think I've already tried that though. I have indeed already checked the contacts and the usb port is fine. Even though the port is fine I also tried the stack charging on the cradle I have for my own playbook.

    As far as the comment "I have the rapid charger" it always confuses me on here as my understanding is that the rapid charger comes with every playbook. Is this not the case?
    10-23-12 10:59 AM
  15. Chaddface's Avatar
    The charger that came with my PB uses the USB port. What I think most people call the rapid charger uses the 3 pin magnetic connection.
    10-23-12 11:04 AM
  16. Bold_until_Hybrid_Comes's Avatar
    The charger that came with my PB uses the USB port. What I think most people call the rapid charger uses the 3 pin magnetic connection.
    All of my playbooks I've purchased have come with the A/C charger which has the big rectangle as the part that plugs into the outlet. I am lucky
    10-23-12 11:51 AM
  17. FF22's Avatar
    Here's an image. Both types of rapid charger (travel and dock) use the same power cord. Let's make this complete - the normal usb charger as sold in the US.
    Attached Thumbnails Playbook won't turn on - NO LIGHTS AT ALL, Nothing-pb-usb-charger.jpg   Playbook won't turn on - NO LIGHTS AT ALL, Nothing-dockandrapidpcharger.jpg  
    Last edited by F2; 10-23-12 at 02:31 PM.
    Chaddface likes this.
    10-23-12 11:55 AM
  18. dugggggg's Avatar
    If by "big rectangle on the outlet" you mean the true rapid charger with the PB-only 3-pin magnetic connector, that may be your problem---it is unclear whether you can use that charger for stack charging, as its 12V output likely follows a different circuit path.

    "Most people" in North America get a micro usb charger with their PB---labeled RIM part number HDW-34724-001 (1.8 amps at 5 volts). This is the one generally used for stack charging. It is a "rapid charger" only to handsets, not the PB.
    Last edited by dugggggg; 10-23-12 at 12:23 PM.
    10-23-12 11:58 AM
  19. Bold_until_Hybrid_Comes's Avatar
    By the way this playbook hasn't shown any signs of life yet. i am out of ideas ive tried it all
    10-23-12 02:34 PM
  20. Bold_until_Hybrid_Comes's Avatar
    ok now after leaving it plugged in until now I get the red light when i first plug it in. Just for a few quick seconds. then 5 flashes of the yellow charging light. If i unplug it during the lights on the lights turn off. Further developments to come.
    10-23-12 08:57 PM
  21. Bold_until_Hybrid_Comes's Avatar
    doing more stacks. I'm actually doing it using usb to the computer. on my last stack cycle the computer actually recognized that a blackberry device was plugged in. Still not able to start but I feel Im getting closer
    10-23-12 09:07 PM
  22. felixcbb's Avatar
    Can you reflash it from the Blackberry Desktop software?
    10-23-12 10:16 PM
  23. Bold_until_Hybrid_Comes's Avatar
    If you connect it to a PC with the USB cable, will the Blackberry Desktop software see it?

    No nothing comes up like that. It just recognized the device. And it only did it once. I've been doing hopeless stacks since with no result
    10-23-12 10:17 PM
  24. felixcbb's Avatar
    I never had turn-on problems with mine, but being a hardware designer here are some things coming to my mind:
    The BB desktop app saw the PB only once... Hmm has the usb connector been damaged and now has an intermittent contact? You have any good magnifier to physically inspect the connector? I see the usb link as the only way to have an access to program the PB hardware when the unit is off. This is one of the ways to unbrick a PB. This is bad news if it can't communicate.
    You said five flashes when the charger is plugged. Would it say anything about the state of charge? When your other PB is off, and you connect the charger, do you get the same flashing sequence?
    10-23-12 10:41 PM
  25. Bold_until_Hybrid_Comes's Avatar
    it was not the PB desktop app that saw it. It was just the generic usb hardware detection. The usb is not the problem. I have inspected it closely.

    1. Plug playbook in
    2. No lights for three seconds
    3. After three seconds of nothing then a solid red light for 17 seconds
    4. Red light goes out after 17 seconds
    5. Yellow light flashes fairly fast, 5 flashes
    6. All lights off
    7. If I unplug it and plug it in again same thing happens
    8. No lights turn on atall no matter what I do if its not plugged in
    10-23-12 10:46 PM
55 123

Similar Threads

  1. Blackberry Curve won't turn on, no red light
    By electric130 in forum BlackBerry Curve Series
    Replies: 15
    Last Post: 09-21-14, 04:23 PM
  2. Bold 9780 won't turn on, no red light, no pc detection via Usb
    By dedeltek in forum BlackBerry Bold Series
    Replies: 7
    Last Post: 12-20-11, 10:52 AM
  3. My BB won't turn on - red light stays on - no blinking.
    By devagar in forum BlackBerry Curve Series
    Replies: 1
    Last Post: 06-19-11, 04:34 AM
  4. Help! My Bold won't turn on..no response AT ALL!
    By courtneyclv in forum BlackBerry Bold Series
    Replies: 5
    Last Post: 01-06-10, 11:38 AM
  5. Curve grey 8310 won't turn on - No Red Flashing lights, nothing.
    By Mikey_D in forum BlackBerry Curve Series
    Replies: 16
    Last Post: 08-24-09, 09:51 AM