07-25-15 09:09 AM
65 123
tools
  1. crackbaby001's Avatar
    I'm glad I came across this thread. your comment helped. now my playbook is "ON"!
    03-31-13 03:33 AM
  2. kasper888's Avatar
    Hi Jagrlover,

    I did exactly what you said (my blackberry was plugged into my usb cable connector to my pc)... and it worked like a charm. AMAZING !!! Thanks a million
    04-10-13 01:52 PM
  3. Sumera Munir Butt's Avatar
    Hi guys my blackberry wouldnt turn on no matter what i did..read a post here and tried the 15 second hold and it worked!...tried everything in two days cant believe this worked.
    05-18-13 02:06 PM
  4. Sumera Munir Butt's Avatar
    i had same problem..for two days...then i came across this thread. Itried the 15 second hold and it actually worked!...thank you
    FF22 likes this.
    05-18-13 02:08 PM
  5. Ted Hechtman's Avatar
    Thank you. Worked perfectly and was a fun experience!!
    05-23-13 07:22 AM
  6. ayyguy's Avatar
    Such an easy fix
    08-05-13 02:30 PM
  7. SKohpay's Avatar
    I had tried charging for 2 minutes, unplug for 2 minutes, charge for 2 minutes over and over and over again. I saw your post and did what you said ...Yay it's charging now! ...Thank you!
    02-07-14 04:41 AM
  8. jina sheridan's Avatar
    my playbook is weird. i am still in high school so i do not have client files on my playbook but i do have tons of music, project, homework and files i would not like to download. my problem is slimier but not quite the same. i charge my playbook over the night and part of the day, so it is almost always over at least 40% left on my battery. it would work about an hour after i unplug it and then it just goes black. it will not turn on or flash any lights and i am still wondering what is happening to my playbook. once i get home, i plug it in and the light turns back on and i hold down the power button and it turns on, and once it's on, it shows i have 99% battery power left. so i know for a fact it is not a battery problem but i am still wondering what is wrong with it! i will try the hold power button thing once it blacks out again but i am still open to ant thoughts and suggestions!
    02-27-14 09:08 PM
  9. kain mcginty's Avatar
    thanks for the 30 second hold and 5 sec on then press once saved my playbook with my 2,0000 apps thanks so much found out that the jail break crashed hahah )
    11-22-14 10:20 AM
  10. jamesnps's Avatar
    Kudos to Commander789 for suggesting thePlaybook inner micro USB bar be adjusted (centered). I very carefully used a pocketknife the put the bar in the port down to the center, and voila- it's charging, and best of all, no need to disassemble the Playbook!


    Thanks again,
    James
    Palm Springs, CA
    06-09-15 09:30 PM
  11. HonnyBrown's Avatar
    bumping this thread for easy access
    07-18-15 09:34 AM
  12. fulner's Avatar
    I know this is an old post, but the Playbook is an old device. Before I go taking aprt my PlayBook, for those that fixed the problem, can you see if its the same as mine?

    My playbook stopped charging with most chargers. It would only Charg with one particular cell phone charger (not a blackBerry Charger, technically I don't have the one that came with the device originally as someone gave me just he playbook some time ago). And then recently that stopped working too.
    07-20-15 03:26 PM
  13. yohannyphm's Avatar
    I've being using my PB flawlessly 5 years now I left it run. Out of battery last week due to when away on vacation without it. Now it won't hold a charge I have tried with original character and stand it boost up and everything but it will not charge. As soon as out of the charger it turns off and will give me the charging picture when connected again will boot up after a while but no lighting bolt on the red battery icon. Any ideas?

    Posted from the all mighty Z30 10.3.2.2339
    07-20-15 03:55 PM
  14. Westernrider's Avatar
    My Playbook was doing the same thing, turned off the second it was removed from the the rapid charging stand. The solution was unorthodox: I slapped the back hard against the palm of my hand several times and voila, it turned on when I pushed the button. To be clear, I had previously opened the PB and checked the battery connection, it was fine. Hitting it I think caused a chemical reaction in the battery. Or it just needed some tough love, I'm not sure. Anyway, not only did it turn on off the charger, it then successfully accepted a charge back up from 0 to 100%. So give it a smack if all else fails.
    yohannyphm likes this.
    07-22-15 03:07 AM
  15. yohannyphm's Avatar
    My Playbook was doing the same thing, turned off the second it was removed from the the rapid charging stand. The solution was unorthodox: I slapped the back hard against the palm of my hand several times and voila, it turned on when I pushed the button. To be clear, I had previously opened the PB and checked the battery connection, it was fine. Hitting it I think caused a chemical reaction in the battery. Or it just needed some tough love, I'm not sure. Anyway, not only did it turn on off the charger, it then successfully accepted a charge back up from 0 to 100%. So give it a smack if all else fails.
    Man unbelievable did smack it as told next morning 100% charge. Thanks!

    Posted from the all mighty Z30 10.3.2.2339
    07-25-15 09:09 AM
65 123
LINK TO POST COPIED TO CLIPBOARD