1. cv004's Avatar
    Hi, I have read a lot of posts about playbooks that will not charge, but all the cases are when the battery is in the red, or completely drained. My playbook is at 86% and I was about to go on a road trip and wanted to bring it up to 100% to last me and realized it wasn't charging... I have the OEM charger, and I have tried several outlets in my home. The playbook is recognized by my computers USB but does not charge there either.



    Any suggestions are greatly appreciated!



    Other notes that may help; Updated to the latest software, 64 GB, the product is only 11 days old. I also ordered a rapid charger off Amazon last week and am still waiting for it, but I rather not have that as my only charging option for a brand new product. Also not stuck at 86% was at 93% this morning.
    10-31-12 10:14 PM
  2. FF22's Avatar
    Have you tried the various restart methods?

    So, it did charge using the included ac-usb adapter/charger but slowly. Were you using it when trying to charge?

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.
    10-31-12 11:08 PM
  3. cv004's Avatar
    It didn't charge at all it has only been losing battery life. I tried the first two methods, will try the third now, thank you!
    11-01-12 12:07 AM
  4. cv004's Avatar
    It didn't work, any other suggestions? I am down to 78 battery
    11-01-12 12:50 AM
  5. FF22's Avatar
    Okay, first, are you using it and trying to charge it at the same time? And you are using the ac adapter? The pb can use a lot of power if in use and so might lose power while you think you are charging it. This is definitely an issue if you are trying to charge through a computer usb port?

    How old is the pb?

    Is the back of the pb warm even if you are not using it? Have you installed Native Email accounts on it? Manual sync of native email can drain the battery - it is a bug/flaw. Sideloaded any Android apps?

    Are you sure that you are plugging in the usb the correct way. Some folks have managed to push it a bit too hard when it was upside down and bent the connector in the port - you can look into the port - there is a shelf type connector that should be level and not bent upward or downward (it is not exactly in the center but should be level)
    11-01-12 01:10 AM
  6. SharyBhalluTC's Avatar
    I just managed to revive my playbook. By just, I mean 5 minutes ago, after trying to revive it for 72+ hours.
    I was getting that dreaded red light for 15 seconds and then 5 flashes of green/yellow lights for 1 second each just after that. (total 20 seconds). This would only happen if I pressed my power button when connected to a power source, not without it. As without a power source, my Playbook won't respond at all.

    Here is what I tried:

    1) Stack charging, charging it for 2 minutes, not charging it for 2 minutes, for 15+ tries. No revival here. Only red light followed by 5 green/yellow lights.
    2) Stack charging, charging for the time the red light was on when I plugged in the charger (15 seconds), then removing the charger for 5 seconds, then plugging it back in and so on for around 80 tries. No revival here either.
    3) Opened my Playbook's back cover. Removed the 2 screws holding the battery connector. Removed the battery flex connector for 2+ minutes multiple times, but no help here either. Even though I just bought my playbook around 7 months ago, I couldn't send it in to claim warranty since I live in Pakistan, and bought it from Canada. This didn't revive mine.
    4) Tried updating it with the BlackBerry Desktop Manager. When connected it to the PC, the Desktop Manager prompted me to repair or update the playbook. I tried updating the playbook 3 times, but every time, it would give an error at the very end (at the rebooting phase). So BDM didn't help either.
    5) Tried updating with CFP. At one moment I thought that my Playbook was revived, since the flashing light sequence changed from (Reeeeeeeeeeeeeed-Green-Green-Green-Green-Green) to (Red-Red.....Red-Red). This happened after I wiped/nuked my Playbook. But as soon as I loaded in 2.1.0.1032 on it via the CFP, the LED sequence went back to (Reeeeeeeeeeeeeeed-Green-Green-Green-Green-Green).

    6) Finally, I was about to give up when I remembered something. I remembered that my brother had bought a phone with had a charger that had a 5 volt output rating but 500 milli ampere current rating (as opposed to 1800 milli ampere current rating on the normal PB charger). I plugged in that charger and the Red light came up. I thought "Damn, I think my Playbook is really dead". As soon as that Red light went away after 15 seconds, the big red Playbook battery icon came up. After around 10 minutes of charging, it stayed at 0% apparently, but it went ahead with the information phase asking me to connect to the WIFI, add a BlackBerry ID and what not. So thankfully it finally revived .
    The 500 milli ampere charger cannot charge the playbook ahead of the 0% mark. So I guess I will either have to fix my PB charger, or buy a new one.

    Moral: It was the charger that went bad. However after connecting the charger to the playbook, the Playbook still used to respond via LEDs. Maybe it responded because it wasn't getting proper current before on the original charger that went bad? I confirmed it when I removed the other charger and put back the original charger in the Playbook. It again gave me a Reeeeeeeeeeeeeed-Green-Green-Green-Green-Green charge sequence. But after putting the other charger in again, it showed the big red battery again (since it didn't charge ahead of 0%).



    Hope my experience helps someone here.
    11-01-12 05:24 AM
  7. Ishaq786's Avatar
    @TS, I think your USB Port is broke or your charger is broke.
    11-01-12 06:56 AM
  8. RohrohrohURboat's Avatar
    @TS, I think your USB Port is broke or your charger is broke.
    I agree, the Usb socket is fragile, one of my playbooks usb socket is damaged from the kids reefing on the charge cable when connected. You have to hold your mouth right and make sure the tang in the socket is straight otherwise it won't connect.
    11-01-12 10:19 AM
  9. realconfused's Avatar
    Just wanted to say thanks for the suggestion about plugging in the charger incorrectly. Mine wasn't charging and I thought my life had ended (dramatic? me?) but sorted it with a pair of nailclippers. THANKS
    01-06-13 09:47 AM

Similar Threads

  1. Playbook won't charge?
    By wayoung in forum BlackBerry PlayBook
    Replies: 87
    Last Post: 10-13-13, 10:33 AM
  2. 8900 Not charging - Battery Is Drained
    By Roystan in forum BlackBerry Curve 8900
    Replies: 1
    Last Post: 10-01-10, 09:06 AM
  3. After upgrading 231,my battery is still 5 bars..its not 4 bars
    By canguler87 in forum BlackBerry Curve 8900
    Replies: 14
    Last Post: 07-23-09, 05:16 PM
  4. mad...tour won't charge battery
    By misageisha in forum BlackBerry Tour 9630
    Replies: 4
    Last Post: 07-23-09, 12:01 AM
  5. charging battery is never ending...
    By dapro911 in forum BlackBerry Storm
    Replies: 12
    Last Post: 05-29-09, 09:32 PM
LINK TO POST COPIED TO CLIPBOARD