1. edymott1's Avatar

    I've trawled the forums on here and it seems that no-one else has had this problem. The Playbook won't charge at all, I've tried the charger it came with as well as numerous other micro USB chargers. I know the chargers and wall sockets work because they can charge my Q5. The small pin inside the micro-USB slot isn't bent either. I've tried plugging it into my computer and nothing happens. I don't get any abnormal lights, its as if the charger simply isn't connected. Hard and soft resets have failed to work as well. I also read that it won't charge if its under a certain battery percentage but I've had this problem for a few days so I know that isn't the issue.

    It was charging fine last week and I'm confident it hasn't been dropped or badly shaken since.

    Any ideas?
    04-08-14 09:41 AM
  2. sonicpix's Avatar
    I had this problem. I switched to the fast PB magnetic charger and it works.

    BB Proud
    edymott1 and mh1983 like this.
    04-08-14 09:46 AM

Similar Threads

  1. Do not call me Z3 LTE anymore, because it won't be my name
    By Superfly_FR in forum News & Rumors
    Replies: 28
    Last Post: 04-18-14, 10:11 PM
  2. Replies: 9
    Last Post: 04-10-14, 08:41 PM
  3. Q10 won't boot after restore
    By Brandon Nikel in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 04-08-14, 02:51 AM
  4. Replies: 7
    Last Post: 04-07-14, 11:38 PM
  5. BB 10.2 won't update on my Q10
    By ctruc in forum BlackBerry Q10
    Replies: 6
    Last Post: 04-07-14, 08:54 PM