1. madkernell's Avatar
    Hi everyone.

    this is my first post on crackberry. sadly it has to do with my playbook. you see my tablet wont boot anymore just shows black screen. i know its chargin perfectly since i got red ligth then glowing yellow lignt when connecting both travel charger and charging dock. later on got the steady pure green light meaning battery its full so i know its not a battery issue (no stack charging method needed but did it anyway one time) still when i press the power button nothing happens, sometimes red light appears but thats it. one thing i noticed: tablet seem to reboot (got red light) when pressing power and + volume buttons simultaneously so something is going on that i cant put my finger on it.

    Recently i stumble upon crackberrys post about reviving bricked devices (connect usb and turn it on with DM running so it asks for a OS update) so i tried that with no luck: DM installs OS perfectly but when its time to reboot DM cannot connect to the tablet so im at the same point: no boot and DM says i need to finish setup and reconnect tablet. but heres the catch: when installation is complete i can hear the clicking sound when pressing both - and + volume buttons as if its taking a screen capture! i tried to force reboot pressing both power and - buttons with no luck again whatsoever: got red light for a couple of seconds and thats it. no boot.
    no matter what i do NOTHING seems to appear on screen: no battery logo, no blackberry logo, nada! this black screen is eating me alive.

    can anyone drop me a hand? im out of warranty so im all by myself. any idea will be truly apreciated, i dont know what else to do

    thank you very much in advance guys.

    sorry for the long post.
    10-14-12 02:01 PM
  2. FF22's Avatar
    It could be your screen has actually failed.

    If you attach to a computer does it show up as a Drive? Is the screen totally black in a dark closet?

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.


    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)



    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    madkernell likes this.
    10-14-12 02:25 PM
  3. Branta's Avatar
    With sounds of activity it suggests a display problem. One suggestion if a micro/standard-HDMI video cable is available. Connect to a tv and see if that has a picture - could rule out screen or backlight failure.
    madkernell likes this.
    10-14-12 02:30 PM
  4. madkernell's Avatar
    With sounds of activity it suggests a display problem. One suggestion if a micro/standard-HDMI video cable is available. Connect to a tv and see if that has a picture - could rule out screen or backlight failure.
    oh wow! thanks branta! you were right i plugged my tablet to my lcd TV through HDMI and its working perfect! so its a display problem. so simple and i havent thought of that. now im thinking if its worth the hassle to replace the display. still will try F2s solutions to give it a last chance.

    thank you very much everybody.
    malgpz900 likes this.
    10-14-12 09:15 PM
  5. Branta's Avatar
    You confirmed a hardware fault for sure. Your first consideration should be whether it is still in warranty because this is not a cheap repair. Hopefully...
    10-15-12 03:44 AM
  6. riffraff17's Avatar
    I have a similar issue. There is no damage to the screen, but it won't display anything. It started with the occasional black screen of death, fixed by a reboot. That became increasingly frequent, happening almost every time the device would go to sleep. When active, the screen would auto-dim when layed flat but brighten when lifted to an angle. Eventually, I couldn't get it to work even after reboots. The screen isn't really black, it does have dim light (you can see it at the right angle or in the dark). I finally did a complete re-install of the OS from the BB Desktop, but when it got to the final step, which requires you to login to the device, I still couldn't see the prompt on the screen. It's fully charged, and it's a first generation Playbook (bought on release day) so the warranty is long expired. I don't want to spend $35 for a micro-HDMI cable just to test if I can avoid that. Is it possible that if I took the device apart I might just find a loose connection for the screen? Would I be able to reassemble it without having to buy new components, like new gaskets, or is the process of disassembly destructive of certain components even when done carefully (as seems to be the case with iPads)? I appreciate any advice.
    01-03-13 03:17 PM
  7. Stan Giles's Avatar
    I just went through this "black screen" problem. Tried all sorts of things trying to re-boot. Finally, after reading one of the posts above I held down both the power button and the centre of the volume control for about 30 seconds (or more) and finally the red light came on and then it rebooted. I noticed it was down to 12% power - although that shouldn't have had anything to do with the issue. Anyhow, its working now and I'm keeping my fingers crossed !!!
    01-19-13 08:18 PM
  8. jfguay2's Avatar
    oh wow! thanks branta! you were right i plugged my tablet to my lcd TV through HDMI and its working perfect! so its a display problem. so simple and i havent thought of that. now im thinking if its worth the hassle to replace the display. still will try F2s solutions to give it a last chance.

    thank you very much everybody.
    Same problem here except that after a certain period of rest, the screen will come on for about a minute or so, and will then go back to a dim black, while the hdmi to tv allows me to see that the pb is fully charged and functionning. Reinstalled OS so this has to be hardware right? Could it be that one of the screen connector is losely connected? I may have to open this baby up myself since it is out of warranty.
    12-30-13 08:58 AM
  9. SPNKr's Avatar

    Just had this happen to my 64 Gb PlayBook, the older 16bg is working fine but I took out my 64 Gb from my backpack knowing it needed a charge and I woke up today and it had a green led light, pressed the power button and i get a black screen, checked HDMI and i can see the screen...backing up now and will file a claim with squaretrade and see if I can get a refund or a replacement. This sucks.
    02-15-14 02:09 PM
  10. SPNKr's Avatar
    Holy smokes! It's back to life after a few hours of black screen! I had the PB connected to my TV for at least ten minutes and turned on (bluetooth thank goodness for BlackBerry Bridge) and wifi started up Maxathon browser went to rainymood and then Apollo and had both audios playing on the TV so I could make it run out of juice and try charging it over night hoping that it would work tomorrow( won't be needed anymore) . Went out to the front lawn for a few minutes came back and was checking the forums and then looked back at the tablet and the screen was on . Brb going to restart see if it turn the screen back on too.....


    Btw I should mention that I used the power down method for at least 20 seconds (still didn't work though when it booted up) and I unplugged and re plugged the hdmi cable in the tablet a few times after the two apps mentioned above were running.

    Okay so I am typing this on my Z10 while it's restarting and good news the screen came on it with the start up animation I'm a happy camper now.


    Posted via my Oreo Z10
    02-15-14 04:31 PM
  11. catalinsc's Avatar
    I have the same problem. The screen is black although I see there is some light but it works on TV. It used to work with a restart but one day it would not light up. How have you solved your problem?
    03-12-16 10:53 PM
  12. catalinsc's Avatar
    jfguay, have you solved your display problem? I am going through the same issue.
    03-12-16 11:09 PM
  13. kalakala3012's Avatar
    Is there any other ways to solve this problem? I have two playbooks with different black screen of death.

    The first one went out of battery and the screen became black forever, I tried rapid charger and normal charger, but there is no light turning on. Finally, it couldn't be turned on at all.

    The second one suddenly went to a dim black light, I could hit volume up and down to hear the sound of shotting image but when I tried to restart it by hitting volume up and power button, it was shut down and could be turn on but the dim black light also appeared.

    Which means with the two machines, I couldn't use even one of them. That sucks.
    05-11-17 11:22 PM
  14. EFats's Avatar
    I have 2 PlayBook, first one had the problem that sounds like what everyone is describing.
    At the time I did some searching around and there was an obscure mention of the issue. I forget the details but it seems like it is manufacturing reliability issue and the problem is a bad solder joint on the part that connects to the LCD screen.

    I haven't bothered to try the fix yet since it doesn't seem that easy to dismantle the PlayBook, but if you pop it open and use a heat gun (NOT hair dryer, not hot enough) at the affected area, it should fix the problem. I've tried something similar on a laptop video chip before and that method does work. If I get around to popping open my PlayBook, I'll try it & report back.


    Posted via CB10
    05-12-17 12:21 AM

Similar Threads

  1. Storm 9530 Black Screen But working???
    By patriotsgrrl in forum BlackBerry Storm
    Replies: 19
    Last Post: 04-18-14, 02:24 PM
  2. Replies: 4
    Last Post: 03-12-10, 05:17 PM
  3. Replies: 4
    Last Post: 03-12-10, 05:17 PM
  4. Curve 8330 Black Screen but buttons work
    By clm38965 in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 01-01-10, 05:44 PM
  5. Black Screen But voice command works
    By beebee5 in forum BlackBerry Curve 83xx
    Replies: 5
    Last Post: 09-22-08, 11:02 AM
LINK TO POST COPIED TO CLIPBOARD