1. JimmyInNewYork's Avatar
    It appears the video store is down again this weekend. When I try launching the store, I briefly see the Featured Movies page quickly followed by the "Could not connect to the Video Store service. Please try again later" message.

    Anyone else having the same problem? Internet and App World are working just fine. I tried doing a hard reset of my PlayBook but it looks like the problem is either on RIM's end or Rovi's end.

    Anyone know how long this usually takes them to fix?

    JimmyInNewYork
    07-21-12 01:49 PM
  2. space_traveler's Avatar
    Works ok here. East coast US.
    07-21-12 02:31 PM
  3. JimmyInNewYork's Avatar
    Works ok here. East coast US.
    I'm in New York, and its not working. Any suggestions?
    07-21-12 03:41 PM
  4. Chaddface's Avatar
    Working fine here in PA too.
    07-21-12 04:42 PM
  5. JimmyInNewYork's Avatar
    Working fine here in PA too.
    Might be a problem with my PlayBook then. As mentioned everything else appears to be working fine.

    Is there a way to reinstall the video store?
    07-21-12 05:20 PM
  6. macberry33's Avatar
    Suggestion: Restart the device, delete your wifi settings and create them again. See if that works
    07-21-12 06:11 PM
  7. JimmyInNewYork's Avatar
    Thanks for the suggestion, but deleting the wifi settings didn't work either. Is it time for something drastic like a security wipe to get the store working again?
    07-22-12 01:12 PM
  8. luqman24's Avatar
    Is it still not available in Canada because I can't find it in App world.
    07-22-12 01:19 PM
  9. DC506's Avatar
    Is it still not available in Canada because I can't find it in App world.
    OK, it's not available in Canada. That makes sense then, because I was asking myself....what's Video Store????
    07-22-12 01:24 PM
  10. stackberry369's Avatar
    Anyone here watch saving hope?
    07-22-12 01:57 PM
  11. FF22's Avatar
    Anyone here watch saving hope?
    Only cause "Lois" is in it!
    07-22-12 03:22 PM
  12. stackberry369's Avatar
    F2,you can buy episodes for $1.99 from video store.I will
    07-22-12 08:17 PM
  13. idon12no's Avatar
    Exact same problem from me in California. Rovi says it's not them and I haven't contacted RIM yet. I first noticed this after the last OS2 update, so I wonder if that could be to blame, but I have no solution yet and it's been going on for over a week.
    08-10-12 08:43 PM
  14. anon(1042122)'s Avatar
    It appears the video store is down again this weekend. When I try launching the store, I briefly see the Featured Movies page quickly followed by the "Could not connect to the Video Store service. Please try again later" message.

    Anyone else having the same problem? Internet and App World are working just fine. I tried doing a hard reset of my PlayBook but it looks like the problem is either on RIM's end or Rovi's end.

    Anyone know how long this usually takes them to fix?

    JimmyInNewYork
    Jimmy, I am also in New York and I have the same problem.. for a while now.
    Could not connect to the Video Store service. Please try again later..
    Did you end up leaving it be or did you find a solution? I wonder if there is a way to reinstall the store, maybe something like the servicebooks on BB.. I really wanted to download/buy movies and use HDMI to watch them, especially the latest Sherlock Holmes would have been an excellent test run.

    I heard there was a new PB version 2.0.1 or 2.1, can we try that?
    09-30-12 02:20 PM
  15. JimmyInNewYork's Avatar
    Originally the problem resolved itself, but I believe it took about a month before I checked and noticed the video store started working again properly.

    As of 2 days ago this problem began happening again with my Playbook, which is really frustrating.

    I tried a combination of hard restarts and deleting my saved wifi connections, but the video store won't work properly. BlackBerry App World works fine, as does the Music Store which is identical to the Video Store, but when I launch the Video Store now I'm again receiving the same error message: "Could not connect to the Video Store Service. Please try again later". The new releases briefly appear on the screen and then I see this error message.

    Has anyone tried calling RIM's customer service number about this? There has to be some kind of fix.

    I'm currently running version 2.0.1.358 and the Video Store was working before and after downloading this version.

    Jimmy
    10-02-12 12:08 PM
  16. anon(1042122)'s Avatar
    I think we have to go through Raxio's customer service.

    1-877 869 3457
    or Live Chat RoxioNow Customer Support

    I don't have my PB with me, so I have to wait until I get back in town and try it.
    I checked the KB, They mention something about Associating a new device in setting screen, but I don't have anything like that in PB.
    10-02-12 12:20 PM
LINK TO POST COPIED TO CLIPBOARD