1. Bullet_Vapour's Avatar
    So I was one of those playbook owners who had sluggish and very slow browser problems, laggy keyboard typing and poor touch screen accuracy before the recent 2.1 update. After the update the performance has improved tremendously....and i mean a lot....but using the playbook browser I still get sluggish performance, laggy keyboard typing, and a whole lot of checkboarding.

    I turned off flash and it did help speed things but I don't want it off....It's the reason why I use the playbook over my ipad 2.

    My ipad 2 on the otherhand is extremely smooth and get keyboard typing rarely gets laggy.

    I have restarted, deleted cache etc and it will help for a day or so and then the sluggish performance comes back. I barely have more than one app running and only 2-3 tabs open in the browser.

    What's up with my playbook? It's a real pain in the a$$ to use ever since I bought it and I'm really tempted to toss it in the garbage once and for all ( I mean it! ) and stick with the ipad 2 which has been super fast and non-problematic compared to this playbook
    04-19-14 05:16 AM
  2. anon(4077577)'s Avatar
    I feel you. Mine is incredibly frustratingly slow as well. Especially when entering text into the youtube search box. Press a letter, wait 5 seconds, press another letter, wait another 5 seconds. Tried everything, reinstalling etc.... it's such a ******** device I actually use it for anger management.

    from an australian Z10...
    04-19-14 05:27 AM
  3. pacoman03's Avatar
    Flash isn't what slows the browser down, it's javascript. Turn js off and the browser will fly, but some sites may not work properly or at all.
    04-19-14 11:37 AM
  4. kbz1960's Avatar
    Move on to a new tablet.
    04-19-14 11:39 AM
  5. Banco's Avatar
    If it becomes too much of a pain to use, then a security wipe is the only way - it will be smooth as butter then, but of course you have the nuisance of downloading all the applications again. One thing I do find is that certain Android apps will cause it to be slow, the question is, which ones. Trial and error I'm afraid.

    One thing you can do is repeated hard resets. I find that after a little while it runs much more smoothly, again it's certain Android sideloads that are likely causing the issue. Try that, and see if over time the lagginess eases. If it doesn't, then security wipe is the way to go.
    walt63 likes this.
    04-22-14 04:51 AM
  6. walt63's Avatar
    Move on to a new tablet.
    Exactly. Just let it go. It won't ever be fully supported, the experience is just going to get worse and the OS is so outdated.

    Posted via CB10
    04-22-14 05:00 AM
  7. co4nd's Avatar
    Flash isn't what slows the browser down, it's javascript. Turn js off and the browser will fly, but some sites may not work properly or at all.
    Turn off javascript? Welcome back to 1998. Javascript is the main language of the web.
    kbz1960 likes this.
    04-22-14 05:57 AM
  8. pacoman03's Avatar
    Turn off javascript? Welcome back to 1998. Javascript is the main language of the web.
    Is it? The fact is that most websites load and work just fine with javascript turned off (including Crackberry). The PB's Browser loads sites two to three times or more faster with javascript turned off, and the ease with which Origami Browser lets the user toggle javascript on and off is one of the main reasons that many prefer it to the stock Browser.
    04-22-14 10:44 AM
  9. kbz1960's Avatar
    Is it? The fact is that most websites load and work just fine with javascript turned off (including Crackberry). The PB's Browser loads sites two to three times or more faster with javascript turned off, and the ease with which Origami Browser lets the user toggle javascript on and off is one of the main reasons that many prefer it to the stock Browser.
    If you're going to turn JavaScript off you might as well visit mobile sites.
    04-22-14 11:26 AM
  10. pacoman03's Avatar
    If you're going to turn JavaScript off you might as well visit mobile sites.
    Or not. Try visiting this forum using the Playbook's browser and opening a number of threads with javascript turned both on and off, and then tell me which is the more pleasant experience.
    04-22-14 11:35 AM
  11. Deckard79's Avatar
    Get a different tablet. Seriously.

    I like the PlayBook, but the browser is pretty awful and there's no way round that.

    Posted via CB10
    04-22-14 11:39 AM
  12. RubberChicken76's Avatar
    So I w\
    What's up with my playbook? It's a real pain in the a$$ to use ever since I bought it and I'm really tempted to toss it in the garbage once and for all ( I mean it! )
    Before you throw it out, feel free to toss it in an envelope and mail it to me! :-) I'll gladly pay postage

    The problem is, unfortunately, one of the unfinished pieces of the playbook: the fact that apps (that aren't games) run in Adobe's extremely slow, extremely sluggish AIR platform. Look at how slow the browser and keyboard are, then ponder the fact that the same device runs 1st person games like Dead Space and Need for Speed at high frame rates. The former are done in AIR. The latter are done in the NDK.

    On PlayBook, only games used the NDK, hence the sheer volume of high performance games compared to the really sluggish apps.

    On BlackBerry 10, Cascades was the NDK brought to the next level to provide an app UI framework. You see the results in the difference between the original settings app (done in AIR) and the updated one (done in Cascades). One was sluggish, one was snappy.

    Alas, no Cascades for PlayBook.
    Last edited by RubberChicken76; 04-22-14 at 12:38 PM.
    04-22-14 11:40 AM
  13. kbz1960's Avatar
    Or not. Try visiting this forum using the Playbook's browser and opening a number of threads with javascript turned both on and off, and then tell me which is the more pleasant experience.
    I agree but I also like to use the other features on the site that require JavaScript. Why are BlackBerry products the ones that always need something turned off or disabled. My windows tablet works fine WITH JavaScript on, why can't the bb?
    04-22-14 11:53 AM
  14. walt63's Avatar
    Are any of you experienced in web development to claim your statements as accurate?

    Posted via CB10
    04-22-14 08:07 PM
  15. Raestloz's Avatar
    I agree but I also like to use the other features on the site that require JavaScript. Why are BlackBerry products the ones that always need something turned off or disabled. My windows tablet works fine WITH JavaScript on, why can't the bb?
    I think it's a moot question. The "solution" for the slow browsing experience is to turn off JavaScript. Asking "why can't I turn JavaScript on and still have good performance?" won't really improve the situation, because it depends entirely on PlayBook browser's JavaScript engine

    Z10 STL100-1/10.2.1.2102
    04-23-14 06:52 AM
  16. kbz1960's Avatar
    I think it's a moot question. The "solution" for the slow browsing experience is to turn off JavaScript. Asking "why can't I turn JavaScript on and still have good performance?" won't really improve the situation, because it depends entirely on PlayBook browser's JavaScript engine

    Z10 STL100-1/10.2.1.2102
    Which sucks. Yes if you want to have a mobile experience and have half of the web not work turn it off by all means if that is good enough for you. It is not for me. I expect more and if bb can't be bothered to deliver it I go elsewhere. I'm tired of having to turn things off or have a subpar device that can't do basic things like every other platform can without those issues.
    04-23-14 07:13 AM
  17. snow_stipple's Avatar
    I find the following helps speed up my Playbook for a short while before I need to repeat.

    Open the Browser Settings area on the Playbook and under Content turn off the Load Images, the Enable Flash, and the Enable JavaScript. Also turn off Wifi and activate the Airplane Mode.Then shut off the Playbook and restart after a couple of minutes. Go back to Browser Settings and turn the three back on. Turn Wifi back on and the Airplane Mode off.

    Besides the above, I regularly clear the Cache, Cookies, and Local Storage in Privacy and Security in Browser settings so you might try these, too (I don't clear the history, though).
    04-23-14 09:23 PM
  18. RubberChicken76's Avatar
    Flash isn't what slows the browser down, it's javascript. Turn js off and the browser will fly, but some sites may not work properly or at all.
    Unfortunately, that means big ones... try searching YouTube for example

    Posted via CB10
    04-26-14 01:14 PM
  19. Carterbits's Avatar
    Turning off keyboard prediction seems to help here.

    Download Noted, my 5-star rated, native BB10 notepad app.
    04-26-14 01:44 PM
  20. silverbullet's Avatar
    I find the following helps speed up my Playbook for a short while before I need to repeat.

    Open the Browser Settings area on the Playbook and under Content turn off the Load Images, the Enable Flash, and the Enable JavaScript. Also turn off Wifi and activate the Airplane Mode.Then shut off the Playbook and restart after a couple of minutes. Go back to Browser Settings and turn the three back on. Turn Wifi back on and the Airplane Mode off.

    Besides the above, I regularly clear the Cache, Cookies, and Local Storage in Privacy and Security in Browser settings so you might try these, too (I don't clear the history, though).
    Thanks. I will try this.

    Yes it's a BlackBerry. If you have something bad to say... speak to Easton!
    04-26-14 03:20 PM
  21. pacoman03's Avatar
    Unfortunately, that means big ones... try searching YouTube for example
    Like I said, some sites won't work right with javascript off. The fix is to then turn it on. It's one reason people like Origami Browser, since Origami makes it easy to toggle javascrip on or off. For YouTube, I don't use the Browser, I use TubeMate, which works just fine for me. Plus, it allows me to directly download any vids that I may like.
    04-26-14 09:10 PM
  22. iCoutinoc's Avatar
    I update mine with 7.1 LOL

    I have mine on my desk and just bought an iPad mini.

    Posted via CB10
    04-26-14 09:17 PM
  23. NursingNinja's Avatar
    Clear the cache. If that doesn't work do a factory reset.

    Posted via CB10
    04-28-14 06:23 AM
  24. anon1727506's Avatar
    http://forums.crackberry.com/blackbe...e-help-921012/

    Try going back and install an older version of the OS.

    Personally 2.1.0.1753 seems much snappier.... but most of these have been security updates, so keep that in mind.
    04-28-14 11:25 AM
  25. nealjane1's Avatar
    Keep your side loads to a minimum I found has helped...

    Posted via CB10
    04-28-14 12:12 PM

Similar Threads

  1. How do you use your playbook in 2014 ?
    By TiFr3d in forum BlackBerry PlayBook
    Replies: 112
    Last Post: 12-14-16, 01:32 PM
  2. Replies: 5
    Last Post: 04-21-14, 04:35 AM
  3. 10.2 update
    By haitham93 in forum BlackBerry Z10
    Replies: 2
    Last Post: 04-18-14, 11:13 PM
  4. Replies: 3
    Last Post: 04-18-14, 09:53 PM
  5. AT&T OTA update without SIM card.
    By jpoulin587 in forum BlackBerry Z10
    Replies: 1
    Last Post: 04-18-14, 08:35 PM
LINK TO POST COPIED TO CLIPBOARD