1. JWWDUKE's Avatar
    I've always had what I considered to be, a slow browser. Only recently have I started to look into fixing it. It just basically seems to take a long time to load pages. Disabling java and flash does help, but then most pages are using java and/or flash so they become useless.

    Up until a couple months ago I had high speed Internet from the phone company, 5MB down and 1/2MB up. Over the last year that I had my playbook I went from my old trusty wrt54g linksys router to a belkin N450DB and that made no difference.

    About 3 months ago I switched to the phone company's new Fibre optic network, 50MB down and 30MB up. It came with their own router.

    When I do a speedtest on the phone company's line quality test website, I get 1.72 MB down and 10.24MB. When I do a test from a 3 year old macbook sitting right beside my playbook it gets 49/28. I've changed alot if settings within the router, nothing seems to make any difference. I did a wipe of the playbook about 6 months ago when I had the old high speed and again about 30 days ago and it didn't make any difference at all. One thing that did seem to speed up the browsing was setting a static ip to my playbook. It didn't change the speed when doing the test but the browser did "feel" faster.

    I don't expect my playbook to be as fast as a laptop browser but it seems weird that the speedtest is so low on the download, compared to the upload.

    I'm thinking that their is actually something wrong with my book.

    If anybody has any ideas or thoughts, I would be willing to troubleshoot.

    Also, I've got a 2.4ghz cordless phone that I've owned for about 5 years doesn't seem to interfere with anything. We also have a video baby monitor that is 2.4ghz and definitely DOES interfere with the wifi signal to my playbook and macbook. However, if I completely unplug the baby monitor and phone, the playbook still has the same slow download speed.
    01-08-13 12:16 PM
  2. TomJasper's Avatar
    I'm sure somebody with more knowledge might give you some idea soon, myself I would take the PB to 2-3 buddies place and compare, this might at least put you in the right direction of PB vs connection config.
    01-08-13 12:41 PM
  3. Chaddface's Avatar
    On my advertised 50/10 connection from the cable company the PlayBook shows 30/8. That was using speedtest.net.
    That 1.72 down sounds awful slow.
    Have you looked in the wifi info to see if anything seems wacky?
    Attached Thumbnails Playbook Slow browsing/wifi problem-img_00000049.jpg  
    01-08-13 12:44 PM
  4. JWWDUKE's Avatar
    I can check it out at my brothers place, he has the regular high speed like I used to have. He also has a playbook so I can get him to check his at my house. Thats good thinking.

    I forgot to mention, my ping is always over 300ms.
    Attached Thumbnails Playbook Slow browsing/wifi problem-1pb-wifi-jan-8-2013.jpg  
    01-08-13 02:15 PM
  5. samab's Avatar
    What are the specific router settings that you changed?
    01-08-13 03:47 PM
  6. JWWDUKE's Avatar
    I've changed the ssid a few times, I've changed from wep to wpa2 to no encryption, turned wmm and wps on and off, changed wireless modes from b to g to n and every combination the router has, also changed some msdu and mpdu settings and some other settings on the band Page for control channel on or off, tried every single channel and tried it on auto, and reset the router to factory defaults, and also deleted and rebuilt the connection on the playbook as well using different settings.
    01-08-13 05:41 PM
  7. anon1727506's Avatar
    I too have tried a number of setting changes with my router, and have done speed test at a number different locations. But the 2 PlayBooks I have are also much slower than my Laptops.

    The PlayBook seems to check for networks about every 40 seconds - little green circle spins. That seems to coincide with the slowdowns... I wonder if there is a way to make it stop checking so often?
    01-08-13 06:42 PM
  8. JWWDUKE's Avatar
    I too have tried a number of setting changes with my router, and have done speed test at a number different locations. But the 2 PlayBooks I have are also much slower than my Laptops.

    The PlayBook seems to check for networks about every 40 seconds - little green circle spins. That seems to coincide with the slowdowns... I wonder if there is a way to make it stop checking so often?
    I never noticed that before. You are talking about the main wifi page right? Mine has the green circle about every 10 seconds! I don't see a setting to stop it from looking for new networks. If you go to the wifi status Page, at the top there is a check mark to "prompt me when a saved hotspot is found nearby", but nothing to stop it from searching for new networks.
    01-08-13 07:20 PM
  9. FF22's Avatar
    I don't know if this would change anything but you can change the order of wifi networks and that may change the priority.
    01-08-13 08:01 PM
  10. samab's Avatar
    I too have tried a number of setting changes with my router, and have done speed test at a number different locations. But the 2 PlayBooks I have are also much slower than my Laptops.
    It is supposed to be slower because the Playbook has only a single antenna vs. laptop has 2.
    01-08-13 09:06 PM
  11. samab's Avatar
    I've changed the ssid a few times, I've changed from wep to wpa2 to no encryption, turned wmm and wps on and off, changed wireless modes from b to g to n and every combination the router has, also changed some msdu and mpdu settings and some other settings on the band Page for control channel on or off, tried every single channel and tried it on auto, and reset the router to factory defaults, and also deleted and rebuilt the connection on the playbook as well using different settings.
    You need to be logical in how you change one setting at a time. For example, n only cannot be combined with wep.

    (1) check your router firmware to see if updates are available

    Belkin USA Site

    (2) start with the default settings of msdu and mpdu, you have wifi problems already --- don't make diagnostic difficult by introducing additional issues

    (a) SSID broadcast on, g only, WPA2/AES, WMM off, auto channel hopping
    (b) WMM on.
    (c) n only, narrow channel, auto channel hopping
    01-08-13 09:17 PM
  12. JWWDUKE's Avatar
    You need to be logical in how you change one setting at a time. For example, n only cannot be combined with wep.

    (1) check your router firmware to see if updates are available

    Belkin USA Site

    (2) start with the default settings of msdu and mpdu, you have wifi problems already --- don't make diagnostic difficult by introducing additional issues

    (a) SSID broadcast on, g only, WPA2/AES, WMM off, auto channel hopping
    (b) WMM on.
    (c) n only, narrow channel, auto channel hopping
    Yes samab, that's how I did it, by changing only one setting at a time.

    I'm not using the belkin now, I'm using the actiontec router that came with the Fibre optic service. I also had this actiontec replaced once.
    01-09-13 07:36 AM
  13. BravoZuluDelta's Avatar
    Try lowering the beacon interval in advanced wireless settings. My PlayBook would drop a startling amount of packets from my WRT54GX router until I lowered the beacon interval from 100 to 25.

    Some routers also do not play well with the power-saving WiFi mode on mobile devices, though I would not expect this to be an issue with newer 802.11n APs. Androids can turn this mode off, but I have not found this option on my PlayBook or Torch.

    Sent from my BlackBerry PlayBook using Tapatalk 2
    01-09-13 08:22 AM
  14. madtad1's Avatar
    I never noticed that before. You are talking about the main wifi page right? Mine has the green circle about every 10 seconds! I don't see a setting to stop it from looking for new networks. If you go to the wifi status Page, at the top there is a check mark to "prompt me when a saved hotspot is found nearby", but nothing to stop it from searching for new networks.
    I also have this issue. I've even tried deleting all saved networks, to no avail. They also magically reappear when I reboot/power up my playbook. I did not have this problem before I did the last update to the Playbook OS.
    01-09-13 09:48 PM
  15. Chaddface's Avatar
    I also have this issue. I've even tried deleting all saved networks, to no avail. They also magically reappear when I reboot/power up my playbook. I did not have this problem before I did the last update to the Playbook OS.
    I believe the green circle appears when you're looking in the available tab under wifi. My PB does it as well. Your saved profiles are being imported from your phone with the bridge app. Maybe try disconnecting the bridge before deleting and setting up the network on the PB.
    01-10-13 09:08 AM
  16. daglesj's Avatar
    Never seen a Playbook give more than 65Mbps.

    I reckon the Playbook has a pretty poor wireless chip.
    01-10-13 09:32 AM
  17. JWWDUKE's Avatar
    Try lowering the beacon interval in advanced wireless settings. My PlayBook would drop a startling amount of packets from my WRT54GX router until I lowered the beacon interval from 100 to 25.

    Some routers also do not play well with the power-saving WiFi mode on mobile devices, though I would not expect this to be an issue with newer 802.11n APs. Androids can turn this mode off, but I have not found this option on my PlayBook or Torch.

    Sent from my BlackBerry PlayBook using Tapatalk 2
    I don't see any setting in my router for interval beacon. Would it be called something else? If it helps, my router is an actiontec R1000H.
    01-10-13 09:51 AM
  18. kbz1960's Avatar
    While I've never had trouble connecting and staying connected the pb has always seemed slower than other devices. But OP your download speed is horrendous.
    01-10-13 10:01 AM

Similar Threads

  1. Wifi problems on playbook os 2.0
    By petworks97 in forum BlackBerry PlayBook
    Replies: 8
    Last Post: 02-28-12, 11:13 PM
  2. wifi problem
    By clubowner in forum General BlackBerry Discussion
    Replies: 37
    Last Post: 06-20-10, 09:58 AM
  3. Ok lol.. now im getting some wifi problems
    By mr.madison in forum General BlackBerry Discussion
    Replies: 12
    Last Post: 08-17-09, 05:46 PM
  4. 8120 wifi problem: cannot browse with hotspot browser
    By billmil in forum BlackBerry Pearl 81xx
    Replies: 2
    Last Post: 10-31-08, 12:33 PM
  5. WiFi problems...
    By 587846 in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 01-21-08, 01:16 AM
LINK TO POST COPIED TO CLIPBOARD