1. 8791249's Avatar
    So, this problem has been progressively worse until I finally can't access my playbook at all. About 6 months ago, my playbook started playing up. When I turned the screen on once, it appeared discolored. The colours were similar to those that were meant to appear but the display had black lines on it. I put the screen on standby (just pressed the power button) and put it on again. The screen returned fine and the problem didn't come back for a while. A month or so later, this started happening more and more frequently until I can now no longer fix it using the on/off method. If anyone has had a similar problem or knows a solution it would be much appreciated. I have attached a picture of what it looks like.
    Attached Thumbnails Playbook screen broken/discolored-hx0t1t.jpg  
    01-05-14 01:02 PM
  2. Superfly_FR's Avatar
    Hi8791249 and welcome to the CrackBerry community.
    I've not heard of a similar problem, some questions to try to target it better :

    1. What type of PB is it, when did you get it ?
    2. What is the OS version ?
    3. Have you tried to reset it by holding both +/- volume buttons until the PB stops 100% (up to 1-2 minutes : no led, screen full black)?
    4. Do you experience battery problems / Do you use PB wall charger (yellow connector) ?
    5. Have you sideloaded anything or using beta apps ?
    6. On the picture you posted, the led seems whitey : is that a reflection or really as you actually see it ?

    Cheers,
    SF
    01-05-14 03:32 PM
  3. 8791249's Avatar
    Hey, thanks for the welcome.

    1. I got it from Curry's UK, it's model RDJ21WW (not sure in terms of Q model)
    2. I don't know the OS version as obviously I can't see the screen and it was actually synced to a different computer, so the Desktop Software isn't much use either. It is most likely a 6-7 month old OS.
    3. I have tried to reset by holding + and -, and that didn't do anything even after 2 minutes of holding. I have tried the power and + button which seems to reset it as normal, although the screen behaves in exactly the same way when it reboots.
    4. I don't experience any battery problems, my battery has always lasted almost 7-8 hours usage. I don't use the PB wall charger, I use both the BlackBerry phone charger and the Playbook Rapid charger, both of which work in the same way.
    5. I haven't sideloaded anything or used beta apps.
    6. The LED screen is actually blue, and when the display on/off trick worked, I noticed that the colour always corresponded to the colour of the actual screen. I think the picture was taken when the 'bubble' display when turning on the Playbook was at the blue part, as it changes colour with that 'bubble' thing when I turn it on. When it finishes turning on, I find that I can swipe up and down, which changes the display back and forth. This leads me to believe that everything works fine but the display.

    Thanks for your help
    01-05-14 04:04 PM
  4. jpash549's Avatar
    Do you have a monitor or tv you can plug the PB into using an HDMI cord? If so you should be able to tell whether it is a screen hardware or software problem. Do you have a warranty and if so why not exercise it? I am in US and do not know about Curry but will they help you? Standard three finger reboot can culre some problems.
    Superfly_FR and k8bushlover like this.
    01-05-14 04:27 PM
  5. Superfly_FR's Avatar
    ... so the Desktop Software isn't much use either
    Do you mean you cannot connect it to Desktop Software ?

    6. The LED screen is actually blue, and when the display on/off trick worked, I noticed that the colour always corresponded to the colour of the actual screen. I think the picture was taken when the 'bubble' display when turning on the Playbook was at the blue part, as it changes colour with that 'bubble' thing when I turn it on. When it finishes turning on, I find that I can swipe up and down, which changes the display back and forth. This leads me to believe that everything works fine but the display.

    Thanks for your help
    Blue LED ?
    That's weird: AFAIK it was only spotted on rooted PB (did not last more than a few weeks).
    Do you have data on your PlayBook you cannot afford to lose ?
    01-05-14 04:30 PM
  6. Superfly_FR's Avatar
    Standard three finger reboot can culre some problems.
    @8791249 : ooops, my bad you have to hold volume+ and - AND power button simultaneously. @jpash549, thanks for reminding it (I'm now BB10 style lol)!

    edit: have to go (11:36 PM here) but for further action, in the case other suggestions would not solve the problem, you may try to reset your PB to factory defaults, here's how (please read the warnings) : http://crackberry.com/factory-reset-...ricked-devices

    Hope you'll get it fixed, warranty claim is not a bad idea though ... you might have received a refurbished unit ...
    01-05-14 04:35 PM
  7. 8791249's Avatar
    Using a HDMI is a great idea, I'll order one and test that. As for the factory reset I do have many pictures on it, but I suppose if I lost them it wouldn't be the end of the world. (Obviously I would prefer to keep them)
    Currys wouldn't help me unless it was under warranty, and I bought it from them over 2 years ago.
    I have tried to connect to the desktop software on my new laptop on which the Playbook doesn't appear connected. (I don't have the old laptop)
    01-05-14 05:28 PM
  8. Superfly_FR's Avatar
    Using a HDMI is a great idea, I'll order one and test that. As for the factory reset I do have many pictures on it, but I suppose if I lost them it wouldn't be the end of the world. (Obviously I would prefer to keep them)
    Currys wouldn't help me unless it was under warranty, and I bought it from them over 2 years ago.
    I have tried to connect to the desktop software on my new laptop on which the Playbook doesn't appear connected. (I don't have the old laptop)
    ? USB3 ports, they are usually problematic with desktop manager. Try to locate an USB2 port and try again.
    When you connect, you don't have any prompt about mounting drive ?
    Check into "My computer" (if Windows) and see if you have a drive corresponding to the PlayBook; then you should be able to copy your files.
    01-05-14 06:21 PM
  9. 8791249's Avatar
    I am using USB2 port, I have tested the cable with my phone and the cable works fine, computer recognizes the phone immediately. When I connect my Playbook, it does nothing. I can tell the Playbook is working because if I press + and -, I get the 'camera click' sound from a screenshot.
    01-07-14 10:28 AM
  10. 8791249's Avatar
    Update: My HDMI cable arrived and it appears fine on my TV. I have security wiped it and updated the software. The screen still doesn't work. Does this mean I need to replace the screen?
    01-09-14 10:13 AM
  11. Gooseberry Falls's Avatar
    Update: My HDMI cable arrived and it appears fine on my TV. I have security wiped it and updated the software. The screen still doesn't work. Does this mean I need to replace the screen?
    There are a lot of tear-down videos and how-tos for the PB:
    BlackBerry PlayBook Teardown - iFixit


    You could inspect the cables and such if you think you might have dislodged them with a jar or drop. I dunno if I'd spend the money to repair it or not. I'd just get a refurb or used one or move on with another tablet.
    01-09-14 10:26 AM
  12. axllebeer's Avatar
    This also happened to my PlayBook. The screen went negative and I used the same methods as you to get it working again. Eventually I ended up slapping it on my leg to return the color correctly. A few months later the screen does nothing but glow ever so calmly. I ended up just replacing the PlayBook entirely. It's still sitting here and I kept it for parts it I ever feel so bold.
    I pretty much have come to the conclusion that in my case it was a hardwear issue. Lose connector perhaps? It will charge, connect to desktop manager, (I did a full backp), and I wiped it thinking that might help, to no avail. Mine won't output over HDMI either.

    See photo.
    Attached Thumbnails Playbook screen broken/discolored-img_40375013452290.jpeg  
    01-09-14 10:49 AM
  13. 8791249's Avatar
    @Gooseberry Falls, I will definitely try this again, I have already taken it apart but haven't done everything that they did in that video.
    Yes @axllebeer, this was exactly the problem that I had. Fortunately for me, I can use the HDMI to put it on my TV as a sort of a media centre. (I just have to make an educated guess as to where to press on the screen.Playbook screen broken/discolored-dsc_0010-1-.jpg
    01-09-14 01:00 PM
  14. jpash549's Avatar
    @Gooseberry Falls, I will definitely try this again, I have already taken it apart but haven't done everything that they did in that video.
    Yes @axllebeer, this was exactly the problem that I had. Fortunately for me, I can use the HDMI to put it on my TV as a sort of a media centre. (I just have to make an educated guess as to where to press on the screen.Click image for larger version. 

Name:	DSC_0010[1].jpg 
Views:	23 
Size:	177.1 KB 
ID:	237313
    If you have a bluetooth mouse connected to the PB you should see the pointer on the TV screen and operate the PB that way. Will work for everything bjt mechanical button presses although may not be supported in some apps.
    01-09-14 01:19 PM
  15. Dominic Hagan's Avatar
    for the cost of one buy a spudger and split it to check the connectors. don't know if you're near me.. I'm in gloucester
    01-09-14 04:12 PM

Similar Threads

  1. Broken Music Player
    By heyjohnnybravo in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 02-19-14, 10:18 AM
  2. What else can I do with my Playbook?
    By justdan in forum BlackBerry PlayBook
    Replies: 47
    Last Post: 01-21-14, 11:06 AM
  3. Q10 cracked screen still works
    By edyts in forum BlackBerry Q10
    Replies: 6
    Last Post: 01-08-14, 05:57 PM
  4. BlackBerry Playbooks still buying bought and getting good reviews off Amazon
    By castano22 in forum General BlackBerry Discussion
    Replies: 53
    Last Post: 01-08-14, 05:47 PM
  5. Apps missing from home screen issue
    By Jack Trumble in forum BlackBerry Z30
    Replies: 4
    Last Post: 01-05-14, 04:03 PM
LINK TO POST COPIED TO CLIPBOARD