1. Hussein Hashi's Avatar
    So I have had a BlackBerry PlayBook for almost 6 months, using it with a convertible case. I have realized over the past couple of days that the power button is not working anymore. Either to turn the playbook off, or to put it on stand by. My question is, has anyone tried this before?

    I am afraid of turning off my playbook by using the Turn Off button on the battery icon, and not being able to turn it on again. Does anyone have a suggestion? I'm thinking of calling RIM to get it replaced. Thanks in advance!
    06-15-12 07:15 PM
  2. ignites's Avatar
    dumb question but have u tried out of case?
    Hussein Hashi likes this.
    06-15-12 07:22 PM
  3. antiRIM's Avatar
    I had that problem a while back, i had to use the restart option... When it booted back up it was working fine. So i don't think you need to contact RIM.. Tell if it works
    Hussein Hashi likes this.
    06-15-12 07:24 PM
  4. FF22's Avatar
    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.
    06-15-12 08:19 PM
  5. Hussein Hashi's Avatar
    Thank you for replying. Yes, I have been trying to turn the playbook on without the convertible case on.

    It seems like turning off the device did the trick, I guess it was some sort of glitch with the software. Its hard to press the power button since it has gone into the device quite a bit so I had to use a pen to press the power button. I will have to exchange this playbook at some point but do not like not being able to use it for long periods . Cheers!
    06-16-12 10:34 AM
  6. Lolly Frey's Avatar
    Thank you for the information! My power button stopped functioning only today. I was worried that it was finally on it's last leg as I have already had to buy the magnetic charger because the USB charger wouldn't work. I thought I would see if others were having this problem with the power button! I didn't even know you could restart it by the battery symbol! It worked and the power button is back to being functional! Thank you!!!
    FF22 likes this.
    01-26-16 06:28 PM
LINK TO POST COPIED TO CLIPBOARD