1. derekvincent's Avatar
    I think I know the answer to this one already but will toss it out to see if I can lucky...

    I let my Playbook battery drain right down and i was getting the red blink then 5 green/yellow blinking... took a bit to sort out but I did the 10 charges with it... then I left it overnight and mist of the next day and now I have nothing... When I plug it in no lights... when I hold down the power button for 20 second nothing... when I try a reset nothing...

    If I plug it into the computer It does not see it and no option to update it... I have tried 2 different playbook charges, the usb charger and my 9900 charge and all big nothing...


    I have had my device since day one so no warranty on it but I have not called RIM yet about it...

    Any ideas before I dig a hole in the backyard?

    Derek.
    05-09-12 09:41 AM
  2. wscotchmer's Avatar
    Based on what I have read on these forums... try plugging it in for a minute, unplug it for a minute, plug it in for a minute, etc. Repeat for 10 or more cycles. Eventually the red light will come on and then you can leave it plugged in for a full charge.

    Good luck!
    05-09-12 09:45 AM
  3. derekvincent's Avatar
    That what I did on the 10 cycle charge.... it went from that with the blinking leds to nothing after about 11 or 12 cycles....
    05-09-12 09:46 AM
  4. digitalman101's Avatar
    I think this will not help... could it be that your electrical transformer (source) burned out?
    05-09-12 09:55 AM
  5. derekvincent's Avatar
    Sadly no I have tried 3 different ones at the office and none have worked...
    05-10-12 09:48 AM
  6. Chaddface's Avatar
    Check to see if the PB charger is working by plugging into your 9900.

    If you call RIM please report any advice they give.
    05-10-12 09:58 AM
  7. derekvincent's Avatar
    It works fine, it will charge another playbook and I have tried 3 different playbook charges plus usb and other chargers...

    I will let everyone know what they say...
    Chaddface likes this.
    05-10-12 10:00 AM
  8. bigpalm's Avatar
    http://forums.crackberry.com/blackbe...0/#post7407817

    Shared my experience on the above at the PB OS thread.

    But was wandering whether for those having had (or still having) the problem, if it is due to the charging software (glitch?) or signs of pending/premature battery failure?
    05-21-12 06:04 AM
  9. mkelley65's Avatar
    Had this same issue. Continue trying Stack Charging till it comes up.
    05-21-12 09:24 AM
  10. jafobabe's Avatar
    You may have damaged the USB port....
    Do you have the Rapid Charger with the magnetic end? If not, you might want to go get one and then try the stack charging.
    05-21-12 09:43 AM
  11. ZSail's Avatar
    Red led on for few seconds when you plug it in? If it is, keep doing it. I was unplugging power as soon as red led turns off and plug back 5-10 second later. It took me 20 minutes or approximately 50 times before it finally started. You may need more than that depending how empty is the battery
    05-21-12 02:51 PM
  12. EdY's Avatar
    This issue has been posted and answered a few times already. I will link you to the appropriate thread in the "Blackberry Playbook OS" section.

    Look for "STACKED CHARGING" and here:

    playbook-wont-turn-wont-debricked-722558/


    Most importantly:
    1. don't get frustrated
    2. don't call up RIM
    3. don't try to reload your OS
    4. don't connect your computer
    5. don't throw your playbook out the window
    6. don't try to open your Playbook

    DO read the threads. Your playbook is FINE. I had same problem a few times, got it back to life easy as pie. Don't sweat it, and just prevent it next time by following TIPS in the thread above.
    peter9477 likes this.
    05-21-12 03:37 PM
  13. derekvincent's Avatar
    I have ordered a rapid charger and it should be in today... I noticed that my USB is munged... if I put a pencil under the cable it will connect.... it must have been touchy and all the messing around with device with the usb plugged in killed it finally...

    I will try the rapid charger and hope it helps...
    05-22-12 08:52 AM
  14. FF22's Avatar
    I think I am going to tweak the Stack Charging instructions to suggest that the UNplugging be done at the wall end to avoid the repeated quick insert/remove at the pb's usb port. Someone already stressed by a non-working pb might damage the usb port.
    kbz1960 and Habubla like this.
    05-22-12 09:56 AM
  15. derekvincent's Avatar
    The rapid charger arrived and things are looking better.... slow pulsing green light showing a charge and when I first plugged it in I got the low charge screen.... give this puppy a couple hours and see how it goes...

    Derek
    Chaddface likes this.
    05-22-12 01:37 PM
  16. Chaddface's Avatar
    The rapid charger arrived and things are looking better.... slow pulsing green light showing a charge and when I first plugged it in I got the low charge screen.... give this puppy a couple hours and see how it goes...

    Derek
    Sounds good. A steady green light will indicate full charge. If you can wait that long.
    05-22-12 02:17 PM
  17. derekvincent's Avatar
    Alright... now we are talking.... within an hour of being on the rapid charger it powered on by itself... it seems to have been wiped but that might have very possibly been something I did to myself while trying to fix it...

    D.
    05-22-12 02:28 PM
  18. Sahil Mani's Avatar
    When I plug in my charger a steady red light followed by an yellow,green light that flicks 5 times turns on I tried to stack charge and I failed, did I do something wrong? Can anyone help me find an easy way to figure this out ,

    Please reply
    02-25-15 12:39 AM
  19. james-007's Avatar
    Just fixed friends with the same issue. Plug it for couple minutes and unplug it for couple. Repeat the process 5-10 times. Hook it up to pc and reload the os. You might have repeat this whole process few times but will work. Your problem is that battery is not charging. Make Google your best friend.....
    02-25-15 01:18 AM
  20. Sahil Mani's Avatar
    Ummm sorry but I tried the process and it didn't work is there any other way I can do it \ all it did was the same thing red light then yellow 5 blinks and I did it 10 tims
    Last edited by Sahil Mani; 02-25-15 at 06:12 PM.
    02-25-15 05:54 PM
  21. punbb's Avatar
    I was in the exact same position and was told to stack charge. Tried it but did not work.

    What ended up working was using a magnetic charger i got off of Amzon. Works now!

    Posted via CB10
    03-01-15 05:19 PM
LINK TO POST COPIED TO CLIPBOARD