1. crazeee4u's Avatar
    I'm assuming it's a faulty charger then because I plugged my phone in and it said "some USB hubs might not provide enough power. Plug the hub into a power outlet (if available) and reconnect your Blackberry device." etc. and I am using the PB charger to test that out.

    Does the charger just randomly stop working though? I've used it a handful of times already and it's charged my PB just fine..

    What happened was on Saturday I used my PB to watch shows on a road trip and it was at about 50% when I got there but I must have forgot to put it on standby or something... I went out that night and when I got to the house I stayed at, it was dead. so I tried to stack charge it, but it wasn't working. It turned on a few times but didn't fully boot up (just the Blackberry Playbook pages showed). Tried many times and googled/crackberry searched many solutions but nothing worked. Then it started doing the single red light, followed by 5 yellow lights.

    If I press the power on key, the red light doesn't even turn on. The only time the LED turns on is when I plug it into either the PB charger or the USB one to my laptop. (since the LED shows up with my PB charger, I'm wondering why it's not charging my phone?)

    Is it possible for me to charge my PB at all with my laptop or should I just stop trying and get a new charger sent to me?

    Sorry for such a long post but I just wanted to provide all info haha!

    Any help or suggestions would be appreciated !
    09-16-12 10:27 PM
  2. FF22's Avatar
    Some folks have had the included charger fail. You can try folding and unfolding the prongs a number of times and see if that might help.

    So, the pb is now "dead"?

    Definitely call rim

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    Phone : 0800 914 533 (within 90 days from activation)
    09-17-12 12:14 AM
  3. crazeee4u's Avatar
    Alright thanks.

    Yeah last night before I went to bed I pressed the power key and it flashed a red light once. Maybe half a second long lol. I left it to "charge" with my wall-USB charger and this morning when I pressed the power key, it stayed red for maybe 10 seconds and then turned off.

    Ill definitely call RIM though. Are there any documents I may need to have on hand like a receipt when I call ?
    09-17-12 09:24 AM
  4. Chaddface's Avatar

    Ill definitely call RIM though. Are there any documents I may need to have on hand like a receipt when I call ?
    I don't recall if I gave them my serial number or PIN but proof of purchase is not required.
    To speed up the process you should have a way of receiving and responding to emails. There are some terms you have to agree to for a RMA. Maybe one more email register for 90 day tech support.
    09-17-12 09:54 AM
  5. FF22's Avatar
    Alright thanks.

    Yeah last night before I went to bed I pressed the power key and it flashed a red light once. Maybe half a second long lol. I left it to "charge" with my wall-USB charger and this morning when I pressed the power key, it stayed red for maybe 10 seconds and then turned off.

    Ill definitely call RIM though. Are there any documents I may need to have on hand like a receipt when I call ?
    If you get that quick red light, you might want to try Stack charging again. In the following treatise, there are indications that in that short burst, the pb is getting power. So, repeat:

    Okay, try any and all of the various methods, including just holding the power button in for 30-40 seconds. Also go into a dark closet and make sure the screen is really black/off and not a lit up gray.

    I was told about "stack" charging, 6 cycles of charge no charge, for 2 minutes each, charging for never more than 2 minutes.

    Plug the PB in with the factory charging cable (red light comes on for a several seconds, then goes off). Wait about 10 more seconds. Unplug PB for about 30 seconds.

    Repeat n times.

    n == 6 for me. Finally my PB light switched to green, then began to oscillate, signalling charging. After a few more minutes my PB came back to life.

    You might want to UNplug/Replug at the wall/socket end to avoid using or damaging the weaker usb port on the pb itself.

    Just talked to tech support, because i'm impatient sometimes. Here is the initial process they gave me to try.

    Plug in the charger for 2 mins, unplug for 10 sec -> Repeat 6 to 8 times

    Then while unplugged perform the Hard reset (POWER, VOL + and - at the same time) . **When the red light comes on PLUG IN THE CHARGER**

    The playbook is supposed to then start charging/boot.
    Along the same lines as just above, someone posted:


    WOW, i tried EVErY SINGLE Step out there and the one step that worked ... was HOLDING down the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear.. the it will charge with just a flashing green..... lol wasted 4 hrs for nothing hope this works for everyone else

    Some have now found a shorter sequence works:

    Oh man I fixed it. I stack charged it! But not for 2 minutes.

    Every time my PB red signal goes off I removed the connection from the wall charger and placed it back within a second. I repeated it for almost 25-30 times and all in the sudden a big charger button showed up on the screen and a green light on the charging LED. I left th e power connection for 2 more hrs and started using it.
    And another posting that might help....

    There are a few solutions and some are mentioned above. SO try the things I am mentioning below.... Let me know if it works .

    Problem Scenario: 1. Blackberry wont boot or turn on, on pressing the power button, the red light stays for a few seconds and does not turn on 2. Sometimes you will see the red light followed by a green/ yellow light that blinks 5 times and does not turn on.

    Reason: The main reason why both of the above things happen is because the battery is completely drained out, you could call it " Flat out". The problem with playbook is that the playbook wont charge if the playbook is Flat out drained. whereas other tablets or cellphones does....Playbook has to fix that issue. Meanwhile we do have a solution to go around that problem and that requires some patience. Some of the solutions mentioned in the previous comments indicate to charge it via computer.... "It doesn`t work" not if the battery is drained out flat.... so dont even bother trying it if u see the above mentioned problem.

    Solution: try this step by step and this are 3 different solutions so one of this would definitely work. 1. Press the Power button and you will see the Playbook Logo ( chances for this are low ) 2. Press the power button and the volume together, if there is 1 % charge left there is a chance that it would boot on, when you see the logo, immediately charge the playbook ( chances are medium ) 3. This solution requires patience. plug the charger into the socket and plug the USB into the playbook, the red light stays for 8-10 secs. Remove the USb from the playbook wait for 2 to 5 sec and replug the usb back to the charger and wait till that red light comes and goes again. repeat this step atleast 20-30 times. you might be asking why? the only power that the playbook gets is when that red light is on when plugging the usb into the playbook, once that light goes the playbook is not charging.. so what you are doing here is forcing the playbook to get charged for 8 sec every time u plug it to the playbook....this way the playbook gets that power needed to boot. Once the Playbook has that power to boot. The red light stays and changes to green but this time it blinks slowly and keeps blinking. you would also see the playbook logo return.... this green light keeps blinking until there is enough charge for the playbook to stand on its own and then changes to a solid red until it gets fully charged.

    Knowledge Base Article

    KB27705-BlackBerry PlayBook Power - Battery charge and discharge characteristics
    09-17-12 11:16 AM
  6. EdY's Avatar
    Hey folks,

    My PB works great but I have had the charging problem for 4 months now... pin-pointed it to a faulty charging accessory (the type with the foldable prongs).

    I have to jiggle it a few times, hear a crackling noise and sparks from the wall charger, then it works if I find just the right position. I have tested with my BB phone so I know it is the charger. Happens every time I plug it in.

    Anyways, called up RIM tech support number on this thread, explained the problem.

    Turns out, Playbook is warranted for 1 year, but accessories like wall charger is only 90 days! So just to let you know!

    These things are cheap anyways and I was hoping to get the rapid charging stand when it went on sale but it sold out!!! :-(

    So if it is the wall charger (easy to confirm by trying on your phone and seeing if it charges it) then you are out of luck! Better visit the Crackberry store!

    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    09-17-12 02:31 PM
  7. FF22's Avatar
    Hey, ages ago, when I had issues with the Travel Rapid Charger I was told it had NO warranty at all!

    I don't believe that there is any notice that the "Package" parts of have a lesser/shorter warranty but I guess they can say whatever.
    09-17-12 04:04 PM
  8. jagrlover's Avatar
    Try holding the power button down for 3o seconds, let go for 5, then press it once. Mine wouldn't charge either and this worked for me when all else failed. Found this somewhere on these forums and it reffered to some sort of "buffer" issue. Can't hurt to try.
    09-17-12 05:31 PM
  9. crazeee4u's Avatar
    rejoice! I just came home and saw my PB turned on onto that loading screen, I'm too scared to press anything right now though. It was definitely the charger being the issue as it doesn't charge my cellphone (I tried to flip in and out the prongs a few times). I'm still within the 90 days of purchase! I've only had my PB since mid August or so.. how do they check when I bought the PB anyway when I call them??

    I'm going to call tomorrow (cause I assume they're closed now) and see if they can swap me for a new charger..
    09-17-12 07:38 PM
  10. Hawnz's Avatar
    I'm going to call tomorrow (cause I assume they're closed now) and see if they can swap me for a new charger..
    You should ask if they would send you the travel rapid charger instead, for free. It never hurts to ask.
    09-17-12 09:34 PM
  11. FF22's Avatar
    At one time I think support was 24/7 but that may not be the case.
    09-17-12 10:01 PM
  12. crazeee4u's Avatar
    woohoo ! they said they're sending me the rapid charger mwahah I didn't have to ask for it. but they said it'll take 3 - 4 weeks and I didn't want to argue hopefully, it'll be a lot quicker than that though!

    Thank you everyone for your help
    09-18-12 11:51 PM
  13. keelan454's Avatar
    I found that my pb stops charging a lot. I normally end up taking it out of the wall for a while they putting it back in and it works.
    09-19-12 01:11 PM
  14. EdY's Avatar
    Probably the wall adapter...

    Mine with the foldable prongs is tempermental. I have to jiggle it and try different positions to get it to make proper electrical contacts.

    I even hear a crackly noise from within the wall adapter and see spark flashes inside of it.

    I think it is all due to the folding prongs... just a bad design on the mechanism.

    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    10-02-12 10:57 AM
  15. wee al's Avatar
    to everyone ive been searching web forums for weeks now trying to bring my dead playbook back to life, mine was bought second hand and without the magnetic charger so i always used my samsung micro usb charger for my phone. i tried everything i could find. eventually i managed to get it to reboot by buying a more powerful phone charger but could not get it to charge past the start up stage. finally tonight i found a forum where someone suggested opening the playbook up with a couple of paperclips. removing the cover and disconecting the battery for 30secs then reasembling the playbook and plugging in. yee ha works like new. if like me you dont have access to origonal playbook charger. buy a 6 500mA usb charger charge to reboot switch off remove back unplug battery for 30secs reconnect, reasemble and plug in. worked straight away.
    FF22 likes this.
    10-12-13 05:20 PM