04-26-16 09:13 AM
41 12
tools
  1. nikolayds's Avatar
    For me what worked on 11.10 ubuntu:
    PB @ latest 2.0 Dev version

    ON PB>Storage & Sharing
    USB Connection: MAC
    File Sharing: ON
    WIFI Sharing: OFF
    Password Protection: OFF

    (wait for a few moments)

    ON Ubuntu:Browse Network,
    notice you see PLAYBOOK-DC9D (if you have not changed the identification)

    As people above said
    it uses usb NIC and Ubuntu has all modules into the kernel to enable the network.

    Transfer Speed is much better, then over the wifi
    12-10-11 11:19 PM
  2. slickvguy's Avatar
    Using Ubuntu 10.10, PB 1.0.8.6067. Got this to work w/o too much fuss.

    One little glitch I ran into was that the IP address shown for usb0 when you do a "sudo ifconfig" is NOT the correct ip address. Doh. If you go into the PB's Config/About/Network, you'll see in the USB section that the IP address is actually one lower than what is shown in the ifconfig output. I remember reading somewhere that the PB exposes multiple IPs?

    Anyway...if you use the IP address shown on the PB screen, you can mount it using whatever method you prefer, and that's all.

    I'm getting about 5 MBps (bytes - not bits) for a file copy (a xvid video) from Ubuntu to the playbook using Nautilus. Using wifi I was getting app. 1.5MBps.

    Couldn't get it working in virtualbox (WinXP). Installed a driver upon usb detection, but not the correct software, and I tried a bunch of things but got nowhere. Thought it would save me from booting into win7 if I ever want to use the sync/backup functions of the RIM software. If anyone got it going in VB, please let me know.
    01-02-12 01:54 AM
  3. cbvinh's Avatar
    openSUSE 11.4
    Playbook 1.0.8.6067

    on Playbook:

    1. tap Gear icon on top right
    2. select Storage & Sharing
    USB Connections: Connect to Mac
    File Sharing: ON
    WIFI Sharing: OFF
    Password Protection: ON (set a PASSWORD, used in step 6)

    3. plug in Playbook via USB (within a short moment, you'll get a notification that Wired Ethernet usb0 has been activated, driver cdc_ether)

    on openSUSE:

    4. as superuser,
    # ifconfig usb0

    usb0 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:XX
    inet addr:169.254.236.138 Bcast:169.254.236.139 Mask:255.255.255.252
    inet6 addr: fe80::1474:11ff:fe0e:a3d4/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:93 errors:0 dropped:0 overruns:0 frame:0
    TX packets:134 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:13143 (12.8 Kb) TX bytes:20414 (19.9 Kb)

    (you care about "inet addr:169.254.236.138" and this address will change every time you plug in the Playbook)
    5. # mkdir -p /mnt/playbook (make a mount point for the playbook, only needs to be done once on your system)
    6. # mount -t cifs -o username=playbook,password=PASSWORD,rw //169.254.236.137/media /mnt/playbook
    (note that the inet address is one less than inet addr in step 4)
    7. # df
    //169.254.236.137/media/
    61095920 3328768 57767152 6% /mnt/playbook

    8. exit from superuser mode
    9. /mnt/playbook is the Playbook

    adapted from source:

    BlackBerry PlayBook + Linux
    01-02-12 07:31 AM
  4. miskr's Avatar
    This is a bash script file similar to what I use to connect my PlayBook to Linux:


    #PlayBook_IP=$(ifconfig -a | grep 169.254 | sed 's/.*inet addr:\(169.254[0-9.]*\).*/\1/')
    #Need to get from freshly started Device Info from PlayBook
    # It is also 1 less than the value found in inet addr:
    # For example from ifconfig usb0 and inet addr:169.254.19.62 use:
    # 169.254.19.61

    # Extract IP Address for PlayBook
    IP0=$(ifconfig usb0 | sed -rn 's/.*r[^ ]+) .*/\1/p')
    IP1=$(echo $IP0 | sed 's/[^\.]*$//g')
    IP2=$(echo $IP0 | cut -d. -f4)
    PlayBook_IP=$(echo "$IP1$(expr $IP2 - 1)")
    echo $PlayBook_IP
    MOUNTPOINT='/mnt/PlayBook'
    USERGROUP='UserGroupName'
    SHARE_USERNAME='playbook'
    SHARE_PW='YourPassword'

    AUTHENTICATION="user=$SHARE_USERNAME,pass=$SHARE_P W"
    PERMISSIONS="dir_mode=0775,file_mode=0775,gid=$USE RGROUP,uid=$USERGROUP"

    sudo mount -t cifs "//$PlayBook_IP/media" "$MOUNTPOINT" -o "$AUTHENTICATION,$PERMISSIONS"
    echo sudo mount -t cifs "//$PlayBook_IP/media" "$MOUNTPOINT" -o "$AUTHENTICATION,$PERMISSIONS"

    echo "Finish"
    echo "Before disconnecting Playbook execute:"
    echo sudo umount -f -l -d "$MOUNTPOINT"
    echo


    Now I can access the PlayBook by entering '/mnt/PlayBook' as the url in Dolphin.
    jryoung likes this.
    02-06-12 05:28 PM
  5. Yankee495's Avatar
    In Mandriva using Dolphin I am able to see my PB wireless by:

    File sharing on, wifi sharing on, connect to windows.
    Open Dolphin
    Go to network
    Add network folder.

    THEN:

    Windows network drive >next
    name=what ya wanna call it
    Server=IP address of the PB - like this: 10.0.0.64
    Folder= /media

    Now you have it.

    USB is different. Got the CD partition mounted with BB device manager on it.
    Working on mounting as USB storage device.
    Last edited by Yankee495; 04-22-12 at 05:49 PM.
    04-22-12 05:42 PM
  6. nicklas79's Avatar
    Hi,

    I have added a little tool "bplaybook" to barry project.

    This tool permits to use your playbook with Linux.

    You can read my post :

    BlackBerry PlayBook | ProgWeb
    BlackBerry PlayBook & Linux | ProgWeb

    And if you are interested in my BlackBerry developments :
    BlackBerry | ProgWeb

    Regards,

    Nicolas
    06-04-12 05:11 AM
  7. xsacha's Avatar
    Unfortunately USB isn't any faster than WiFi. The Playbook has a slow memory chip.
    Both are 5MB/s here.
    Last edited by xsacha; 06-04-12 at 05:52 AM.
    06-04-12 05:49 AM
  8. Philldoe's Avatar
    Unfortunately USB isn't any faster than WiFi. The Playbook has a slow memory chip.
    Both are 5MB/s here.
    Eh, I think there is more to it than that. my USB transfers range from 10 to 12 mb/s. Which tops out the peak for USB connections. Something of note... my Windows PC only get's 6-8 but this could also have a lot to do with motherboards chipset.

    Windows Desktop Intel based build
    Linux Laptop AMD based
    06-04-12 12:14 PM
  9. nicklas79's Avatar
    I confirm.

    I haven't done measurements, but I think that USB is 2x faster than wifi.

    I have to check with wifi 2.4 GHz and 5 GHz

    Nicolas
    06-04-12 03:43 PM
  10. xsacha's Avatar
    Strange you were able to get 10-12MB/s. I have only ever seen 5MB/s (maybe 6) on USB

    I have one of the original 64GB Playbooks. Is yours a newer revision or something?
    06-04-12 09:34 PM
  11. Philldoe's Avatar
    Strange you were able to get 10-12MB/s. I have only ever seen 5MB/s (maybe 6) on USB

    I have one of the original 64GB Playbooks. Is yours a newer revision or something?
    I haven't checked. I bought my first PB shortly after release. It was stolen Last august so I bought a new one at Radioshack that was a return sold as new.
    06-04-12 11:07 PM
  12. arvveeeeee's Avatar
    How do you check if all the stock apps are working properly? Like the camera...maybe be able to config thru this way to fix the camera problems certain people like myself are experiencing?
    06-29-12 07:40 AM
  13. quackquack147's Avatar
    on blackberry playbook
    storage and sharing -> connect to mac
    file sharing -> on
    password protect -> on

    now on linux box
    modprobe -v usbnet
    modprobe -v cdc_ether

    now plugin in your blackberry and as root rype
    dhclient usb0
    viz.
    root@mohona:/home/testuser# dhclient usb0
    root@mohona:/home/testuser# ifconfig usb0
    usb0 Link encap:Ethernet HWaddr 16:74:11:b1:89:3f
    inet addr:169.254.1.2 Bcast:169.254.1.3 Mask:255.255.255.252
    inet6 addr: fe80::1474:11ff:feb1:893f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:17 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2014 (1.9 KiB) TX bytes:490 (490.0 B)

    and then again as root
    mount -v -t cifs -o username=playbook,password=your_alphanumeric_p@$$w 0rd**,rw //169.254.1.1/media /mnt/playbook

    you can automate this anyway. but the cool thing is it has got a dhcp server. nice. nice. so dhcp server is enabled. :-D

    hope this helps
    thanks
    -paul
    06-15-13 02:46 PM
  14. mygeekside's Avatar
    Thank you so much!!! I was almost giving up!!!
    11-09-13 08:53 PM
  15. leoncogs's Avatar
    And the years march on! Here's thread for fedora mounts when connecting playbook to pc. Basically same as above.

    [SOLVED] help with code to set up automatic usb0 network share - FedoraForum.org
    02-07-14 11:12 AM
  16. entactogenesis's Avatar
    Just want to revive this thread, in case anyone else is still having this problem. I recently dug out my PlayBook to see if I could revive it and get some use out of it. Although I could connect via WiFi, transferring some larger video files took way too long, so I wanted to connect via USB. Unfortunately following all these instructions in this thread and others did not work for me, both in Fedora and Arch Linux. I finally figured out a way to get it working on Arch Linux. The reason why it didn't work was because the USB network interface was never getting assigned a proper address from the PlayBook. Here's what I did:

    On the PlayBook, enable Sharing:
    Settings > Storage & Sharing > USB Connections [Connect to Windows]
    Settings > Storage & Sharing > File Sharing [On]
    Settings > Storage & Sharing > Password Protect [On]

    Check your PlayBook's IP address:
    Settings > About > View information about your tablet [Network]

    Under USB, the IPv4 address for me is: 169.254.239.121/30

    Note, as you may know, that IP address will always change whenever you disconnect/reconnect, so it may be different for you. From that network address, we can calculate what address we should be assigned on our network interface on the connecting laptop/desktop, and the network address.

    If the PlayBook's IP address is: 169.254.239.121
    Then our IP address will be: 169.254.239.122 (add one to the last octet)
    The address for the network will be: 169.254.239.120/30 (the PB's IP, minus one from the last octet)

    Do the same with whatever IPv4 address you have for your PlayBook and note them down.

    Now, from the terminal, I run ip link to show my interfaces. On most Linux distributions you may use ifconfig instead.

    Code:
    $ ip link
    For me, device four is the interface that the PlayBook is connecting to, with id enp0s26f7u3:
    Code:
    4: enp0s26f7u3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 16:74:11:29:1c:ce brd ff:ff:ff:ff:ff:ff
    I run the command ip addr to see if there's been an IP address assigned to the interface by the PlayBook:
    Code:
    $ ip addr
    But it looks like it hasn't:
    Code:
    4: enp0s26f7u3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 16:74:11:29:1c:ce brd ff:ff:ff:ff:ff:ff
    So I assign the IP address we calculated above to the interface:
    Code:
    $ sudo ip address add 169.254.239.122 dev enp0s26f7u3
    You may have noticed before, that the state of the link is DOWN. Let's bring it up:
    Code:
    $ sudo ip link set up enp0s26f7u3
    Let's also setup the route, so that any traffic sent through that interface goes to the right network. Notice I am using the network address we calculated above:
    Code:
    $ sudo ip route add 169.254.239.120/30 dev enp0s26f7u3
    Finally, let's create a folder called 'playbook' in the /mnt directory and mount the PlayBook to that folder:
    Code:
    $ sudo mkdir -p /mnt/playbook
    $ sudo mount -t cifs //169.254.239.121/media /mnt/playbook/ -o username=playbook
    You'll be prompted for the password you set for the file sharing:
    Code:
    Password for playbook@//169.254.239.121/media:
    Once that is complete, you should be able to navigate to /mnt/playbook and copy/move any files over to the PlayBook.
    04-26-16 09:13 AM
41 12
LINK TO POST COPIED TO CLIPBOARD