1. ConanDowns97's Avatar
    My playbook has been off for about 6 months now, no charge what so ever.

    I plugged the charger in thinking it would charge normally but it didn't, it does a sequence of things over and over again!

    Sequence !
    *plug charger in*
    Red led
    Battery logo
    Green led
    Cuts out
    Repeats

    I have tried stack charging and it didn't work, please help me, I have only used it twice
    02-04-14 04:20 PM
  2. glasgowgas's Avatar
    http://forums.crackberry.com/blackbe...97/index2.html

    have a look at my posts in this thread, my PB has never missed a beat since................
    02-04-14 05:00 PM
  3. ConanDowns97's Avatar
    I think mines does what you're post says, red light, battery with lightning bolt, the green light, but mines just goes off then repeats the process again and again
    02-04-14 05:04 PM
  4. ConanDowns97's Avatar
    Anyone have a solution ? been 'charging' for a day now
    02-04-14 05:12 PM
  5. Carl Estes's Avatar
    Are you using the OEM charger that came with the PB? Output is 1.8 amps. Phone charger won't cut it when you are down to this level of battery. Make sure you are using the OEM charger (or BB Rapid Travel Charger), and use a power strip to flip on and off the juice for about the first 15/20 times, leave on for charge for about 10 minutes, then flip off the strip for about 10 seconds killing power then repeat steps.
    c
    Last edited by Carl Estes; 02-05-14 at 02:20 PM. Reason: The Baby Made me do it....
    Cynycl likes this.
    02-05-14 01:25 PM
  6. Cynycl's Avatar
    Are you using the OEM charger that came with the PB? Output is 1.8 amps. Phone charger won't cut it when you are down to this level of battery. Make sure you are using the OEM charger (or BB Rapid Travel Charger), and use a power strip to flip on and off the juice for about the first 15/20 times, waiting about ten minutes in between.

    c
    Carl meant 10 seconds, not minutes.
    Carl Estes likes this.
    02-05-14 01:29 PM
  7. Carl Estes's Avatar
    Carl meant 10 seconds, not minutes.
    I stands korrected and edited my post.

    My appologies.....

    c
    Cynycl likes this.
    02-05-14 02:21 PM

Similar Threads

  1. Please help me before i teach my Z10 to fly ... (Balance issue)
    By Wild Flower in forum BlackBerry Balance
    Replies: 9
    Last Post: 03-03-14, 04:53 AM
  2. Help Needed: Want to use this GIF as my BBM dp
    By azum4u in forum BlackBerry Q10
    Replies: 1
    Last Post: 02-04-14, 04:06 PM
  3. Having issues after installing an app or game, then it won't run?
    By digitalmayhem01 in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 02-04-14, 02:42 PM
  4. Rarely issues w/ either of my BB 10
    By kobnyc in forum BlackBerry Z10
    Replies: 3
    Last Post: 02-04-14, 12:57 PM
LINK TO POST COPIED TO CLIPBOARD