1. ElRod27's Avatar
    Just purchase a new Playbook, set up the time, Blackberry Id etc and now to the screen where it says it needs to do a software update. The header says "Battery Level Critically Low", I have connected via the wall charger and the battery is currently showing as 0%. I have had it plugged in for approx 45 mins and no increase. The PB seems to recognise the charger though, as if I disconnect it, a message saying it will turn off with a countdown from 60 secs appears.

    Is this normal for the initial charge to take so long? Is it better to turn it off when charging?Slightly worried I may have a defective PB or charger.

    :-(

    Edit: literally just increased to 1%, not sure if this was the result of patience or a bit of 'wiggling about' with the charger. At this rate I may be able to use it by Boxing Day!
    Last edited by ElRod27; 12-24-11 at 11:15 AM.
    12-24-11 11:11 AM
  2. peter9477's Avatar
    It's possible you have a defective charger, or a defective PlayBook that's unable to charge properly.

    Any chance you have access to a friend with another charger?

    Try plugging it into the USB port on your PC with the included USB cable. That alone is not enough to charge it with the screen on (it takes more power than the USB port can supply) but if you put it into Standby the PC should slowly charge it... if the battery and charging subsystem in the PlayBook are actually functional.

    Also check carefully that you have the cable plugged in properly... it can be a bit tricky at first, as it can be plugged in slightly skewed to one side.

    I'd suggest buying my Battery Guru app, but of course you can't do that until you manage to get the thing set up so that's probably no help to you.
    12-24-11 11:16 AM
  3. crackberryjill's Avatar
    I am having problems with my charger. You can see my thread in there. Did you get yours through a RIM employee?

    The rep I talked to last night says some of the ones shipped out on the RIM orders had the wrong chargers.

    Also some people here have said it seems to take forever to get off 0%, then all of a sudden it jumps up. Hope you don't have the same issues as me.

    The "Battery Guru" app is great, so once you do get your Playbook up and running, I would recommend it. A well spend .99.
    peter9477 likes this.
    12-24-11 11:21 AM
  4. peter9477's Avatar
    Interesting reports on the RIM employee units. I just finished a multi-day test of three of those units, but unfortunately didn't bother testing the chargers. Sounds like this might be a more wide-spread problem than I thought at first.

    The PlayBooks themselves worked fine with my old chargers, but I'll go back and check the included chargers on them right now!
    12-24-11 11:26 AM
  5. cscott44's Avatar
    Good to know that I can use my old 9650 chargers and the 9930 chargers with my playbook.
    12-24-11 11:59 AM
  6. peter9477's Avatar
    The PlayBooks themselves worked fine with my old chargers, but I'll go back and check the included chargers on them right now!
    I just retested four out of five new units, including two purchased under the RIM EPP, and the chargers are working fine for all of them. At the least then, it's not a universal problem with the Employee Purchase Program units. (These ones were shipped in Canada.)
    12-24-11 12:12 PM
  7. ElRod27's Avatar
    Hi all,

    I've managed to get to the magic 20% to allow te update. It appears I may had the problem crackberryjill alluded to where it took an age to get off 0%. I left the screen on to do this.

    For the record I purchased my PB from Currys in the UK, not through a RIM employee.

    Thanks all.
    peter9477 likes this.
    12-24-11 12:24 PM
LINK TO POST COPIED TO CLIPBOARD