1. fastrx's Avatar
    So i woke up yesterday morning and couldn't turn on my PlayBook. I tried restoring it and charging it with the playbook charger. Still nothing. I tried my rapid playbook charger dock. nothing.

    If i press the power button, it'll turn red then blink.

    Help?
    02-01-12 06:05 PM
  2. alnamvet68's Avatar
    Just plug it into the charger and leave it alone for 12 hours or so...it's in serious need of a charge.
    Last edited by alnamvet68; 02-01-12 at 06:13 PM.
    02-01-12 06:07 PM
  3. fastrx's Avatar
    Just plu it into the charger and leave it alone for 12 hours or so...it's in serious need of a charge.
    i did that this last night. i just came from work and its still dead.
    02-01-12 06:12 PM
  4. alnamvet68's Avatar
    Hmmmmmmmmmmm....well, I guess I don't have a fast Rx for ya'.
    02-01-12 06:13 PM
  5. alnamvet68's Avatar
    I take it you've had the PB for a while, and this is a first time occurance?
    02-01-12 06:15 PM
  6. FF22's Avatar
    You might need to debrick it?

    Try the Debrick method....

    1) Turn your playbook OFF by holding down the power button
    2) Let your playbook sit for about 10 minutes as earlier suggested.
    3) After letting the PB sit (and still powered off) open up the Blackberry Desktop Software (the latest version)
    4) Once the Blackberry Desktop Software is opened, use the USB Cable and hook the PB to the PC.. THEN power on the Playbook
    5) A screen will show on your computer showing that the device cannot be found
    6) Click on Update. It will take awhile

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com
    (UK Support) 0800 096 2805
    02-01-12 06:58 PM
  7. kbz1960's Avatar
    Sometimes the docks aren't charging, been some threads here on that. Are sure the dock was charging it?
    02-01-12 07:08 PM
  8. dugggggg's Avatar
    Red followed by five yellows means "I badly need a charge" and best results seem to be obtained using the stock USB charger---not the rapid chargers.

    Blinking red without yellows means some other serious problem---try the aforementioned debricking procedure.
    02-01-12 07:23 PM
  9. fastrx's Avatar
    i'll try it again, thanks guys. i'll report back
    02-01-12 07:30 PM
  10. fastrx's Avatar
    wtf. i just held the power button for 2 seconds and it just turned on and now going through the setup process.

    very wierd. i have done this so many times too lmao

    now its updating to 1.0.8.6067
    02-01-12 07:35 PM
  11. alnamvet68's Avatar
    wtf. i just held the power button for 2 seconds and it just turned on and now going through the setup process.

    very wierd. i have done this so many times too lmao

    now its updating to 1.0.8.6067
    So, I'm assuming you just got the PB....
    02-01-12 07:37 PM
  12. fastrx's Avatar
    So, I'm assuming you just got the PB....
    you misread what i said, i've pressed the button and held it probably 50 times during the last 2 days.

    i've had it since it came out
    02-01-12 07:41 PM
  13. FXCLM5's Avatar
    lucky you, my first one kept turning itself on by itself, and was going whacko on the password screen.

    it eventually would fail on the 6th attempt and password would now force you to type in "blackberry" to continue, or else it woulda surpassed the 10x password failure and wiped my entire playbook... lol
    02-01-12 08:11 PM
  14. redblueblur's Avatar
    the most common problem with the red blink of death that I have encountered and talked with other users with, is dead battery and the trickle charger app, there has to be enough power in the pb to run the charger's app, to resolve this plug it in for two minutes, unplug and plug back in for another two minutes, repeat five or ten times until it starts charging properly, worked for me and I almost returned it, wish I had and got the 64 gig instead as there is no micro sd port, at first I hated that there were no poor people apps, and even premium apps can not be purchased with prepaid visa and they cost more in canada than in the states and therefore must be ethically avoided, there were even free apps over the holidays that were america only, and that by a canadian company for a canadian device. That problem had me being laughed at by another disabled person with an asus transformer. They could get the useful apps for only 99cents and some of the premium apps are free on 'free app of teh day' in tegra or amazon or android. Lucky someone told me the link for poor people. You can not find it with the aristocracy controlled google disinformation engine but it is out there. Happiness K
    02-02-12 01:25 AM
  15. ShimmyShine's Avatar
    the most common problem with the red blink of death that I have encountered and talked with other users with, is dead battery and the trickle charger app, there has to be enough power in the pb to run the charger's app, to resolve this plug it in for two minutes, unplug and plug back in for another two minutes, repeat five or ten times until it starts charging properly, worked for me and I almost returned it, wish I had and got the 64 gig instead as there is no micro sd port, at first I hated that there were no poor people apps, and even premium apps can not be purchased with prepaid visa and they cost more in canada than in the states and therefore must be ethically avoided, there were even free apps over the holidays that were america only, and that by a canadian company for a canadian device. That problem had me being laughed at by another disabled person with an asus transformer. They could get the useful apps for only 99cents and some of the premium apps are free on 'free app of teh day' in tegra or amazon or android. Lucky someone told me the link for poor people. You can not find it with the aristocracy controlled google disinformation engine but it is out there. Happiness K
    Beat me to it, I was going to suggest the stack charge, as well.
    02-02-12 01:30 AM
  16. SK122387's Avatar
    I've been having this same problem recently. It happened a couple weeks ago, and then turned on and was normal. Then about 2 weeks later it happened again. I had left it on the charging pod overnight, and it didn't charge. Then I charged it full, and it got weird and choppy...and then reset itself to the bootup screen...and then only rebooted to a faded image of my background (it somehow bypassed the password, but the screen was a washed out image of my background, no icons, no nothing).

    After this, it just died. It was off all day. It didn't charge using my wall charger, the charging pod, and my Desktop Manager didn't recognize it when it was plugged in. I called RIM and was put on hold a bunch, and ended up having to take pictures of the charger tip, the charging port on my PB and then one of the charger plugged into the PB. I sent those pictures 2 days ago, and am waiting to hear back from RIM, to OK the exchange.

    Of course, after I send the pictures, my PB turned on and is normal and everything is perfectly fine now. But when they call back, I'm still going through with the exchange.. I want my PB to be perfect or to have a new one in time for the OS2.0 release!

    In short......... just leave it alone for a while, after holding down the power button for a while. And call RIM. This could be the start of a sporadic problem that really shouldn't be happening on an otherwise solid device that never has any issues.
    02-02-12 02:01 AM
LINK TO POST COPIED TO CLIPBOARD