1. CrackBerry Question's Avatar
    Hi guys and girls, I know there are a million instances of things I can do with the problem I'm having but I've searched for weeks and tried everything, with no results. Most people seem to be able to get to the point I'm at and the playbook will charge. I have one solid red light when i plug in my usb charger (2.4V), followed by a battery symbol in red with a lightning bolt, and then a green light for about 4 seconds. I know this is common, and usually you need to stack charge to get it to this point according to the forums. The back is warm, I've had it charging for about 16 hours now with no change to the process that is repeating. Does anyone have any ideas for me? Again, I've searched and know this is a common problem, but as far as my research could tell, people would get it to the point i have it and it would accept a charge. Mine seems to be doing that as it's warm, but no change..arghhhh..please help me. Also, I've left it on a charger for hours before, and just went out and bought the high voltage charger. I would think the battery would have enough to power up by now. Any ideas are greatly appreciated as I really need to get it going.
    10-07-15 04:15 PM
  2. DaFoxGrey's Avatar
    If you have properly stack charged the device, then your battery may be bad.

    Double check stack charge procedure and "jump start" procedure:


    Full tear down, shows access to change out battery:
    10-07-15 06:03 PM
  3. andi-bsd's Avatar
    Playbook suck. I had just throw my playbook to trash. Gone with all my precious vid and pics memories...



    Posted via CB10
    10-07-15 10:13 PM
  4. BoneMatrix's Avatar
    Ensure you're using the 1.8A BlackBerry PB charger and not just any old micro USB charger.

    Posted via CB10
    10-10-15 02:12 AM
  5. Rustybronco's Avatar
    What? no backups? First rule of thumb on any storage device, back it up regularly.
    10-10-15 03:09 AM
  6. nelsoncat's Avatar
    i've tried a 2.4 volt charger and a 2.0 and neither works, it's seriously been on the charger for a week, back is warm..but keeps cycling through the red light, battery with a lightning bolt/green light process. Never anything else. The back is warm so it's pretty maddening, and i can't do the stack procedure where i plug it in for two minutes then unplug it because mine is just repeating this silly process. I've tried stack charging it 20 seconds at a time until the red light goes out probably 200 times over the course of four hours and still nothing. Maddening considering i am getting juice somehow because the battery image and red light come on. Thanks for your help so far guys.
    10-12-15 01:25 PM
  7. DaFoxGrey's Avatar
    Then I would say the battery needs to be replaced.
    10-12-15 02:36 PM
  8. Rustybronco's Avatar
    ^^ In full agreement.
    10-12-15 02:51 PM
  9. SanAntonioism's Avatar
    In going through the steps for the stack charging, I now get 5 green flashes after pressing the on button, up volume and down volume. What's the significance to 5 green flashes?
    11-02-15 09:33 AM
  10. kubosh's Avatar
    Do you have correct OS on your Device ? Even if you dont have baterry you can run Playbook
    11-09-15 06:44 AM
  11. SanAntonioism's Avatar
    I had everything up to date. And no, it doesn't run being plugged in. Will not come on.

    I solved my problem - I bought an iPad. Since Blackberry doesn't seem to do anything to update or improve the Playbook anyway, I just give up. I miss the connection to my Z30 but there was no choice.
    11-15-15 02:48 PM
  12. Gran PC's Avatar
    Since Blackberry doesn't seem to do anything to update or improve the Playbook anyway, I just give up.
    Lol no ****. It's discontinued.
    11-16-15 04:44 PM
  13. anon(2313227)'s Avatar
    It is not voltage that matters. Of course it helps.
    When a PB has lost charges for a long time, plug it in and you see the red LED light up then goes away.
    Under stand that that's how long the PB got charges for. You need to keep unplugging and plugging the PB and let it charges(those 3-5 second the LED is lit). Keep doing this for a while and your PB will charge again like normal. I mean a while - 30 times, maybe more.
    Cracklen likes this.
    11-16-15 04:50 PM

Similar Threads

  1. Priv accessories part numbers showing up at retailers
    By ToniCipriani in forum BlackBerry Priv
    Replies: 38
    Last Post: 10-15-15, 01:33 PM
  2. I miss my Playbook!!!!
    By andreydagr8 in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 10-07-15, 11:16 AM
  3. Replies: 0
    Last Post: 10-07-15, 10:01 AM
  4. BBM Channel not showing up bew post
    By wasalph in forum Discover BBM Channels
    Replies: 0
    Last Post: 10-07-15, 01:59 AM
  5. BB z10 Not showing home screen after updating to 10.3.2
    By Richmind7 in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-06-15, 02:23 PM
LINK TO POST COPIED TO CLIPBOARD