1. gp2002's Avatar
    I just had a charging pod sent to me in SE Asia but it only comes with the North American power adapter (125V as opposed to 220V in Asia).

    Can anyone tell me if I can use a simple power voltage converter so I can use the pod here?

    Any suggestions are welcome.

    Cheers

    DL
    07-02-13 07:30 AM
  2. FF22's Avatar
    All you should need is something to change the shape of the plug. The unit can work in both 120/220.
    07-02-13 09:44 AM
  3. gp2002's Avatar
    F2

    The three prong plug fits the outlets here so there is no need.

    Not to doubt your answer but.........are you 100% sure it's okay to just plug it in without having to convert?

    Many thanks
    07-02-13 11:10 AM
  4. Chaddface's Avatar
    My pod is at work but the specs on the rapid charger say:
    Input 110-240V 50-60Hz

    I believe the pod is the same. It should be printed on the underside.
    FF22 likes this.
    07-02-13 12:00 PM
  5. bambinoitaliano's Avatar
    I just had a charging pod sent to me in SE Asia but it only comes with the North American power adapter (125V as opposed to 220V in Asia).

    Can anyone tell me if I can use a simple power voltage converter so I can use the pod here?

    Any suggestions are welcome.

    Cheers

    DL
    If your so call charging pod is original equipment manufacturer from BlackBerry, there's no need of voltage converter. As long as you have the appropriate adapter to plug into the outlet.
    07-02-13 12:33 PM
  6. gp2002's Avatar
    Yes......it is from BlackBerry purchased from the CrackBerry site. On the cord is a sticker that says 125V so that's why I am asking.

    **Just updated**

    On the bottom of the pod it says: Input: 100-240 so I am assuming it is okay to plug it in directly.

    Hypothetically........what would happen if it WAS NOT allowed to be plugged in directly and I plugged it in?
    Last edited by gp2002; 07-03-13 at 06:35 AM. Reason: update.
    07-02-13 11:53 PM

Similar Threads

  1. all sound on Z10 not working
    By cloudberry in forum BlackBerry Z10
    Replies: 20
    Last Post: 09-09-14, 01:41 AM
  2. Profile problem in Q10
    By fahad30300 in forum BlackBerry Q10
    Replies: 1
    Last Post: 07-06-13, 07:14 PM
  3. Are there apps that now work with the new debug method?
    By Bilaal in forum PlayBook Android App Sideloading
    Replies: 3
    Last Post: 07-03-13, 02:42 PM
  4. If our playbooks had bb10, we would complain about the lag!
    By muker1515 in forum BlackBerry 10 OS
    Replies: 15
    Last Post: 07-03-13, 12:13 AM
  5. Sending photos. Via hotmail, pc version on playbook.
    By alggomas in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 07-02-13, 12:44 PM
LINK TO POST COPIED TO CLIPBOARD