1. Loz82's Avatar
    I have looked through the forum and found similar issues with charging the playbook but just wanted to check that I'm getting the basics right before I contact anyone about possible repair etc!

    My playbook does not appear to charge. The battery has now completely run dead.

    But I have noticed when using the charger supplied with the playbook (yellow tipped) it doesn't appear to fully plug in to the device, is this correct? When I charge my phone etc the charger is always flush against the device. I don't want to 'wiggle' or force the connection.

    I notice this is the same when I have tried to charge the device using the laptop.

    Should a light appear when the device is charging? This also is not happening but I cannot remember if a light used to show while charging

    The playbook has hardly been used and has never left the house, it has also been in a leather case since I took it out of the box. (I am one of those annoying people that cannot stand a mark on their gadgets lol).

    Any suggestions/advice no matter how simple gratefully recieved
    02-12-12 09:59 AM
  2. peter9477's Avatar
    Have you tried charging it while plugged into your PC using the supplied USB cable?

    This won't work if you have the screen on, but if you put it in standby once it's connected it will (should) charge, though quite slowly. It would take about 12h for a full charge from empty.

    Also, did it ever charge for you, or is this a new unit and you've basically only been able to run it off the initial (probably 30-40%) charge which it came with? In other words, did it work before and something has changed, or it just never worked?
    02-12-12 10:05 AM
  3. Loz82's Avatar
    Hi there,

    I get the same response (nothing) from plugging in yellow charger to mains and usb charger to laptop!

    The unit has charged before only charged it 3-4 times tho.

    My other half has just messaged Blackberry on Twitter to see what they suggest (has worked well in the past with other gadgets).

    Thanks for your quick response.
    02-12-12 10:15 AM
  4. kill_9's Avatar
    I have found that if the tablet battery is at 0% the only way to recharge the battery is using the wall charger plugged directly into the wall outlet which shipped with the tablet and to leave the tablet powered off for at least 2 hours. The USB cable cannot revive a battery at 0%. The charging cable should have a small gap between the tablet USB port and the black plastic connector.
    02-12-12 10:19 AM
  5. Loz82's Avatar
    Thanks again,

    We now have it plugged in the wall with the original mains charger (yellow tipped). Will leave it there and not touch it for a few hours and see what happens
    02-12-12 10:26 AM
  6. FF22's Avatar
    Over in the US (Canada?) we don't have that yellow tipped charger. Make sure that you are plugging it in correctly. As others have pointed out, the port on the pb is not the normal standard micro-usb. It is a bit more rectangular. So it might be possible to plug in the cable upsidedown???

    The rapid charger puts less strain on the pb using a magnetic connection.
    02-12-12 10:39 AM
  7. cogsinister's Avatar
    I have both the US and the Yellow tipped charger and the Yellow one is a poor fit in the socket, while the standard US/Canada one fits tightly.
    02-12-12 10:50 AM
  8. Mike_Luchia's Avatar
    I've already gone through two of the supplied chargers. First one failed a week after I got the PlayBook and was replaced by Costco, second died about a week ago. Finally decided to go with the rapid charger with the magnetic connection. I'll see if Blackberry will replace the second defective charger under warranty.

    02-12-12 11:11 AM