1. danfm's Avatar
    I can connect to a wireless network with my Playbook practically everywhere (including both networks with and without authentication pages) except where I need it most - at my company.
    The way how you connect to this particular network is you connect to an open SSID, get the authentication page, enter username and password, accept the agreement and get access to the internet. This works for every laptop, mobile phone and tablet in the company except for the Playbook.
    The reason is that after connecting to the SSID with the playbook, and receiving the IP address from the router, the browser does not want to show the authentication page. Without that of course no access to internet.
    Tried everything possible under the sky I could, even entering the address I was given character by character, but browser keep saying "Unable to connect".

    Talked to RIM second level several times, they gave up on this saying it is my company fault.
    Talked to my company IT all the way to the third level, they are saying it is RIM's fault. I kind a tend to agree with that because every other mobile device and tablet do connect on the company wireless network except RIM playbook.

    It is worth mentioning that when connecting to my company wireless network with a laptop, I do get warning in the browser about the certificate: "the security certificate presented by this website was not issued by a trusted certificate authority". I then get option to continue anyway which I do, get authentication page and connect nicely to the internet.
    The playbook however does not display either that warning or gives me the authentication page, just the ridiculous "unable to connect".

    Is there a way to get to the authentication page in this case with playbook or do something else to get access to the internet?

    01-18-13 02:04 PM
  2. Herve5's Avatar
    1) try connecting any other address with an alternate browser (SimpleBrowser for instance), which normally will also redirect you to the badly-certified page. Maybe other browsers will then allow you to deal with the bad cert
    2) otherwise, ask your many-level IT guys to give you their certs, and load them in the 'certs' folder that appear aside the docs one when you connect the PB to your PC or mac. Once your company certs are on the PB the untrusted cert issue should disappear. BTW, if you have a company PC, said certs indeed should already be loaded in it...
    danfm likes this.
    01-18-13 02:48 PM
  3. FF22's Avatar
    I have no idea but maybe you can try one of the other Browsers and see if they provide the necessary page.
    danfm likes this.
    01-18-13 02:56 PM
  4. mkelley65's Avatar
    If there is a certificate issue with the Authentication Page and your IT dept is saying this is RIMS fault then your IT Dept needs to go mop floors ay McDonald's.
    01-18-13 03:23 PM
  5. Sysgen's Avatar
    Your third level support should have realized their certificate is not valid, they are using a self signed certificate or the Certificate Authority is unknown to the playbook. If they could provide you with the Root Certificate Authority you could load it on the playbook and from that point on it should resolve the "the security certificate presented by this website was not issued by a trusted certificate authority" issue.

    But I'm surprised that Iphones or Ipads dont have an issue also, they are even worst with root certificates, they support very few.
    danfm likes this.
    01-18-13 03:43 PM
  6. rcm1301's Avatar
    This is similar to how you connect in most hotels with free wifi and I had never problems. I do not think it is the PB. Have you consulted the PB user manual, specifically page 52 for troubleshooting?
    01-18-13 03:56 PM
  7. jimpilot's Avatar
    We had this issue at my work but an update to the Playbook corrected it. Are you using the latest version of the Playbook OS?
    01-18-13 04:00 PM
  8. joshua_sx1's Avatar
    Try this simple approach... delete the your company wifi from the PB setting... turn off your PB... then switch it on... then connect your company wifi (again)...
    01-19-13 02:32 AM
  9. baggins15's Avatar
    The playbook has a hotspot login feature which I think applies here. You don't see an asterisk beside the wifi icon I take it? This is how the hotspot login window pops up.
    01-19-13 07:56 AM
  10. Peter Luke's Avatar
    Hi I have simililar problem in my company. We figured out that if you open the appworld apps the authentification page appear and we can connect to the wifi.
    Otherwise if we use the default browser it does'nt work. Hope this will help you.
    danfm likes this.
    01-19-13 10:34 AM
  11. danfm's Avatar
    Many thanks to everyone who came to the rescue.
    I was away for few days and will investigate the suggestions mentioned and report back, maybe that can help some others too.

    Happy BB Playbook user
    01-21-13 09:03 AM
  12. danfm's Avatar
    In the meantime, my IT has contacted me and they wish to troubleshoot this further and would like to have a packet capture of a broken session. Is there a packet capture app for the Playbook, something like Wireshark?
    01-21-13 09:44 AM
  13. Peter Luke11's Avatar
    just press both + and - volume button near the ON/of button.
    01-23-13 11:21 AM
  14. jpash549's Avatar
    If you go into the wifi settings believe you can get a log report. This may be what they want. I'm using the N7 with the Blackberry Playbook downstairs so can't show steps.
    01-23-13 01:31 PM
  15. jpash549's Avatar
    On PB gear/wifi/? Mark lower left corner of box. There will be access to all sorts of diagnostic information. In addition you will be able to copy logs to the clipboard and then paste into docs to go or elsewhere.

    This may not be the packet capture that they are thinking of but it may be very helpful.
    danfm likes this.
    01-23-13 02:05 PM
  16. danfm's Avatar
    Here is the update.
    Tried few things suggested above.
    Going to APP World first instead of to the browser did not work for me.
    Downloaded quite a number of alternative browsers (Simple, Chameleon, Dolphin, Boat, Maxton, Private, Proxy) so they could ignore the bad certificate and give me the authentication page. None of them brought me to the authentication page.
    Was looking for a packet capture app but could not find any ( was aware of the Playbook log file and had already sent it to IT long time ago).

    There is a happy ending though.
    My IT has found an issue with the DHCP gateway which they fixed and after that I was able to receive the authentication page and connect to internet.

    Thanks again all who responded, this is a great community.

    A VERY happy BB Playbook user
    FF22 likes this.
    01-24-13 10:20 AM

Similar Threads

  1. Can not connect to wifi at home with linksys router
    By kenwood33 in forum BlackBerry PlayBook
    Replies: 9
    Last Post: 12-25-14, 08:27 PM
  2. Playbook can only connect to wifi via WPS
    By redryder in forum BlackBerry PlayBook
    Replies: 10
    Last Post: 03-05-12, 04:43 PM
  3. Just got Playbook... can't connect to WiFi
    By wyzard in forum BlackBerry PlayBook
    Replies: 8
    Last Post: 04-24-11, 08:24 PM
  4. Bold not connecting to internet except WiFi
    By SVTCobraLTD in forum General BlackBerry Discussion
    Replies: 5
    Last Post: 12-18-09, 10:38 PM
  5. Can Not Connect To Desktop Manager
    By BBMaster in forum BlackBerry Storm
    Replies: 0
    Last Post: 02-10-09, 06:11 PM