1. arvveeeeee's Avatar
    Okay, this is just a personal discovery of how I sort of figured out how to restore the use of the Blackberry Playbook's Camera if you are one of the many (including myself) that have been plagued by a recent non-functioning Camera. The problem is, it only allows you to use the rear-camera and can take photos. Choosing to switch to front-face camera will freeze the Camera app and you'll receive the "close down any other instances of the camera...blah blah blah!" message. The Camera will also allow you to record through the rear-facing camera but when attempting to watch what you have recorded, it will not play.

    **this may only be just my playbook that this step works**

    IF you cant do a screen shot (holding down the +/-) buttons at the same time, do as what I discovered:

    -Choose the Battery Icon
    -Select Power Off
    -Wait until the Playbook is completely shut off
    -About 30 seconds, turn the Playbook back on
    -While in the process of turning on, Hold down the +/- buttons at the same time a few times..depends on how many times you wanna do it.
    -When the Playbook has finished turning on, Hold down the +/- buttons and you should hear the SNAPSHOT sound
    -Check the Camera app. You should be able to see through the Rear-Facing Camera but unfortunately will not be able to use the front-facing camera.


    **FIX ALLOWS PICTURES TAKEN THROUGH THE REAR-FACING CAM ONLY**


    I just thought I'd share this...if this does not work for anyone, please DEVS you may delete this thread.
    garohz likes this.
    06-13-12 09:01 AM
  2. Ben1232's Avatar
    ...DEVS lol
    Barracuda7772 likes this.
    06-13-12 09:29 AM
  3. ..Steve..'s Avatar
    A few weeks ago bought a new PB 32gb. Out of the box after updating the camera did not work. Called BB support but they just wanted me to keep reinstalling the OS. I had a couple flickers of the camera in that time so I didn't think it was hardware related. After a week of that I gave up and retired the PB to cupboard. A couple weeks ago there was an update for Desktop Manager so did that.

    After the update I tried the PB again and after booting up the camera was alive. So for me there was a problem somewhere in either my original download or something I had done. Nonetheless all working. I had tried similar to you but no success. Am glad yours is working. Was so rapt with the PB bought a second for the car.
    06-13-12 09:33 AM
  4. Ninjatogo's Avatar
    Okay, this is just a personal discovery of how I sort of figured out how to restore the use of the Blackberry Playbook's Camera if you are one of the many (including myself) that have been plagued by a recent non-functioning Camera. The problem is, it only allows you to use the rear-camera and can take photos. Choosing to switch to front-face camera will freeze the Camera app and you'll receive the "close down any other instances of the camera...blah blah blah!" message. The Camera will also allow you to record through the rear-facing camera but when attempting to watch what you have recorded, it will not play.

    **this may only be just my playbook that this step works**

    IF you cant do a screen shot (holding down the +/-) buttons at the same time, do as what I discovered:

    -Choose the Battery Icon
    -Select Power Off
    -Wait until the Playbook is completely shut off
    -About 30 seconds, turn the Playbook back on
    -While in the process of turning on, Hold down the +/- buttons at the same time a few times..depends on how many times you wanna do it.
    -When the Playbook has finished turning on, Hold down the +/- buttons and you should hear the SNAPSHOT sound
    -Check the Camera app. You should be able to see through the Rear-Facing Camera but unfortunately will not be able to use the front-facing camera.


    **FIX ALLOWS PICTURES TAKEN THROUGH THE REAR-FACING CAM ONLY**


    I just thought I'd share this...if this does not work for anyone, please DEVS you may delete this thread.
    Apparently RIM developers are aware of this issue; it is from a software error with the latest OS version, the site says they are still investigating it, maybe 2.1 will fix it for you.
    06-13-12 11:45 AM
  5. BB_Bmore's Avatar
    I'm assuming people with this problem have playbooks that are past the warranty?

    I wouldn't stand for that. The cameras are great on this thing and they better work.
    06-13-12 02:18 PM
  6. ignites's Avatar
    no problem with my cameras (RF and FF) and im on OS 2.1. My PBs one of the first that was released (purchased on day 1). Try reloading the os
    06-13-12 02:24 PM
  7. TheScionicMan's Avatar
    maybe 2.1 will fix it for you.
    Didn't help mine...
    06-13-12 02:36 PM
  8. niazdokrat's Avatar
    Upgrading to 2.1 dev beta fixed my video chat ( front cam only) and screenshots but hte camera app still doesnt work. too afraid to do a security wipe or reinstall again and risk losing all functionality again lol.
    06-13-12 02:52 PM
  9. rotorwrench's Avatar
    I read on one of the other Blackberry forum, can't remember, will find it and attach, that they were speculating, as one poster above has, that many "bugs" were not software related but associated with bad or corrupted updates. The number of times I've read here and on the phone forums of owners not waiting long enough for update processes, intializations etc...panicking or assuming the process is hung and interupts the update, is very large. Also speculations on "bugs" and issues associated with device wiping, sideloading and betas.

    We have 7 PBs at work, all updated the same way and process, no sideloads, betas or wipes and we have had no camera, battery, video, lagging etc....7 out of 7 is a very telling statistic. I personally have no idea, but if it was a software bug you would see substantially more reports here than what have been posted.
    ralfyguy likes this.
    06-13-12 03:58 PM
  10. nomloj's Avatar
    Had this problem back in Nov or so of last year. Waited for OS2.0, but that didn't fix it. Called support in late Feb and they had me do a security wipe, then a reload, after which an RMA was given. Got back a new Playbook with the raised buttons and no issues since. If it's still under warranty, try that route. Also, noticed that when I was having that issue, that video taping from the one working camera will usually cause a freeze or a forced close, got very few video clips longer than 1minute... I could take pictures all day long with it, though.
    06-14-12 12:46 AM
  11. garohz's Avatar
    Honestly, when reading your post, first thing came to my mind was "that's is just stupid",
    but I'd tried it all and failed, force restart, security wipe, reinstall os, back to 1.8, 2.0, 2.1, betas, etc.. and all I got was front camera on the video chat app.,

    so I gave a try to your solution and....IT WORKED!!!!!!

    THANKS YOU SO MUCH!!!

    now, I can use BOTH cameras!!!!

    my Playbook is the best tablet AGAIN! =]
    06-22-12 01:41 AM
  12. varunsain's Avatar
    A restart fixed it for me. It took about 20 seconds to shut down though.. I guess it was killing the process that was using the camera app.
    06-22-12 02:43 AM
  13. geotog's Avatar
    I'll be darn, if fixed mine too, both front and back! I tried complete wipes and other methods, but this actually worked. What makes it work though, is it hardware problem or software issue? Many thanks! By the way, check your volume or you may not hear the camera shutter after reboot, as was my case. Update....Not permanent fix, had to perform again after tablet went into power save mode. I think this is a software issue, and RIM needs to address this one way or the other. I know I won't consider buying or recommending a RIM product unless it is done in due time..a bad reputation is hard to shake... Come on RIM get your act together up there, Canadians jobs depend on it.
    Last edited by geotog; 01-05-13 at 04:12 PM.
    01-05-13 04:18 AM
  14. yan_syanne's Avatar
    how can i restore my camer and other icons after wiping ?
    05-14-13 06:54 PM
  15. pacoman03's Avatar
    how can i restore my camer and other icons after wiping ?
    Go into settings, then Software Updates, then check for updates. Then install the update.
    05-14-13 08:13 PM
  16. andrelaforest12's Avatar
    I did what is written and work perfect.The two camera is working thanks.
    07-08-15 08:16 PM
  17. Jeffvench's Avatar
    I lost my camera after the last update. Gray screen on camera, video. Know hundreds of others had same problem and said it was a software problem. Nothing I read fixed it. Not even installing a new camera app off the store. was not going to spend more money on new software, either. But this morning 6/16/16 it came back to life. Camera, video and Video chat all worked.

    THE FIX - (like I said it worked for me).

    I started off loading apps installed on the playbook. The one that seemed to "release" the camera was Zinio. Blue app thing wish a swiggley logo. I deleted it - then was going to just get rid of the camera .. but I opened it for "crap" and giggles and I saw myself. Then I clicked a photo of my cat - perfect HD. Turned on the video.... took a video. Turned on the chat and it worked too. SO I turned it off, crossed my fingers, said a prayer and on reboot... the camera works. I hope it lasts and I hope it helps at least someone out there. I am so flipping happy - great camera. Was ready to toss my playbook. Good Luck and let me know if it works for you too.
    06-16-16 07:37 AM
  18. the_igg's Avatar
    I recently started work as an undertaker. I'm here to collect all BlackBerry PlayBooks.



    Posted via the CrackBerry App for Android
    06-16-16 08:02 AM
  19. brookie229's Avatar
    I recently started work as an undertaker. I'm here to collect all BlackBerry PlayBooks.



    Posted via the CrackBerry App for Android
    Bring out your dead! Bring out your dead!
    06-16-16 05:19 PM
LINK TO POST COPIED TO CLIPBOARD