1. satchit's Avatar
    My playbook doesn't charge at all, when i connect it to a charger , I see a red light blinking & yellow light blinking 5 times. Have tried all, is there any solution for this issue ?
    06-02-16 12:21 PM
  2. DaFoxGrey's Avatar
    My playbook doesn't charge at all, when i connect it to a charger , I see a red light blinking & yellow light blinking 5 times. Have tried all, is there any solution for this issue ?
    Have you tried this?
    http://forums.crackberry.com/blackbe...aybook-741383/
    06-02-16 12:58 PM
  3. BoneMatrix's Avatar
    My playbook doesn't charge at all, when i connect it to a charger , I see a red light blinking & yellow light blinking 5 times. Have tried all, is there any solution for this issue ?
    Are you using the 1.8A rated BlackBerry PB charger?
    06-03-16 04:36 PM
  4. satchit's Avatar
    Nope, I don't have that charger. I am using the charger which was provided with my BlackBerry Q10

    Posted via CB10
    06-04-16 06:49 AM
  5. DaFoxGrey's Avatar
    Nope, I don't have that charger. I am using the charger which was provided with my BlackBerry Q10

    Posted via CB10
    In the small print on the labeling of the charger, it will say what it's rated output is.
    Normally they have it in MAh, Milliamp hours.
    • One thousand MAh = 1amp.
    • So if it has 750MAh = 0.75A, 1800MAh = 1.8A, and so on.

    Normally the chargers provided with the BlackBerry smartphone devices are 750MAh.
    The Playbook, however, needs more @1800MAh
    06-04-16 08:32 AM
  6. satchit's Avatar
    Thanx Mate, will find one & try.
    will update you .
    DaFoxGrey likes this.
    06-04-16 05:08 PM
  7. ionjody's Avatar
    I get the same behaviour as with both a Q10 750 mA charger and the playbook 1800 mA charger (red LED 15 sec, then screen comes up with dead battery symbol, then green LED, then nothing, then the sequence restarts automatically - pressing the buttons has no effect).

    If I try a JBL speaker 2300 mA charger, it's different. I still get the red LED for 15 seconds, but then there are five yellow flashes, then nothing. I can get another cycle by either cutting and reconnecting the power, or by simply pressing the Playbook's on button.

    I've tried the "stack charge" method with both by standing there and cutting the power at the end of the initial 15 second red LED phase and reconnecting after a second or so. So I'm only running the red LED phase and not letting it get to either the dead battery symbol or the 5 yellow LED flashes. Is this what I should be doing?

    Does any one know which of these behaviours is more likely to eventually have it charge successfully? Which charger should I use? The speaker charger claims to be more powerful but I don't know if it really is. Does anyone know why these behaviours would be different?

    Someone at work mentioned something about a new playbook OS, but I can't find anything here. Is there something?

    Jody

    Posted via CB10
    06-05-16 12:21 PM
  8. melander's Avatar
    I have two Playbooks. One which charges with the included USB charger and one which does not. The one which does not charge via USB, I must use the optional Playbook magnetic charger

    Recently, when the Playbook that worked with the included charger failed to charge, with the same behavior as yours, I tried stack charging method but it really does not work. I believe it is an error or physical problem with the USB port when that happens. I connected my failing Playbook to the optional magnetic charger and it charged right up

    Posted via CB10
    brookie229 likes this.
    06-05-16 10:08 PM
  9. brookie229's Avatar
    I have two Playbooks. One which charges with the included USB charger and one which does not. The one which does not charge via USB, I must use the optional Playbook magnetic charger

    Recently, when the Playbook that worked with the included charger failed to charge, with the same behavior as yours, I tried stack charging method but it really does not work. I believe it is an error or physical problem with the USB port when that happens. I connected my failing Playbook to the optional magnetic charger and it charged right up

    Posted via CB10
    There is a well-described faulty USB port problem with Playbooks as they get used. Many Playbooks have had this problem and the only way to charge them is by using the magnetic charger. Mine is still good though
    06-05-16 10:55 PM

Similar Threads

  1. Mint PlayBook 64 GB Wi-Fi + OEM Bluetooth keyboard + cases
    By gallopiton in forum Buy, Sell, Trade - Sold / Archived
    Replies: 46
    Last Post: 07-17-16, 10:50 PM
  2. Replies: 9
    Last Post: 06-03-16, 04:42 PM
  3. PlayBook I-Spy type App, Security camera?
    By CrackBerry Question in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 06-01-16, 04:45 PM
  4. How can I register my BB Playbook I need help trying to get help from BB is nuts?
    By CrackBerry Question in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 06-01-16, 01:51 PM
LINK TO POST COPIED TO CLIPBOARD