1. Scrybe's Avatar
    I'm having a heck of a time getting my Rogers e-mail account connected to the PlayBook. Keep getting server error. Does anyone know the proper settings -- the ones the PB automatically suggests don't seem to work.
    02-21-12 12:30 PM
  2. holmesrob's Avatar
    I tried the same for a little while and gave up. This link looks like it should have the information. Nothing I tried worked, but like I said, I gave up pretty quickly.

    Help Index

    If you get it working, post the setting please!
    02-21-12 01:14 PM
  3. smoothrunnings's Avatar
    I'm having a heck of a time getting my Rogers e-mail account connected to the PlayBook. Keep getting server error. Does anyone know the proper settings -- the ones the PB automatically suggests don't seem to work.
    Call Rogers support they'll tell you...

    A.
    02-21-12 01:16 PM
  4. pbnuts's Avatar
    Havent tried, but found this at rogershelp.com

    Your Email Address: username@rogers.com or username@nl.rogers.com
    Enter your Rogers Email user name in place of "username"

    Password: Enter your Rogers Email password.
    Remember your password is case sensitive. Check that caps lock is not on.

    Incoming (POP) Server: pop.broadband.rogers.com

    Outgoing (SMTP) Server: smtp.broadband.rogers.com

    SMTP Authentication: Should be ON.
    This will allow you to send mail. If you are asked to enter a username and password, enter the same ones used to download mail.

    Outgoing (SMTP) Port Number: 587
    02-21-12 01:22 PM
  5. nick_80's Avatar
    02-21-12 01:23 PM
  6. jmbeca's Avatar
    Check for the threads about Yahoo settings, they usually work for Rogers email.

    http://forums.crackberry.com/blackbe...-2-0-a-700948/
    02-21-12 01:23 PM
  7. nick_80's Avatar
    For some reason I tried the settings the playbook suggested too and it wouldn't seem to work.

    Then bam, it worked.
    02-21-12 01:26 PM
  8. jpeplow's Avatar
    Havent tried, but found this at rogershelp.com

    Your Email Address: username@rogers.com or username@nl.rogers.com
    Enter your Rogers Email user name in place of "username"

    Password: Enter your Rogers Email password.
    Remember your password is case sensitive. Check that caps lock is not on.

    Incoming (POP) Server: pop.broadband.rogers.com

    Outgoing (SMTP) Server: smtp.broadband.rogers.com

    SMTP Authentication: Should be ON.
    This will allow you to send mail. If you are asked to enter a username and password, enter the same ones used to download mail.

    Outgoing (SMTP) Port Number: 587

    These setting will work, just make sure that when you are setting it up, you clicked the advanced settings tab and choose POP (I think it defaults to IMAP).
    02-21-12 01:34 PM
  9. T.roy's Avatar
    Havent tried, but found this at rogershelp.com

    Your Email Address: username@rogers.com or username@nl.rogers.com
    Enter your Rogers Email user name in place of "username"

    Password: Enter your Rogers Email password.
    Remember your password is case sensitive. Check that caps lock is not on.

    Incoming (POP) Server: pop.broadband.rogers.com

    Outgoing (SMTP) Server: smtp.broadband.rogers.com

    SMTP Authentication: Should be ON.
    This will allow you to send mail. If you are asked to enter a username and password, enter the same ones used to download mail.

    Outgoing (SMTP) Port Number: 587
    pop is port 110 and make sure you have ssl off on both
    02-21-12 01:38 PM
  10. CrackMachine's Avatar
    pop is port 110 and make sure you have ssl off on both
    Above worked for me for email but I can't seem to get the calendar working (gmail calendar syncs OK). Is there a limit of 1 calendar synching with the PB or does the Rogers configuration not work?
    02-21-12 02:13 PM
  11. stego's Avatar
    This worked for me...


    POP Yahoo! Mail Plus with Another Email Client | Yahoo! Mail Help

    I had to use my full email as a username however.
    02-21-12 08:00 PM
  12. GreenCopperz's Avatar
    Having same issues here using Eastlink, the NS cable internet provider. Was working great this morning, now keep getting the same server error. I can only get brief connectivity, then it drops and then the email disappears...
    02-21-12 08:09 PM
  13. PA-Ottawa's Avatar
    I got the e-mail function working OK, ie receiving and sending e-mails, but it refuses to "import" the contact list from Rogers. Anyone else have same problem? Know a fix?
    02-22-12 10:39 AM
  14. kahuna9000's Avatar
    I am having the same issue...email works fine, but no way to import contact list off my home computer running win7 and windows live mail. I can save the file as a CSV file but no where to import into playbook. And I don't have a yahoo account, nor do I want one.
    02-29-12 12:57 PM
  15. Michel Souris's Avatar
    The PB native email implementation is awful and doesn't support IMAP fully, so you won't fully be able to connect with Rogers (no folders in account, etc). Try one of the Android email clients as people are having more luck with them. RIM is hopeless.
    02-29-12 02:52 PM
  16. Scrybe's Avatar
    All: After having it work on Rogers with the prior settings in this email, it suddenly has stopped working. I can still receive emails but cannot send. What does everyone WITH ROGERS have for SMTP settings for their PlayBook? I'm baffled as to why my email doesn't go through. Is anyone else having this error?

    Any help would be greatly appreciated. Rogers, by the way, is useless. I've called the Internet support, BlackBerry support and general tech support and they basically say they can't help. They are totally unfamiliar with the device. I have input the POP and SMTP settings they've suggested without avail.
    08-30-12 09:04 PM
  17. Darwin 158's Avatar
    So, I was having the same problems and was very luck to get a clever first-level tech at Rogers who suggested doing an end-run on the Rogers POP3 and SMTP servers and going direct to the Yahoo IMAP servers that Rogers uses anyhow - as follows:

    Select IMAP instead of POP at the initial Advanced setup screen then:

    Username: your FULL email address with the @rogers.com (i.e. frustrated@rogers.com)
    Email: Your Rogers email address again
    Password: Your Rogers email password
    Server Address: imap.mail.yahoo.com
    Port: 993 (seems important)
    Encryption: SSL

    SMTP Username: your FULL email address with the @rogers.com (i.e. frustrated@rogers.com)
    SMTP Password: Your Rogers email password
    SMTP Server Adress: smtp.mail.yahoo.com
    Port: 465
    SMTP Encryption: SSL

    This worked for me after hours of fruitless effort on the POP side.
    Last edited by Darwin 158; 11-14-12 at 11:27 PM. Reason: Typo
    Lorraine Clarke likes this.
    11-14-12 03:10 PM
  18. Lorraine Clarke's Avatar
    Brilliant. I deleted the old email and set this one up. Works like a charm. Thanks Darwin 158
    02-25-13 06:56 AM
  19. Rick Andy's Avatar
    Thanks Darwin.
    Your suggestion works best for me, but it is not perfect. Every time I bring up the Messages app I get an "Enter Account Password" dialog, which I cancel. When Messages finishes coming up, the Rogers email account may or may not be connected. If it is connected, the connection fails later on.

    To restore the email connection, I do the following:
    1. Open the Accounts.
    2. Select the Rogers email account.
    3. Add a space to the Description and then delete the space. This is just to enable the Save button.
    4. Press the Save button.
    The connection to Rogers email is restored.

    Any help would be appreciated.
    03-12-13 12:05 PM
  20. Menthol86049's Avatar
    Thanks Darwin. Worked for me.

    Can I set it that when it open it shows one acount instead of all acount
    Last edited by Menthol86049; 05-26-13 at 09:28 AM. Reason: Add ?
    05-26-13 09:22 AM
  21. Kokee51's Avatar
    Thanks for the help with this. It has been so frustrating trying to set up my Rogers account using POP. Much appreciated !!!
    08-17-13 09:19 AM
LINK TO POST COPIED TO CLIPBOARD