1. jsilvey2351's Avatar
    A friend has a BB 8330 that is about 3 1/2 years old. When searching app world the Blackberry Bridge is not even offered. Is this due to the fact that his BB is so old? Does anyone know if you can bridge with the 8330? If he doesn't have the most recent software loaded, would this solve the problem? His wife has an 8530 and it works fine on hers (1 1/2 years old compared to 3). Any help is greatly appreciated.
    12-28-11 10:16 AM
  2. BuzzStarField's Avatar
    A friend has a BB 8330 that is about 3 1/2 years old. When searching app world the Blackberry Bridge is not even offered. Is this due to the fact that his BB is so old? Does anyone know if you can bridge with the 8330? If he doesn't have the most recent software loaded, would this solve the problem? His wife has an 8530 and it works fine on hers (1 1/2 years old compared to 3). Any help is greatly appreciated.
    You assumption is correct - you must be running OS5 or later to be able to load the Bridge app on your device.

    My son is using my old 8330 and it is bridged to his Christmas present. The trouble is, only one or two carriers have a version of OS5 suitable for the 8330. And it only works with some versions of the phone.

    If you do a search on CrackBerry, you find find instructions for downloading OS5 for Boost mobile and installing it on your device. Please note that this solution is appropriate if you are fairly comfortable with technology and are willing to take the risk (llimited perhaps) of bricking your Curve. You should also know that available memory for apps is extremely limited after installing the new OS and some apps do not work at all. My son has facebook, twitter an BBM loaded so he is happy. It's a biut of a pain to install, but OS5 has been running on the device for the last year with absolutly no problems.

    There are people in the 8330 forum that can be of further assistance if you need it. Good luck.
    Spencerdl and jsilvey2351 like this.
    12-28-11 10:54 AM
  3. Spencerdl's Avatar
    Just to add to previous post, you stated in your title that the 8330 is a Sprint device. Sprint does have OS5 for the 8330 however be aware of memory issues
    jsilvey2351 likes this.
    12-28-11 11:04 AM
  4. cleveland216's Avatar
    I gotta be the bearer of good news, huh?!?

    I have 8330 on Sprint running OS5, Bridging to PB and VERY HAPPY!!

    First you have to find the official Boost Mobile OS5 update (5.0.0.483). Delete some XML file on your PC. Run the update exe file, and enjoy OS5 on Sprint. Instructions are somewhere on the Net

    I have to confess though, I have a 9930 in hand, contemplating whether to take it back to the store. I was upgrading because the curve is so slow on OS5, as well as its 3G compared to the 9930's 3G. However if I decide to keep the 9930 my bill will grow an extra $23 a month.

    My decision is ultimately to go back to 8330. It works very well under Bridge and it's not that slow. It's bearable. You will LOVE it

    Thank me later
    BuzzStarField and jsilvey2351 like this.
    12-28-11 11:20 AM
  5. jsilvey2351's Avatar
    Thanks a lot fellow CB members. I have already forwarded the link on.
    12-28-11 01:31 PM
LINK TO POST COPIED TO CLIPBOARD