1. brhilaire's Avatar
    Is it just me or does it seem like the battery life under OS 2.0.1.688 has diminished significantly? My playbook sometimes remain idle and the bars just keep dropping as if I was watching a movie on it. Since OS 2.0.1.688, I've had to charge my battery like 2-3 times a day.
    09-03-12 06:04 PM
  2. jon3578's Avatar
    same here i just upgraded to 840. as soon as i got the 668. my battery life was cut in half id say. if i went to bed with %50 and put the pb in stand by it wouldnt even turn on in the AM. i went from charging every other day to more than once a day.
    i suggest roll it back or go with 840.
    09-03-12 06:38 PM
  3. FF22's Avatar
    If you have Hotmail on the native email, that has been implicated in battery drain.
    09-03-12 08:25 PM
  4. stackberry369's Avatar
    I have had no problem with battery life since upgrading.try dimming the light.
    09-04-12 12:07 AM
  5. brhilaire's Avatar
    I have a feeling it's related to the led lights on my email accounts. But surprisgnly, even during standby mode the battery runs down quickly.
    09-04-12 11:32 AM
  6. peter9477's Avatar
    I have a feeling it's related to the led lights on my email accounts. But surprisgnly, even during standby mode the battery runs down quickly.
    LEDs use very little power, so this seems unlikely, but if you want to check it out, go into the Settings and change the notification to "Glow Only". That won't use any power at all, so if your consumption changes then I guess you were right.
    09-04-12 11:43 AM
  7. brianatbb's Avatar
    same here i just upgraded to 840. as soon as i got the 668. my battery life was cut in half id say. if i went to bed with %50 and put the pb in stand by it wouldnt even turn on in the AM. i went from charging every other day to more than once a day.
    i suggest roll it back or go with 840.
    what is 840?
    09-04-12 12:54 PM
  8. peter9477's Avatar
    what is 840?
    The latest beta...

    https://developer.blackberry.com/devzone/register
    09-04-12 01:10 PM
  9. mufc_Nick.C_mufc's Avatar
    When i went to the 2.0.1.688 my battery was a lacking a bit but it is all ok now
    09-04-12 04:16 PM
  10. jtyk's Avatar
    When i went to the 2.0.1.688 my battery was a lacking a bit but it is all ok now
    I have the same problem since i switched to update 840!my battery is quickly depleted!
    09-07-12 02:50 AM
LINK TO POST COPIED TO CLIPBOARD