1. Eskibo's Avatar
    Hi guys

    Last night when I turned on my Playbook the screen was completely messed up. Anyone here know what might have happened? I have not dropped it or anything - nor has anyone else, since I live alone. Check out the pics below
    09-23-12 03:09 AM
  2. Eskibo's Avatar
    Its hard to see, but you can barely make out the icons etc. Sometimes the screen is a little less white and there is a constant slight flickering.
    It also seems like the picture "imprints" itself to the screen. Eg when I start it up and get the startup screen, I can see icons, battery indicator etc.
    09-23-12 05:17 AM
  3. MrNutt's Avatar
    What happens when you adjust the brightness?
    09-23-12 05:27 AM
  4. Eskibo's Avatar
    The fuzzy whiteness remains, but goes from being dark greyish to bright white. By doing this I also noticed the color (the little you can make out) goes from looking like photo negative to "normal" as i slowly move the slider back and forth.
    09-23-12 07:36 AM
  5. Ishaq786's Avatar
    That needs a repair job. Hardware is messed.
    09-23-12 07:53 AM
  6. Eskibo's Avatar
    Im afraid you might be right. Strange how it can mess itself up just like that. Playing a bit more with the brightness slider makes it improve a little( but still bad), but everytime i press the power button to switch the screen off and then on again makes it go back to bad.
    09-23-12 07:59 AM
  7. FF22's Avatar
    Have you tried restarting it:

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.
    Eskibo likes this.
    09-24-12 12:39 AM
  8. Eskibo's Avatar
    I've tried the three button method, but not the others. Will give them a go once I get home from work and let you know what happens
    09-24-12 03:31 AM
  9. Eskibo's Avatar
    Alright, tried everything and none of it remedied the problem.
    09-24-12 09:03 AM
  10. FF22's Avatar
    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    Eskibo likes this.
    09-24-12 10:26 AM
  11. bunty_hoven's Avatar
    My Playbook's screen was also playing up recently, I phoned up RIM support, they made me re-install the OS & perform a security wipe to rule out the issue being caused by a software issue. After doing this, they sent out a Fedex box for me to return the playbook back to one of their repair centres. The issue was indeed hardware related and they replaced my unit with a new one (I'm not sure whether its a refurb).

    The whole process was really quick - reported the issue a week last Friday, Fedex'd the playbook out on the Monday and got it back the following Thursday.

    I've seen other playbook owners reporting the same issue, I hope this was a dodgy batch, rather than a floor in the playbook's video architecture, as I've only got 4 months left of my warranty...
    Eskibo likes this.
    09-24-12 11:35 AM
  12. Eskibo's Avatar
    Thanks to the both of you. Its encouraging to know things probably will go smoothly getting this sorted with RIM.
    Time to give them a call...
    09-25-12 01:54 AM
LINK TO POST COPIED TO CLIPBOARD