1. new_tradition's Avatar
    Hiya, I just registered, and I admit it was only for this problem, but I hope I can get some help.

    I was the middle of some browsing on my Playbook (truthfully, I've just been using it for web surfing and writing/editing documents) and all of a sudden, the screen looked like this:


    (I've noticed the colours actually changed a bit, so it's not always red. Sometimes it's black and white, blue and white, etc)

    I honestly do not know how looking at a text web page caused this to happen O_o

    (I should mention this actually happened about 1-2 months ago, but I didn't do anything about it because I'm lazy >_>)

    Anyways, I've done hard and soft resets, I've used the desktop tool over and over, but the screen still looks like the above. I've been prompted to finishing setting up my playbook after the updates from the desktop tool, but of course, I can't do squat if the screen looks like that :X

    Before this happened, it was updated to OS2 for a while, and I downloaded some apps, but I never really used them

    I'm kind of at my wits end. I emailed RIM, but I get an auto response that basically said they weren't going to help me. I even entered the serial number, but the site said it didn't qualifying or something. I bought this in December 2011 from Futureshop, and I never got a warranty or anything, so I'm stuck with this defective unit D:

    At this point, if the only way to fix this is by rooting, I'll honestly consider it. Like I said, I've just been using this for web browsing more than anything.

    Thanks~
    06-14-12 02:13 PM
  2. robsteve's Avatar
    You need to call RIM to get warranty support. Email usually doesn't work unless you have the case ID in the subject line. If you bought it in December, it will still be under warranty. Just call RIM and be prepared to provide a receipt in case your serial number was not input into their system properly.
    06-14-12 02:18 PM
  3. Chaddface's Avatar
    I would call RIM instead of emailing. If you bought it new in December then you still have a warranty despite what that automated system says.
    The warranty is one year from date of purchase.
    06-14-12 02:19 PM
  4. FF22's Avatar
    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    06-14-12 02:59 PM
  5. narci's Avatar
    I would call RIM instead of emailing. If you bought it new in December then you still have a warranty despite what that automated system says.
    The warranty is one year from date of purchase.
    Warranty is beyond the 1 year...for now.

    I just RMAd a PB that was past wrranty period and the RMA rep told me they are warranting PB past the 1 year period.
    06-14-12 05:29 PM
  6. afdfirefighter77's Avatar
    Try taking a screen shot with the volume buttons, then pulling the image via the computer. If it comes out normal looking, its a hardware issue. If not, its probably software.
    06-14-12 08:54 PM
  7. new_tradition's Avatar
    Thank you guys for the info! I had no clue about the 1 year warranty. Big sigh of relief from me, haha.

    Try taking a screen shot with the volume buttons, then pulling the image via the computer. If it comes out normal looking, its a hardware issue. If not, its probably software.
    I'm able to take screen shots, but my PC isn't recognizing my Playbook so I can't even open the storage to look at them D:

    Is it because I had been doing the soft resets? I'm getting a message at the bottom of my screen that set-up isn't completed...
    06-19-12 02:57 PM
  8. Cracklen's Avatar
    "...I had no clue about the 1 year warranty. Big sigh of relief from me,.."

    Mentioned in at least one, of those inserts/manuals in the flat box next to the box with your stock charger and usb cord !

    And if you pruchased with a cc with extended warranty prog. of 1 additional yr thru the cc programs' underwriter !

    nite
    06-19-12 11:50 PM
  9. h20work's Avatar
    Hiya, I just registered, and I admit it was only for this problem, but I hope I can get some help.

    I was the middle of some browsing on my Playbook (truthfully, I've just been using it for web surfing and writing/editing documents) and all of a sudden, the screen looked like this:

    Click to view quoted image

    (I've noticed the colours actually changed a bit, so it's not always red. Sometimes it's black and white, blue and white, etc)

    I honestly do not know how looking at a text web page caused this to happen O_o

    (I should mention this actually happened about 1-2 months ago, but I didn't do anything about it because I'm lazy >_>)

    Anyways, I've done hard and soft resets, I've used the desktop tool over and over, but the screen still looks like the above. I've been prompted to finishing setting up my playbook after the updates from the desktop tool, but of course, I can't do squat if the screen looks like that :X

    Before this happened, it was updated to OS2 for a while, and I downloaded some apps, but I never really used them

    I'm kind of at my wits end. I emailed RIM, but I get an auto response that basically said they weren't going to help me. I even entered the serial number, but the site said it didn't qualifying or something. I bought this in December 2011 from Futureshop, and I never got a warranty or anything, so I'm stuck with this defective unit D:

    At this point, if the only way to fix this is by rooting, I'll honestly consider it. Like I said, I've just been using this for web browsing more than anything.

    Thanks~
    My 64gb started doing this exact same thing yesterday. I'm able to do the three finger salute and reboot, it works for a little while then goes back to a mostly black screen with the lines in it. Glad I packed an extra pb on this trip. I'm running the official 2.0.1 os on it.
    06-20-12 12:03 AM
  10. h20work's Avatar
    I think the bigger question is why it your camera sticking and led sticking up from the rest of the case and what's up with the corners?
    06-20-12 12:11 AM
  11. jeroen_13's Avatar
    I think the bigger question is why it your camera sticking and led sticking up from the rest of the case and what's up with the corners?
    What happened to your Top-right corner ?!

    EDIT; it is the Playbook leather case :lol:
    06-20-12 04:04 AM
  12. varunsain's Avatar
    Hey why don't you try closing the images app? haha/.. i guess you need to reboot!
    06-20-12 04:38 AM
  13. new_tradition's Avatar
    ~UPDATE~

    So, uh, another bout of procrastination, but I called RIM on July 11, and we did whatever we could over the phone (basically more hard resets, lol), but nothing helped, so I had to send in my Playbook.

    All in all a very smooth process. After being talked through what was going to happen over the phone, FedEx came July 12th to take my Playbook, and I was able to keep track of what was going on online. Got it back today, just a week later, and it's working like it just came out of the box.

    I still don't know how my problem came about, so I don't know what precautions I should take in the future :/

    Anyways, thank you guys again for reminding me about the warranty. Saved me a lot of grief xD
    07-18-12 11:13 AM
  14. FF22's Avatar
    Glad to hear you finally got around to fixing the issue by having rim fix the issue.

    As for prevention - sometimes electronics just fail which would probably be the case for you pb.
    07-18-12 11:32 AM
LINK TO POST COPIED TO CLIPBOARD