1. pillsy's Avatar
    Had it hooked up to the TV watching NFL, got a low battery warning so I moved it over to the rapid charger. No problems for like an hour. Then the sound went out. Assumed it was something with the website I was using to watch games. Next thing I notice the screen goes completely dark and it's unresponsive. Press the power button...nothing happens. Volume +/- and power button to reset...nothing happens. Completely unresponsive thus far. I checked the power source to make sure it was getting juice. Outlet is fine, charger base is plugged into the cord fine. Is there a fix for this?
    10-20-13 05:56 PM
  2. Chaddface's Avatar
    Did you try the USB charger that came with the PB yet?
    Sometimes the rapid charger doesn't work for me.
    10-20-13 06:01 PM
  3. milo53's Avatar
    You held the 3 buttons for 30 secs? I think it takes that long. Or, when charging there are zero lights on? No slow flashing lights? If nothing, wait 1 hour and try all again, if nothing it's probably hosed. I just had exact same thing occur on Panasonic Toughbook at my job, nothing worked and no lights. The motherboard was hosed.
    10-20-13 06:10 PM
  4. pillsy's Avatar
    I had to get the rapid charger because the USB port stopped working about a year ago. Rapid charger has worked fine ever since.
    jpash549 likes this.
    10-20-13 06:11 PM
  5. milo53's Avatar
    Yes, forgot...try micro usb connection to charger and, or PC-Playbook, search for any life.
    10-20-13 06:12 PM
  6. jpash549's Avatar
    I had to get the rapid charger because the USB port stopped working about a year ago. Rapid charger has worked fine ever since.
    Is it the pod or the rapid travel charger? With either the pins couldd fail to make contact allowing your battery to drain. No flashing lights is certainly bad andyou certainly should get a signal if it is a low battery issue.

    http://btsc.webapps.blackberry.com/b...ListHelperImpl

    Sent from my Nexus 7 using CB Forums mobile app
    10-20-13 06:46 PM
  7. Chaddface's Avatar
    Try cleaning the contacts. If you have the ability, check the voltage on the charger. Should be about 12 volts between the outer two pins.
    10-20-13 08:05 PM
  8. pillsy's Avatar
    Ok, looks like it was just a dead battery and it wasn't charging for whatever reason. Cleaned the contacts on the rapid charger and the PB pins, plugged it into another outlet (overnight one) and the red light came to life. Charging now as we speak.

    CRISIS AVERTED! Thanks all.
    FF22 and dphjeff like this.
    10-20-13 08:42 PM
  9. FF22's Avatar
    On occasion the rapid charger gives what I call a False Lightning Bolt - it will show charging but if the contact is not complete, it may not actually be charging. I generally try verifying with Battery Guru.
    10-20-13 09:03 PM

Similar Threads

  1. Just bought a used 9860 for fun, will it be fun?!
    By johnnyuk in forum BlackBerry Torch 9860/9850
    Replies: 28
    Last Post: 11-26-13, 03:52 PM
  2. Is it my Playbook thats playing up or crackberry?
    By sad_old_man in forum BlackBerry PlayBook
    Replies: 409
    Last Post: 11-21-13, 06:26 AM
  3. Getting my 9310 tomorrow
    By jackm3 in forum BlackBerry Curve 9310
    Replies: 15
    Last Post: 10-29-13, 06:21 PM
  4. 9320's OS7.1 Firmware just not working at all, need major help.
    By SleezyEdits in forum BlackBerry Curve 9220/9320
    Replies: 2
    Last Post: 10-21-13, 02:11 AM
  5. My lockscreen has gone
    By uktivo in forum BlackBerry Z30
    Replies: 1
    Last Post: 10-20-13, 11:57 AM
LINK TO POST COPIED TO CLIPBOARD