08-30-12 01:39 PM
34 12
tools
  1. Chuck3661's Avatar
    64GB PlayBook with dead batt. bought Nov. '11 and the battery wend dead May, 2012. I mean that I had it on the charger for a few days (I was out of town) and when I got back the LED was blinking red slowly. The PB won't turn on. Does anyone have any idea how to fix this?
    08-28-12 01:35 PM
  2. JeepBB's Avatar
    I see stack charging in your future.

    If you haven't used it since May, it's likely that the battery is completely flat. The PB battery (unfortunately) isn't like a phone battery where you can just connect a charger and re-charge it after years lying in a drawer... it has to have some residual charge or it won't recharge.

    It probably seemed a good idea at the time to some bright spark in RIM - but hopefully BB10 battery management will be re-engineered away from such a stupid idea.

    I'm sure my friend F2 won't mind if I steal his words below. Good Luck!

    ++++++++++++++++++++++++++

    I will simplify the search - here's the various Stack charging methods. Try one, try all. Try in any order:

    Okay, try any and all of the various methods, including just holding the power button in for 30-40 seconds. Also go into a dark closet and make sure the screen is really black/off and not a lit up gray.

    I was told about "stack" charging, 6 cycles of charge no charge, for 2 minutes each, charging for never more than 2 minutes.


    Plug the PB in with the factory charging cable (red light comes on for a several seconds, then goes off). Wait about 10 more seconds. Unplug PB for about 30 seconds.

    Repeat n times.

    n == 6 for me. Finally my PB light switched to green, then began to oscillate, signalling charging. After a few more minutes my PB came back to life.

    You might want to UNplug/Replug at the wall/socket end to avoid using or damaging the weaker usb port on the pb itself.


    Just talked to tech support, because i'm impatient sometimes. Here is the initial process they gave me to try.

    Plug in the charger for 2 mins, unplug for 10 sec -> Repeat 6 to 8 times

    Then while unplugged perform the Hard reset (POWER, VOL + and - at the same time) . **When the red light comes on PLUG IN THE CHARGER**

    The playbook is supposed to then start charging/boot.
    ...........................
    Along the same lines as just above, someone posted:

    FOUND A QUICK FIX HOPE IT HELPS

    WOW, i tried EVERY SINGLE Step out there and the one step that worked ... was HOLDING down the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear.. the it will charge with just a flashing green..... lol wasted 4 hrs for nothing hope this works for everyone else

    .................
    Some have now found a shorter sequence works:

    Oh man I fixed it. I stack charged it! But not for 2 minutes.

    Every time my PB red signal goes off I removed the connection from the wall charger and placed it back within a second. I repeated it for almost 25-30 times and all in the sudden a big charger button showed up on the screen and a green light on the charging LED. I left th e power connection for 2 more hrs and started using it.
    ................
    And another posting that might help....

    There are a few solutions and some are mentioned above. SO try the things I am mentioning below.... Let me know if it works .

    Problem Scenario: 1. Blackberry wont boot or turn on, on pressing the power button, the red light stays for a few seconds and does not turn on 2. Sometimes you will see the red light followed by a green/ yellow light that blinks 5 times and does not turn on.

    Reason: The main reason why both of the above things happen is because the battery is completely drained out, you could call it " Flat out". The problem with playbook is that the playbook wont charge if the playbook is Flat out drained. whereas other tablets or cellphones does....Playbook has to fix that issue. Meanwhile we do have a solution to go around that problem and that requires some patience. Some of the solutions mentioned in the previous comments indicate to charge it via computer.... "It doesn`t work" not if the battery is drained out flat.... so dont even bother trying it if u see the above mentioned problem.

    Solution: try this step by step and this are 3 different solutions so one of this would definitely work. 1. Press the Power button and you will see the Playbook Logo ( chances for this are low ) 2. Press the power button and the volume together, if there is 1 % charge left there is a chance that it would boot on, when you see the logo, immediately charge the playbook ( chances are medium ) 3. This solution requires patience. plug the charger into the socket and plug the USB into the playbook, the red light stays for 8-10 secs. Remove the USb from the playbook wait for 2 to 5 sec and replug the usb back to the charger and wait till that red light comes and goes again. repeat this step atleast 20-30 times. you might be asking why? the only power that the playbook gets is when that red light is on when plugging the usb into the playbook, once that light goes the playbook is not charging.. so what you are doing here is forcing the playbook to get charged for 8 sec every time u plug it to the playbook....this way the playbook gets that power needed to boot. Once the Playbook has that power to boot. The red light stays and changes to green but this time it blinks slowly and keeps blinking. you would also see the playbook logo return.... this green light keeps blinking until there is enough charge for the playbook to stand on its own and then changes to a solid red until it gets fully charged.

    Knowledge Base Article

    KB27705-BlackBerry PlayBook Power - Battery charge and discharge characteristics
    08-28-12 02:17 PM
  3. FF22's Avatar
    Jeep, old man, do I really post that long of a narrative!!!????!!! My, my, I do need an editor.

    Or is that editour?

    "Bright spark" and "Rim", hmm, in the same sentence? I do wish that Kevin or one of the wunderkinds would ask why they went with the oddball charging system.
    Last edited by F2; 08-28-12 at 05:21 PM.
    JeepBB likes this.
    08-28-12 05:18 PM
  4. anon5129477's Avatar
    ebay your old old one for parts and you got lots of beer money
    08-28-12 05:32 PM
  5. JeepBB's Avatar
    Back on-topic (sorry, I think I was one of those who derailed the OP's thread! )...

    I recently had an RMA too and was also surprised by the level of the flat fee for repairs. I had already decided that if the verdict had been to charge for the repair, I was going to ask RIM to send it back unrepaired and I'd put it on eBay. Faulty PBs sell on eBay for almost as much as working ones (maybe 25 difference for a PB with case and often a rapid charger as well). Sellers can't ask for any more because you can go to a shop and buy a brand-new boxed PB for not much more.

    To be fair, I reckon a lot of the flat fee covers the FedEx costs there and back (UK <-> Germany, in my case) on which RIM takes the hit... but the difference between the repair fee and buying a new PB isn't a lot these days given the huge discounting going on.
    08-29-12 03:07 AM
  6. CanadianBB's Avatar
    I am having a hard time understanding why the faulty usb port would not be warranty?

    My PB just went out yesterday. It is 6 months old and having issues with it such as: it is fully charged by the way. Whenever I put it in stand by or it goes into stand by I cannot get it back on. I end up doing about 6 or 7 or 20 restarts before it finally kicks in. I did the Desk top Debrick thing 3 times and once of course with Rim on the phone as they did not believe I could do it. lol

    When the repair bill form came in for me to send back: Said Battery dead. I wrote half a page explaining what was really happening.

    Now my concern is 2 things: Does loading the Beta Void your warranty?
    If it is in the 1st year it should automatically be warranty? Shouldn't it?


    Brian
    08-29-12 03:15 PM
  7. FF22's Avatar
    You should still have a warranty. And while software (beta OS) might screw up its running, it should not physically damage the pb.
    08-29-12 07:30 PM
  8. Cracklen's Avatar
    Good luck with this
    08-29-12 07:50 PM
  9. b-dubya's Avatar
    Update...

    Checked the status of my PB today and it was on the FedEx truck this morning for delivery but since I wasn't home, they are going to redeliver it tomorrow (I have a pre-planned vacation day so I'll be there for delivery). For some reason, FedEx fails to just take my packages to the leasing office if I'm not home (USPS and UPS always does) and leave it with them.

    That being said...still waiting on my refund from the repair facility. BB has sent a couple of messages to the repair facility telling them that RIM is picking up the tab on the repair but the facility is the one who needs to put the credit through and they haven't heard back yet. I'll give it until Monday to be acknowledged that it will be processed...if that doesn't happen, I'll call my bank and dispute the charge to force their hand a little.
    08-30-12 01:39 PM
34 12
LINK TO POST COPIED TO CLIPBOARD