1. Revampd's Avatar
    I have had my Playbook for a year and have loved using it but feel pretty lost when it comes to it's "innards". I'm a techie (by trade) and have been all my life. I can do ANYTHING with a PC but have always felt afraid to delve into the Playbook... till now.

    I finally decided (because of problems with the camera which I couldn't fix) to reinstall/update my software using desktop manager software. I was running .668 and after the 1MB update, didn't like it much. I have (twice) reinstalled using DM and I'm now running 2.0.1.358. Why it chose that I'm not sure.

    I have a feeling that I haven't really "completely" reinstalled. DM used words such as "Update" and "Repair".
    My basic question is this... Is there an equivalent to Fdisk for the Playbook? Can I wipe down to the rock bottom of the hard drive (flash drive? I dunno) and reinstall, perhaps choose which operating system I want?

    I can do these things easily on my PC. I can find drivers to load old OS's on new computers, new OS's on old computers. I am so lost on this Playbook, which I love dearly and as a techie that bothers me greatly.

    I have searched the forums till my fingers ache () but have come away frustrated. I know that you techies out there will be able to point me in a direction. Now that I've taken the plunge and begun to really tinker, I'm willing to go deep.

    Thank you all in advance for any help you can give.
    farside33 likes this.
    09-29-12 09:46 AM
  2. kbz1960's Avatar
    The OS on it is the latest official, they pulled the .668

    There is no way that I know of to completely erase everything on the drive like a format. Maybe the old rooters know of a way with cfp or another program but I with the boot loader being locked not sure about that.
    09-29-12 09:54 AM
  3. Revampd's Avatar
    Thank you for the quick reply. I so love these forums. Yes, that explains the .358 install. The reason I don't think that I've really "completely" wiped the old stuff is because of the camera problem which is still there after two reinstalls.

    The camera app will load but... no camera. Just a dark screen. I would suspect hardware except for the fact that after the reinstall, when opening the camera app for the first time (and only the first time) I got a message stating "The camera is in use. Close any other instances of the camera and try again." Also I can't even do a screen capture. Not even the camera "click" is there. Seems like software to me.

    Again, thank you for the quick reply
    09-29-12 10:00 AM
  4. FF22's Avatar
    You might call Rim. They seem to know that there is a Camera Issue but I'm not sure that they've identified what causes it.

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    09-29-12 10:09 AM
  5. annon91221's Avatar
    Most mobile computing such as phones and tablets are very different than PCs. All playbooks come with same harware, therefore BB releases software and drivers bundle that works on all playbooks. You can't change any hardware therefore no need for specific drivers..
    Regarding issue with your camera, if it is giving you problems contact BB customer support.

    P.S...if you like tinkring with playbook, check out playbook rooting forums, it is where programmers try and take full control of hardware, but as far as I know they haven't had much luck yet...BBs are famous for security...
    09-29-12 10:09 AM
  6. Revampd's Avatar
    Thank you both! I wasn't aware that there was a "camera issue" with the Playbooks. But it does make me feel better that I might not be the only one. I can live without the camera. It's not often that I've used it on the Playbook anyway. Perhaps with BB10, it will be resolved

    I will most likely begin to look into the rooting and such. But I use my Playbook every day. Maybe time to buy another for "experimenting". Sure... all I needed was an excuse to get another... lol.

    On a side note, I really hope that RIM hits a home run with BB10. These are such great products and I am a very loyal customer.
    kbz1960 likes this.
    09-29-12 10:20 AM
  7. kbz1960's Avatar
    Even if you're out of warranty RIM has done a repair or replace for some. Maybe depends on how nice the person calling is?
    09-29-12 10:47 AM
  8. BB_Bmore's Avatar
    There is a program called "cfp" that allows you to load your choice of OS. If you do a search you will find how it works. Good luck.
    09-29-12 11:08 AM
  9. frisco49ers's Avatar
    I had the same problem with my camera, they took it back and fixed it, was gone for 5 days, back good as new.
    09-29-12 12:15 PM
  10. kill_9's Avatar
    I wasn't aware that there was a "camera issue" with the Playbooks.
    My personal-use BlackBerry PlayBook is running BlackBerry Tablet OS 2.0.1.358 and I just checked the camera and video camera functionality. I could not reproduce the issue. When you reinstalled the software onto the tablet did you perform a security wipe in advance and after the installation did you restore anything from a backup? On opening the camera application it took my tablet approximately 5 seconds to transition from black screen to seeing an image of screen captured by the rear-facing camera.

    If the camera continues to malfunction, contact BlackBerry PlayBook Support for yoiur free 90-day technical support and 1-year warranty manufacturer coverage.
    09-29-12 12:17 PM
  11. ryacht's Avatar
    Just a general remark - I noticed as well that most modern devices dont give you as much access to the filesystem, OS settings etc. as it has been on pc s. even those tend to restrict. see mac computers or win 7 or 8. win offers you libraries so you dont really know where you file is - if on your pc at all (cloud).

    a trend unwelcomed by us techies

    ray
    09-29-12 12:56 PM
  12. nomloj's Avatar
    I've had the very same issue with my camera. Only thing is, the rear camera worked just fine but the front camera was a blank dark screen. If I swapped cameras, it took a LONG time before I could get any functions to appear. Once it was back on the rear camera, it was ok. I started noticing error messages and timeouts taking videos on the rear camera, though. Tech support had me do a security wipe, but it didn't help. A re-install didn't work, either (to fix the front camera). Sure enough, they had me send it in with a written description on the RMA. They sent me a new replacement instead (different serial number). Some folks have said their's was just fixed and returned. Most likely, you have one of the older batches with the non-raised power button that could be causing the issue. There was a post about tearing the Playbook apart to raise the button, but not sure how deep you want to dive into the hardware. I myself operate in the hardware support field, and am loathe to taking mobile devices apart due to less experience with them. As we say, if it ain't broke, don't fix it (hardware wise). Give tech support a call... they may just get it fixed for you.

    Edit: forgot to mention that you could always reformat while attached to the computer. BUT, seeing as how this will destroy all data on there and cause Desktop Manager to no longer recognize it as a BB product, best to stay away from the reformat route. Don't think there's any easy way to get a hold of the OS without that recognition from Desktop Manager.
    Last edited by nomloj; 09-29-12 at 01:04 PM.
    09-29-12 12:59 PM
  13. jpash549's Avatar
    Better get the camera issue fixed. Seems like it would be a good idea to register a warranty issue with RIM and quit trying to solve with software yourself. You may not use the camera much now but it can be really useful. And if you cant take screenshots that is really troublesome. And if you can get a decent deal for sure buy another or two. As a techie you need plenty of equipment. And be sure to get a couple of rapid travel chargers for use with the pogo pin magnetic charging port. Also do you have any indication of something else running. This would seem unlikely with all the reinstalling you have done. You don't mention battery problems but I assume you have Battery Guru and have checked that for normal operation. And you should have Ghost Commander and Advanced Application Manager to help check Android apps. You mentioned the brief notice about control of camera which is why I bring this up. Ah the mysteries of life and all those zeroes and ones.
    Last edited by jpash549bb; 09-29-12 at 03:27 PM.
    09-29-12 03:11 PM
  14. FF22's Avatar
    I agree with jpash....

    Call now and, at least, register the camera issue and suggest you might wait till the OS update but still get it on record. I don't think an OS change will fix it. For some reason, once it goes missing, it appears there is NO user fix.
    09-29-12 04:30 PM
  15. snow_stipple's Avatar
    Revampd,

    Does the camera work when you use AOL AV?
    rxdude likes this.
    09-29-12 07:38 PM
  16. Revampd's Avatar
    Well, thank you all so very, very much. Right after I posted the last I went out for the day. I just got home to a plethora of advice .

    To those who recommended calling RIM, I will do that on Monday (and I'll be as nice as I can ). Again, it's good to know that I'm not the only one who has experienced a camera problem. I have never seen the power button on another Playbook but mine is definitely flush with the case and not easy to push. If I have to send it in I will, but major withdraw will ensue. Probably best to get another first. I never realized how much I use my Playbook till I had to wait for it to reinstall earlier!

    I will look for the cfp program. It's time to get into how this pretty little piece of hardware works. I did perform a security wipe, by the way, before the second time I reinstalled and I had the same results. As for restoring data after the backup, I couldn't do that because I had been running .668 before the reinstall and the DM informed me that I couldn't do that as the data was incompatible with .358. Not a biggie really, I had saved my files to my PC with simple drag n' drop. But whatever else was saved wouldn't go back.

    Yes Ray, I agree completely. Microsoft has been "moving us away" from the bottom end of the OS ever since 3.1 (oops, just gave away my age) and I don't like it at all. I refuse to go past XP for that reason. We had to do everything by hand in the old days and yes it took a bunch of learning, but I feel that it gives a good foundation for operating a PC. For myself it helps put a good mental image in my head of what's going on under the hood. Do the owners of Win 7 PC's even know what a file extension is or what it's for? It's not necessary to know I suppose but for me knowing the "why" of things is as important as the "how".

    Once again, thank you all for your replies. I rarely post in these forums but I read them every day. You guys are the best!
    09-29-12 07:45 PM
LINK TO POST COPIED TO CLIPBOARD