1. chuckkdaduck's Avatar
    We'll I've tried looking through the forums with playbook wont charging properly but couldnt find any in my situation.

    My playbook is currently sitting at 50% left before its dead. I've tried to plug in the charger to the playbook but it doesnt charge at all. It doesnt show the charging symbol on the battery icon when I plug it in. I've tried numerous times unplugging and plugging it back it with no success. So i tried a different playbook charger (my moms playbook) and it does the same thing doesnt charge and NO charging icon (the lighting symbol on the battery icon).

    I thought this was really weird so I plugged my playbook with my blackberry charger and shows that it is charging? well it shows the "its connected symbol" on the battery icon. So im not sure if its both my playbook chargers or my playbook that cant detect it???

    Any suggestions? need help before 50% is gone!! thanks!
    09-01-12 07:05 PM
  2. kbz1960's Avatar
    Three finger salute.
    09-01-12 07:08 PM
  3. Ben1232's Avatar
    Broken micro USB socket ? Try a rapid charger / dock.
    09-01-12 07:18 PM
  4. flybabyroxy's Avatar
    have u tried rebooting it? my 9930 does the same thing sometimes til I reboot.
    09-01-12 07:20 PM
  5. chuckkdaduck's Avatar
    have u tried rebooting it? my 9930 does the same thing sometimes til I reboot.
    yup ive tried to reboot it but with no luck. Im doing a repair on it right now with DM and hopefully a wipe will work. I hope its a software thing and not a hardware thing :S
    09-01-12 07:35 PM
  6. chuckkdaduck's Avatar
    So I wiped my Playbook and still wont charge?!? I have 40% left of battery. I've tried both chargers on my Mom's playbook and with ease it chargers her playbook.

    What's also weird is that the Playbook chargers dont also work on my curve 9360?!? gives me a message that it cannot connect.

    Need some ideas guys!
    09-01-12 08:13 PM
  7. FF22's Avatar
    Look inside the usb port. There is a "board" in there that should be level and not bent up or down. If bent, you might try GENTLY leveling it again. Have you tried another socket in the house? Her's does NOT work on your either? You mentioned some charger working " a bit"

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    09-01-12 08:39 PM
  8. kretch's Avatar
    Will it connect to DM with a usb cable?

    You also need to try a rapid chrger.
    09-01-12 08:47 PM
  9. badtoy1986's Avatar
    I am having the same issue. It will not charge via stock charger or two other USB chargers and cables including my iPad charger. However, I just plugged it into my computer via the USB cable. It is showing its taking a charge.

    When I use the stock charger it does nothing. When I use my iPad charger with another microusb cable I get the red light for about 10 seconds then the light turns off. This is only when it's powered off. I get nothing when it's on. The port looks perfect.
    09-09-12 11:01 PM
  10. louzer's Avatar
    A normal phone charger might not be providing enough juice to the Playbook to charge. Try connecting your Playbook to your computer via a powered USB port. This should provide a charge. If so, this buys you some time and I'd recommend the rapid charger. It uses the magnetic port on the bottom of the Playbook. USB ports are notorious for going bad over time because of the tension every time you plug/unplug it. I've been using the rapid chargers exclusively for quite a while now with great success. And they charge the Playbook in about half the time.
    09-09-12 11:19 PM
LINK TO POST COPIED TO CLIPBOARD