1. neel69's Avatar
    my PB is struck at the same charge even after charging for hours..Its connected to the mains with the charger present in the kit...The bolt sign is present..but its showing the same percentage...help..
    08-02-12 08:32 PM
  2. kbz1960's Avatar
    I don't know, UK?, plug have the blades that flip? If so unplug it, flip them a couple times and plug it in again.
    08-02-12 08:37 PM
  3. neel69's Avatar
    na..India..after connecting to the mains its showibng the bolt sign...But still its stuck in the same percentage... :-(
    08-02-12 08:48 PM
  4. kbz1960's Avatar
    Sorry, I thought "kit" was a word those Brits say. Have you tried to turn it on? Or hold the power, +, and - buttons all at the same time to boot it? Hold just the power button for 30 seconds or so?

    Just things to try.
    08-02-12 08:53 PM
  5. jpash549's Avatar
    Take usb plug out. Put in standby. Put usb plug in. Does it turn on Playbook? Too bad you don't have Battery Guru. It would tell you if it is actually charging. Other people have reported that the lightning bolt can show without the PB actually charging. Also be sure that the plug is in correct alignment. Believe that the Blackberry symbol should be up when looking at the screeon.
    Last edited by jpash549bb; 08-02-12 at 09:18 PM.
    08-02-12 09:04 PM
  6. neel69's Avatar
    nothing worked..submitted it to service centre(Redington India). Hoping to get it by 20 days.. Too bad that it happened within a month of purchase...
    08-03-12 12:55 PM
LINK TO POST COPIED TO CLIPBOARD